在线检测未来函数

通达信扭曲反转主图指标公式

来源:Internet,编辑:股旁网,2014-07-23

市均价:=((H+L)/2*0.382+(C+O)/2*0.618);
均价:=AMOUNT/(VOL*100);
重心:=IF(INDEXC,市均价,(市均价+均价)/2);
相对高:=(重心*0.191+H*0.809);
相对低:=(重心*0.191+L*0.809);
折价:=(重心*0.191+C*0.809);
DLB:=(((SUM(VOL,3)/REF(SUM(VOL,18),1))+(SUM(VOL,12)/REF(SUM(VOL,72),1)))/2+(SUM(VOL,6)/REF(SUM(VOL,36),1)))/2;
X1:DMA(折价,DLB),COLORWHITE,DOTLINE;
X2:EMA(X1,6)*(1+2/700),COLORWHITE,LINETHICK1;
X3:EMA(X2,12)*(1+2/1300),COLORMAGENTA,DOTLINE;
X4:EMA(X3,18)*(1+2/1900),COLORMAGENTA,LINETHICK1;
X5:EMA(X4,18)*(1+2/1900),COLORYELLOW,DOTLINE;
X6:EMA(X5,30)*(1+2/3100),COLOR00CCCC,LINETHICK1;
X7:EMA(X6,42)*(1+2/4300),COLOR00BB00,DOTLINE;
X8:EMA(X7,54)*(1+2/5500),COLOR00BB00,LINETHICK1;
JJ:=ABS(X1/REF(X1,1)-1);
GG:DMA(X1,JJ),COLOR7F00FF,LINETHICK2;
大:=MAX(X1,MAX(X2,MAX(X3,MAX(X4,MAX(X5,MAX(X6,MAX(X7,X8)))))));
小:=MIN(X1,MIN(X2,MIN(X3,MIN(X4,MIN(X5,MIN(X6,MIN(X7,X8)))))));
ZZX:=(((((X1+X8)/2+(X2+X7)/2)/2+(X3+X6)/2)/2+(X4+X5)/2)/2+(大+小)/2)/2;
多空线:=(ZZX+(X1+X2+X3+X4+X5+X6+X7+X8)/8)/2;
SL:多空线+(X1-X2+X3-X4+X5-X6+X7-X8+(大-小)/4)/5,COLORCYAN,DOTLINE;

通达信扭曲反转主图指标公式

 

相关文章