在线检测未来函数

通达信决策曲线指标公式

来源:Internet,编辑:股旁网,2014-07-29

MA01:=MA(CLOSE,5);
MA02:=MA(CLOSE,8);
P01:=IF(CROSS(MA01,MA02),1,0);
P02:=IF(CROSS(MA02,MA01),-1,0);
P0:=P01+P02;
MA11:=MA(CLOSE,8);
MA12:=MA(CLOSE,21);
P11:=IF(CROSS(MA11,MA12),1,0);
P12:=IF(CROSS(MA12,MA11),-1,0);
P1:=P11+P12;
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
K:=SMA(RSV,12,1);
D:=SMA(K,24,1);
J:=3*K-2*D;
P21:=IF(CROSS(K,D)AND D<20,1,0);
P22:=IF(CROSS(D,K)AND K>80,-1,0);
P23:=IF(CROSS(J,0),0.5,0);
P24:=IF(CROSS(100,J),-0.5,0);
P2:=P21+P22+P23+P24;
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
P31:=IF(CROSS(DIFF,DEA)AND DEA<0,1,0);
P32:=IF(CROSS(DEA,DIFF)AND DIFF>0,-1,0);
P3:=P31+P32;
WR1:=100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,113));
P41:=IF(WR1>80,1,0);
P42:=IF(WR1<20,-1,0);
P4:=P41+P42;
OB:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
P51:=IF(OBV>REF(EMA(OBV,24),1),1.5,0);
P52:=IF(OBV<REF(EMA(OBV,24),1),-1.5,0);
P5:=P51+P52;
BR:=SUM(MAX(0,HIGH-REF(CLOSE,1)),26)/SUM(MAX(0,REF(CLOSE,1)-LOW),26)*100;
AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
P61:=IF(BR>350,3,0);
P62:=IF(BR<45,-3,0);
P63:=IF(AR>180,3,0);
P64:=IF(AR<45,-3,0);
P6:=P61+P62+P63+P64;
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),26);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26);
VR:=100*(TH*2+TQ)/(TL*2+TQ);
P71:=IF(VR>350,3,0);
P72:=IF(VR<45,-3,0);
P7:=P71+P72;
MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);
MAMASS:=MA(MASS,6);
P81:=IF(MASS<27 AND CROSS(MASS,26.5),2,0);
P82:=IF(MASS>27 AND CROSS(MASS,26.5),-2,0);
P8:=P81+P82;
WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,24)/10000;
MAWVAD:=MA(WVAD,6);
P91:=IF(WVAD>0,1,0);
P92:=IF(WVAD<0,-1,0);
P9:=P91+P92;
VOLUME:=MA(VOL,10)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,14),14);
Q11:=IF(EMV>0,1.5,0);
Q12:=IF(EMV<0,-1.5,0);
Q1:=Q11+Q12;
TR0:=EMA(EMA(EMA(CLOSE,13),13),13);
TRIX:=(TR0-REF(TR0,1))/REF(TR0,1)*100;
Q21:=IF( CROSS(TRIX,TR0),1.5,0);
Q22:=IF( CROSS(TR0,TRIX),-1.5,0);
Q2:=Q21+Q22;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
Q31:=IF(RSI>80,1,0);
Q32:=IF(RSI<20,-1,0);
Q3:=Q31+Q32;
OSC:=100*(CLOSE-MA(CLOSE,20));
MAOSC:=EXPMEMA(OSC,6);
Q41:=IF(CROSS(OSC,MAOSC),1,0);
Q42:=IF(CROSS(MAOSC,OSC),-1,0);
Q4:=Q41+Q42;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13));
Q51:=IF(CCI>180,2,0);
Q52:=IF(CCI<-180,-2,0);
Q5:=Q51+Q52;
TR1:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/TR1;
MDI:=DMM*100/TR1;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:=EXPMEMA(ADX,6);
Q61:=IF(CROSS(PDI,MDI),2,0);
Q62:=IF(CROSS(DMI,PDI),-2,0);
Q6:=Q61+Q62;
DPO:=CLOSE-REF(MA(CLOSE,21),21/2+1);
MADPO:=MA(DPO,6);
Q71:=IF(DPO>0,1,0);
Q72:=IF(DPO<0,-1,0);
Q7:=Q71+Q72;
MTM:CLOSE-REF(CLOSE,12);
MAMTM:=MA(MTM,6);
Q81:=IF(CROSS(MTM,MAMTM),1,0);
Q82:=IF(CROSS(MAMTM,MTM),-1,0);
Q8:=Q81+Q82;
MID1:=SUM(VOL*(2*CLOSE-HIGH-LOW)/(HIGH+LOW),0);
CHO:=MA(MID,10)-MA(MID,20);
MACHO:=MA(CHO,6);
Q91:=IF((CLOSE>MA(CLOSE,90))AND CROSS(CLOSE,0), 1.5,0);
Q92:= IF((CLOSE<MA(CLOSE,90))AND CROSS(0,CLOSE), -1.5,0);
Q9:=Q91+Q92;
PSY:=COUNT(CLOSE>REF(CLOSE,1),12)/12*100;
PSYMA:=MA(PSY,6);
R11:=IF(PSY>75,1.5,0);
R12:=IF(PSY<25,-1.5,0);
R1:=R11+R12;
MID2 := MA(CLOSE,20);
UPPER:= MID2+2*STD(CLOSE,20);
LOWER:= MID2-2*STD(CLOSE,20);
R21:=IF(CROSS(CLOSE,LOWER),2,0);
R22:=IF(CROSS(UPPER,CLOSE),-2,0);
R2:=R21+R22;
TYP1 := (HIGH + LOW + CLOSE)/3;
V1:=SUM(IF(TYP1>REF(TYP1,1),TYP1*VOL,0),14)/SUM(IF(TYP1<REF(TYP1,1),
TYP1*VOL,0),14);
MFI:=100-(100/(1+V1));
R31:=IF(MFI>80,1,0);
R32:=IF(MFI<20,-1,0);
R3:=R31+R32;
VARA:=R1+R2+R3+Q1+Q2+Q3+Q4+Q5+Q6+Q7+Q8+Q9+P0+P1+P2+P3+P4+P5+P6+P7+P8+P9;
决策曲线:VARA;

通达信决策曲线指标公式

 

相关文章