在线检测未来函数

通达信主力对倒出货指标公式

来源:Internet,编辑:股旁网,2014-08-17

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:=(1+7/100)*DD;
下:=(1-7/100)*DD;
MA5:=MA(C,5);
ZLCM:=EMA(WINNER(CLOSE)*70,3);
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
DRAWGBK(MA5>=REF(MA5,1),RGB(0,150,0),RGB(150,0,0),0,'',0);
DRAWGBK(MA5<=REF(MA5,1),RGB(150,0,0),RGB(0,150,0),0,'',0);
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
ZZLJJ:=EMA(ZZLKP,89);
现价: IF(DYNAINFO(4)=0,C,DYNAINFO(7)),COLOR0077FF,POINTDOT;
KC:=(2*C+H+L+O)/5;
CB:MEMA(KC,5);
XL:=SLOPE(CB,3)>0;
价值线:CB;
IF(XL,CB,DRAWNULL),LINETHICK3,COLORRED;
IF(XL-1,CB,DRAWNULL),LINETHICK3,COLORGREEN;
反弹线:MA(CB,10) ,COLOR9999FF,LINETHICK3;
顶线:上+ABS(CB-MA(CB,10))*0.9,COLORWHITE;
底线:下-ABS(CB-MA(CB,10)),COLORWHITE;
VAR1:=(HIGH+LOW+OPEN+CLOSE)/4;
VAR3:=2*EMA(LLV(VAR1,7),10)-VAR1;
黄金线:MA(3*VAR1-2*SMA(VAR1,2,1),12),COLORYELLOW;
乾坤线:3*VAR3-2*SMA(VAR3,10,1),COLORGREEN;
ZJLRQD:=ZZLKP-ZZLJJ;
AA:=EMA(ZJLRQD,1);
BB:=EMA(AA,5);
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED;
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600;
STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700;
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22;
STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44;
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF;
STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF;
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF;
STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF;
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777;
STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999;
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB;
STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD;
STICKLINE((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)),OPEN,CLOSE,3,0),COLORGREEN;
主力资金试盘:=IF(CROSS(AA,BB),3,0),STICK,LINETHICK4,COLOR0080FF;
主力对倒出货:=IF(CROSS(BB,AA),-3,0),STICK,LINETHICK4,COLOR00FF00;
DRAWICON(主力资金试盘>0,(LOW * 0.98),34);
DRAWICON(主力对倒出货<0,(H*1.03),35);

通达信主力对倒出货指标公式

 

相关文章