在线检测未来函数

大智慧星星指路指标公式

来源:Internet,编辑:股旁网,2014-10-20

A0:=AMOUNT; A01:=AMOUNT/V/100;A02:=(H+L)/2;A03:=(C+H+L+O+A01+A02)/6;M05:=EMA(A01,5);
M10:=EMA(A01,10);M15:=EMA(A01,15);M20:=EMA(A01,20);
A05:=EMA(A0,5);A10:=EMA(A0,10);A15:=EMA(A0,15);J20:=EMA(A02,20);
J05:=EMA(A02,5);J10:=EMA(A02,10);J15:=EMA(A02,15);A20:=EMA(A0,20);
T01:=(A01-M05)/MAX(A01,M05)+(M05-M10)/MAX(M05,M10)+(M10-M15)/MAX(M10,M15)+(M15-M20)/MAX(M15,M20)
+(A02-J05)/MAX(A02,J05)+(J05-J10)/MAX(J05,J10)+(J10-J15)/MAX(J10,J15)+(J15-J20)/MAX(J15,J20)
+((A0-A05)/MAX(A0,A05)+(A05-A10)/MAX(A05,A10)+(A10-A15)/MAX(A10,A15)+(A15-A20)/MAX(A15,A20))/10;
T02:=SUM(T01,5)/5+SUM(T01,10)/10+SUM(T01,20)/20+SUM(T01,30)/30+SUM(T01,40)/40+SUM(T01,50)/50
+SUM(T01,60)/60+SUM(T01,70)/70+SUM(T01,80)/80+SUM(T01,90)/90+SUM(T01,100)/100+SUM(T01,110)/110
+SUM(T01,120)/120+SUM(T01,130)/130+SUM(T01,140)/140+SUM(T01,150)/150+SUM(T01,160)/160+SUM(T01,170)/170
+SUM(T01,180)/180+SUM(T01,190)/190+SUM(T01,200)/200+SUM(T01,210)/210+SUM(T01,220)/220+SUM(T01,230)/230
+SUM(T01,240)/240;
T03:=EMA(T02,2);
DRAWTEXT(T02>0 AND T02>T03,T03,'*'),colorred;
DRAWTEXT(T02<0 AND T02>T03,T03,'*'),colorwhite;
DRAWTEXT(T02<T03,T03,'*'),colorgreen;

大智慧星星指路指标公式

 

相关文章