在线检测未来函数

通达信抄底逃顶主图指标公式

来源:Internet,编辑:股旁网,2014-11-15

BF:=MA(CLOSE,20);
上:BF+2*STD(CLOSE,20),NODRAW;
下:BF-2*STD(CLOSE,20),NODRAW;
DRAWBAND(上,RGB(85,20,30),BF,RGB(0,60,5));
DRAWBAND(BF,RGB(0,60,5),下,RGB(0,60,5));
PP:=CROSS(C,MA(C,4));
EE:=STICKLINE(PP AND MA(C,20)>=REF(MA(C,20),1) AND
C>O,H,L,1,0),COLORFF00FF,LINETHICK2;{20日均线走强买点};
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3)AND
MACD>0;
CT:=MACD>REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF
(MACD,3)<REF(MACD,4)AND MACD>0;
PPO:=MA(C,4)>MA(C,24) AND PP AND MA(C,24)>=REF(MA(C,24),1) ;
VIP:=AA AND PPO OR CT AND PPO;
DRAWICON(VIP=1,LOW*0.95,9),COLORRED;
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORRED,LINETHICK2;
MA20:MA(CLOSE,20),COLORBLUE;
MA62:=MA(CLOSE,62),POINTDOT,COLORBLUE;
MA133:=MA(CLOSE,133),POINTDOT,COLORGREEN;
{涨幅}
日:((C-REF(C,1))/REF(C,1))*100,COLORRED,NODRAW;
周:((C-REF(C,5))/REF(C,5))*100,COLORLIRED,NODRAW;
月:((C-REF(C,20))/REF(C,20))*100,COLORRED,NODRAW;
季:((C-REF(C,60))/REF(C,60))*100,COLORYELLOW,NODRAW;
STICKLINE(日>=9.95,O,C,2,0),COLORRED,LINETHICK2;
IF(MA10>=MA5,MA10,DRAWNULL),COLORGREEN,LINETHICK2;
IF(MA5<=MA10,MA10,DRAWNULL),COLORGREEN,LINETHICK2;
买线YGB:=EMA(C,2);
卖线YGB:=EMA(SLOPE(C,21)*20+C,42);
指导线:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
界:=MA(CLOSE,27);
B买:IF(CROSS(指导线,界) OR CROSS(买线YGB,卖线YGB),C,DRAWNULL),COLORMAGENTA,NODRAW;
持仓:IF(买线YGB>=卖线YGB,C,DRAWNULL),COLORRED,NODRAW;
S卖:IF(CROSS(界,指导线) OR CROSS(卖线YGB,买线YGB),C,DRAWNULL),COLORLIGRAY,NODRAW;
空仓:IF(买线YGB<卖线YGB,C,DRAWNULL),COLORGREEN,NODRAW;
N1:=7;
LC:=REF(CLOSE,1);
X:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1),COLOR00FF00;
魔王:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),1,X),COLOR00FF00;
TJ0:=X=魔王;
TJ1:=X=魔鬼;
TJ2:=X<REF(X,1);
TJ3:=X>REF(1,X);
JRS1:=DRAWICON(TJ1 AND TJ2,X,1);
JRS2:=DRAWICON(TJ0 AND TJ3,X,2);
DRAWICON(FILTER(JRS1>0,1),L*0.97,1);
DRAWICON(FILTER(JRS2>0,1),H*1.02,15);
VAR4:=(LOW+HIGH+CLOSE)/3;
操作:=MA(VAR4,5);
拉升:=HHV(操作,13),POINTDOT;
压力:=HHV(操作,60),POINTDOT;
买卖:=LLV(操作,13),POINTDOT;
支撑:=LLV(LOW,60)*1.02,POINTDOT;
顶部:=HHV(HIGH,60)*0.98,POINTDOT,COLORCYAN;

通达信抄底逃顶主图指标公式

 

相关文章