在线检测未来函数

通达信小波段及选股指标公式

来源:Internet,编辑:股旁网,2014-11-25

STICKLINE(C>1,-1,1,5,0)COLOR600000;
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
XYS0:(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
STICKLINE(XYS0>=0,XYS0,0,2,0),COLORRED;
STICKLINE(XYS0<0,XYS0,0,2,0),COLORLIGREEN;
PJGJ:=AMOUNT/VOL/100;
SSRYDJX:=MA(PJGJ,13);
SSRCJL:=EMA(VOL,13);
SSRCJE:=EMA(AMOUNT,13);
SSRCBJX:=SSRCJE/SSRCJL/100;
CYS13:=(CLOSE-SSRCBJX)/SSRCBJX*100;
XYSHSL:=EMA(VOL/CAPITAL*100,13);
ZZX:0,COLORWHITE;
{STICKLINE(XYSHSL>6.1 AND CYS13>5 ,2 ,0 ,2 ,0 ),COLORGREEN;
STICKLINE(XYSHSL>3.8 AND CYS13>5 ,1.5 ,0 ,2 ,0 ),COLORYELLOW;
STICKLINE(XYSHSL>2.1 AND CYS13>5 ,1 ,0 ,2 ,0 ),COLORCYAN;
STICKLINE(XYSHSL>1.8 AND CYS13>5 ,0.5 ,0 ,2 ,0 ),COLORBLUE;}
XYS1:MA(XYS0,2);
XYS2:MA(XYS0,1);
STICKLINE(CROSS(XYS1,XYS2) AND XYS1>=0,XYS0,0,2,0),COLORLIRED;
STICKLINE(XYS1>XYS2 AND XYS2>=0,XYS0,0,2,0),COLORLIRED;
STICKLINE(CROSS(XYS2,XYS1) AND XYS1<=0,XYS0,0,2,0),COLORLICYAN;
STICKLINE(XYS1<XYS2 AND XYS2<=0,XYS0,0,2,0),COLORLICYAN;
MA3:=MA(C,3);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
V0:=MA(C,3)>REF(MA(C,3),1) AND MA(C,5)>REF(MA(C,5),1) AND C>MA(C,3)
AND MA(C,3)>MA(C,5) ; {均线C,MA3,MA5多头排列并向上;}
角度MA3:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
角度MA5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
角度MA10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
暴力拉升:IF(角度MA3>45 AND 角度MA5>45 AND 角度MA10>45 AND 角度MA20>45 AND MA(C,250)>REF(MA(C,250),1),
2,0),LINETHICK2,COLORYELLOW;

{
选股公式:

流通股本:=CAPITAL/100<30000;
涨幅:=DYNAINFO(14)>=0.02 AND DYNAINFO(14)<=0.08 AND MA(C,5)>=MA(C,20);
震幅:=ABS((H-L)/L);
震幅平均:=SUM(震幅,30)/30>=0.03;
去掉连涨停:=COUNT(O=H AND C/REF(C,1)>1.097,30)<2;
去掉新股:=DYNAINFO(17)>0 AND BARSCOUNT(C)>=250 ;
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
XYS0:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*100;
XYS1:=MA(XYS0,2);
XYS2:=MA(XYS0,1);
捕捞季节:=CROSS(XYS2,XYS1);
A1:=EMA(CLOSE,7)-EMA(CLOSE,21);
B1:=EMA((0.668*REF(A1,1)+0.333*A1),1);
做多:=IF(A1>=B1,A1,B1)*30+50;
做空:=IF(B1-A1,B1,A1)*30+50;
波段买入:=做多=做空;
下跌天数:=COUNT(波段买入,5)>=4;
涨幅 AND 震幅平均 AND 捕捞季节 AND 下跌天数 AND 去掉连涨停 AND 去掉新股;
}

通达信小波段及选股指标公式

 

相关文章