在线检测未来函数

通达信均线三角主图指标公式

来源:Internet,编辑:股旁网,2014-12-30

M1:=5;
M2:=10;
M3:=20;
M4:=60;
M5:=120;
M6:=250;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
M:=30; N:=30;
TJ:=HHV(H,M)=H;
TJT:=BARSLAST(TJ);
TJ1:=LLV(L,N)=L;
TJ1T:=BARSLAST(TJ1);
DRAWLINE(H=HHV(H,M),HHV(H,M),L=LLV(L,N),LLV(LOW,N),0)COLORYELLOW;
NOTEXT2:DRAWLINE(H=HHV(H,M),HHV(H,M),L=LLV(L,N),REF(H,TJT),0)COLORYELLOW;
STICKLINE(NOTEXT2 AND L=LLV(L,N) AND FILTERX(L=LLV(L,N),TJT+1),
REF(L,TJ1T),REF(H,TJT),0,0)COLORYELLOW;
均线:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW;
买入:IF(MA1>REF(MA1,1),MA1,DRAWNULL),LINETHICK3,COLORRED;
卖出:IF(MA1<REF(MA1,1),MA1,DRAWNULL),LINETHICK1,COLORWHITE;
MAA10:=MA(C,10);
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.1,'↖跟庄买进'),COLORYELLOW;
STICKLINE(买,OPEN,CLOSE,2,0),COLORYELLOW;

通达信均线三角主图指标公式

 

相关文章