在线检测未来函数

通达信资金潮指标公式

来源:Internet,编辑:股旁网,2015-02-09

STICKLINE(C>0,0,0,10,0),COLORGRAY;
VV:=AMOUNT/100000000;
LB:=MA(VV,1)/HHV(VV,0);
XS:=2;
obv:=SUM(IF(C>REF(C,1),vv,IF(C<REF(C,1),-vv,0)),180);
wobv:=EMA(obv,3);
rOBY:=DMA(obv,LB/xs);
sOBV:=DMA(obv,LB/XS/xs);
YOBV:=DMA(obv,LB/XS/XS/xs);
SSOBC:=DMA(obv,LB/XS/XS/XS/xs);
LOBV:=DMA(obv,LB/XS/XS/XS/XS/xs);
QROBV:((SSOBC-LOBV+(YOBV-LOBV)/2+(sOBV-LOBV)/3+(rOBY-LOBV)/4+(wobv-LOBV)/5)/5);
MQR:MA(qrobv,8);
OBc:((rOBY-LOBV)/2+(sOBV-SSOBC+YOBV-LOBV)/2+wobv-sOBV)/3,LINETHICK2;
MOBv:MA(OBC,4);
KOBV:=2*(obc-MOBV);
DOBV:2*(QROBV-MQR),COLORSTICK;
MACDOBV:(KOBV+DOBV)/2,NODRAW;
STICKLINE(MACDOBV>=0,0,MACDOBV,5,1),COLORRED;
STICKLINE(MACDOBV<0,0,MACDOBV,5,1),COLOR00bb00;
STICKLINE(DOBV>=0,0,DOBV,0,0),COLOR00CCCC;
STICKLINE(DOBV<0,0,DOBV,0,0),COLORCYAN;
OBVH1:=REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,34))),COLOR0099FF,LINETHICK1;
OBVH2:REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,72))),COLORWHITE,LINETHICK1;
OBVL1:=REF(MACDOBV/2,BARSLAST(MACDOBV=LLV(MACDOBV,34))),COLORGRAY,LINETHICK2;
OBVL2:=REF(MACDOBV/2,BARSLAST(MACDOBV=LLV(MACDOBV,144))),COLOR0099FF,LINETHICK2;
行情:=NOT(REF(OBVH1,1)=REF(OBVH2,1)) AND OBVH1=OBVH2;
DRAWTEXT(MACDOBV>OBVH1,OBVL2*2,'*'),COLORWHITE;
DRAWTEXT(大行情,OBVH2*4,'★'),COLORRED;
QGOBV:=REF(HHV(mobv,9),1);
QDOBV:=REF(LLV(mobv,9),1);
ZJGL:=(((obc-MOBV)/ABS(MobV)+(QRobV-MQR)/ABS(MQR)+((obc-qrobv)/ABS(QROBV)+(MOBV-MQR)/ABS(MQR))/2)/3)*10;
DSGL:=(((obc-MOBV)/ABS(MobV)+(obc-QgOBV)/ABS(QgobV)+(MobV-QDOBV)/ABS(QDobV))/3)*10;
SGL:=(ZJGL+DSGL)/2;
DRAWTEXT(CROSS(ZJGL,0)AND OBC>REF(OBC,1),QROBV*0.8,'★'),COLORYELLOW;
DRAWTEXT(CROSS(DSGL,0)AND OBC>REF(OBC,1) AND OBC>QROBV,QROBV*1.25,'★'),COLORWHITE;

通达信资金潮指标公式

 

相关文章