在线检测未来函数

通达信掌控传奇主图指标公式

来源:Internet,编辑:股旁网,2015-02-10

DQ:=POW(10,6)+181220-DATE;
YX:=IF(DQ>0,1,0);
A:=(3*C+O+L+H)/6*YX;
B:(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210,COLORRED,LINETHICK2;
QS:MA(B,5),COLORBLUE,LINETHICK2;
RQ:B*1.0682,COLORRED,LINETHICK2;
X:=IF(CROSS(B,QS),1,0);
Y:=ABS(REF(QS,BARSLAST(X)-REF(CROSS(B,QS),BARSLAST(X))));
Z:=IF(CROSS(QS,B),B,Y);
LL:=LLV(LOW,77);
HH:=HHV(HIGH,77);
LH:=(HH-LL)/HH;
HD:IF(C<HH,LL,HH),COLORLIBLUE,LINETHICK1;
JC:IF(C>LL,HH,LL),COLORYELLOW,LINETHICK1;
JDCM:(JC-HD)/JC,NODRAW;
ZL:=LLV(INDEXL,33);
ZH:=HHV(INDEXH,33);
ZQ:=(INDEXC-ZL)/(ZH-ZL),COLORMAGENTA;
BL:=SMA(ZQ,23,1);
BQ:=SMA(BL,13,1);
UX:=IF(CROSS(BL,BQ),1,0.5);
CM:=BETAEX(COST(90+(100-90)/2)+COST((100-90)/2),BL,27),COLORGREEN;
YY:=ABS(REF(BQ,BARSLAST(UX)-REF(CROSS(BL,BQ),BARSLAST(UX)))),COLORLIBLUE,LINETHICK3;
M1:C*(1+DYNAINFO(14)*0.0382)*1.0382,COLORYELLOW,NODRAW;
M2:C*(0.9-DYNAINFO(14)*0.0618)*1.0618,COLORYELLOW,NODRAW;
MAV:=(C*2+H+L)/4;
SK:=EMA(MAV,13) - EMA(MAV,34);
SD:=EMA(SK,5);
KK:=2*(SD-SK)*3.8;
DD:=2*(SK-SD)*3.8;
∞:DMA(C,V/CAPITAL);
顶:REF(M1,3),NODRAW;
底:REF(M2,5),COLORCYAN,NODRAW;
PN1:=DYNAINFO(8)>0;
PN2:=DYNAINFO(17)>0;
PN3:=DYNAINFO(22)>0;
PN4:=DYNAINFO(23)>0;
ST:=IF(NAMELIKE('ST')=1,0,IF(NAMELIKE('S ST')=1,0,IF(NAMELIKE('*ST')=1,0,1)));
去除:=PN1*PN2*PN3*PN4*ST;
DRAWICON(L<=底 AND DD>KK AND 去除,L,1);
DRAWICON(CROSS(H,顶),H,2);
DRAWICON(Z=REF(Z,1) OR BL>BQ AND BARSLAST(CROSS(B,QS))<BARSLAST(CROSS(QS,B)),Z,28);
STICKLINE(CROSS(B,QS),L,∞,1,0),COLORRED,LINETHICK3;
STICKLINE(CROSS(QS,B),L,Y,1,0),COLORBLUE,LINETHICK3;
STICKLINE(JDCM<0.25,JC*1.002,JC*1.006,1,0),COLORGREEN,LINETHICK3;
DRAWICON(CROSS(B,QS),L*0.99,25);
DRAWICON(CROSS(QS,B),H*1.02,27);
DRAWICON(CROSS(QS,B),H*1.01,2);
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,O*1.018,C*0.968,2,0),COLORYELLOW;{涨停}
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,O,C,2,0),COLORGREEN;{跌停}
STICKLINE(跌停,H,L,0,1),COLORGREEN;
斜率:(B-REF(B,1))/REF(B,1)*100,NODRAW;
PL2:(LOW-B)/ B*100,NODRAW;
STICKLINE(CROSS(1,PL2),O,C,2,0),COLORRED;

通达信掌控传奇主图指标公式

 

相关文章