在线检测未来函数

大智慧顶底操盘指标公式

来源:Internet,编辑:股旁网,2015-02-11

A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
d:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);
长期线:A+100,color9900FF;
短期线:B+100,color888888;
中期线:d+100,coloryellow,linethick2;
见顶:(ref(中期线,1)>85 and ref(短期线,1)>85 and ref(长期线,1)>65) and cross(长期线,短期线),color777777,PRECIS0;
顶部区域:(中期线<ref(中期线,1) and ref(中期线,1)>80) and (ref(短期线,1)>95 or ref(短期线,2)>95 ) and 长期线>60 and 短期线<83.5
and 短期线<中期线 and 短期线<长期线+4,colorAAAAAA,PRECIS0;
顶部:=filter(顶部区域,4);
底部区域:(长期线<12 and 中期线<8 and (短期线<7.2 or ref(短期线,1)<5) and (中期线>ref(中期线,1) or 短期线>ref(短期线,1)))
or (长期线<8 and 中期线<7 and 短期线<15 and 短期线>ref(短期线,1)) or (长期线<10 and 中期线<7 and 短期线<1),color4080AA ,PRECIS0;
stickline( {见顶 or} 顶部,99,103,20,1 ),colorred,linethick2;stickline( 底部区域,-4,0,22,0 ),colorgreen;
低位金叉:长期线<15 and ref(长期线,1)<15 and 中期线<18 and 短期线>ref(短期线,1) and cross(短期线,长期线) and 短期线>中期线 and (ref(短期线,1)<5 or ref(短期线,2)<5 ) and (中期线>=长期线 or ref( 短期线,1)<1 ),COLOR800080,PRECIS0;
stickline( 低位金叉,0,5,11,0 ),colorred;
80,COLOR996699,PRECIS0,LAYER7;
20,COLORGREEN,PRECIS0,LAYER7;
10,COLORCC6633,LINETHICK2,PRECIS0,LAYER7;
90,COLOR9966FF,LINETHICK2,PRECIS0,LAYER7;

大智慧顶底操盘指标公式

 

相关文章