在线检测未来函数

飞狐散户彩带指标公式

来源:Internet,编辑:股旁网,2015-02-26

VERTLINE(HOUR=15),POINTDOT,color4900;
VARE:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
卖出线:=SMA(SMA(VARE,3,1),3,1);
买入线:3*SMA(VARE,3,1)-2*卖出线,LINETHICK1,colorFFFF00;
PARTLINE(买入线>REF(买入线,1),买入线),LINETHICK2,color80;
PARTLINE(买入线<REF(买入线,1),买入线),LINETHICK1,colorFFFF00;
80,LINEDOT,color4900;
A:=3*SMA((CLOSE-LLV(LOW,22))/(HHV(HIGH,22)-LLV(LOW,22))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,22))/(HHV(HIGH,22)-LLV(LOW,22))*100,5,1),3,1);
底部:=10;
XDKX1518:STICKLINE(CROSS(A,底部),-5,20,1,0),LINETHICK1,colorFFCC00;
明天会涨:=IF(CROSS(A,底部),-8,0);
FILLRGN(明天会涨<0 OR 明天会涨>-5,明天会涨,0),colorFFFF;
VAR2:=REF(LOW,1);
VAR3:=(SMA(ABS(LOW-VAR2),13,1))/(SMA(MAX(LOW-VAR2,0),13,1))*0.05;
VAR4:=EMA(VAR3,13);
VAR5:=LLV(LOW,34);
VAR8:=EMA(IF(LOW<=VAR5,VAR4,-20),3);
STICKLINE(VAR8>REF(VAR8,1),-20,VAR8,4,1),color80;
STICKLINE(VAR8<REF(VAR8,1),-20,VAR8,4,1),colorFF00;
RSV2:=(CLOSE-LLV(LOW,180))/(HHV(HIGH,180)-LLV(LOW,180))*100;
K2:=SMA(RSV2,26,1);
D2:=SMA(K2,26,1);
长线:STICKLINE(EMA(D2,3)>REF(EMA(D2,3),5),EMA(D2,3),REF(EMA(D2,3),5),58,0),colorF1239A;
STICKLINE(EMA(D2,3)<REF(EMA(D2,3),5),EMA(D2,3),REF(EMA(D2,3),5),58,0),colorFF0000;
RSV1:=(CLOSE-LLV(LOW,35))/(HHV(HIGH,35)-LLV(LOW,35))*100;
K1:=SMA(RSV1,4,1);
D1:SMA(K1,8,1),LINETHICK0;
中线:STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),18,0),color80;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1),EMA(D1,3),REF(EMA(D1,3),1),18,0),colorFFC000;
流通【亿】:CAPITAL/1000000,LINETHICK0,colorFFFF00;
每股收益:FINANCE(33),LINETHICK0,colorFF00;
总股【亿】:FINANCE(1)/10000,LINETHICK0,colorFF00;
VAR9:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,34);
VAR11:=HHV(HIGH,34);
散户:=EMA((VAR9-VAR10)/(VAR11-VAR10)*100,12);
新庄:=EMA(0.667*REF(散户,1)+0.333*散户,4);
PARTLINE(散户>REF(散户,1) AND 散户<80,散户),LINETHICK2,colorED;
FILLRGN((新庄<散户)*2.5,散户,新庄),colorFF;
FILLRGN((新庄>散户)*2.5,散户,新庄),color8900;
FILLRGN((新庄<散户)*2.5 AND 散户>80,散户,新庄),colorFFFF;
100,color7900;
20,LINEDOT,color5900;
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND F<0,1,0);
P2:=今小前;
重心:=(CLOSE+0.618*REF(CLOSE,1)+0.382*REF(CLOSE,2)+0.236*REF(CLOSE,3)+0.146*REF(CLOSE,4))/2.382;
GAO:=HHV(CLOSE,60)-LLV(CLOSE,60);
RSI:=(SMA(MAX(重心-REF(重心,1),0),5,1))/(SMA(ABS(重心-REF(重心,1)),5,1));
指导线:=重心+GAO*(RSI-0.5);
0,LINETHICK2,color7900;
大盘MSD:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
PARTLINE(大盘MSD>REF(大盘MSD,1),大盘MSD),LINEDOT,LINETHICK1,colorFF00;
PARTLINE(大盘MSD<REF(大盘MSD,1),大盘MSD),LINETHICK2,color6900;
DRAWICON(CLOSE>OPEN AND 买入线<50 AND CROSS(指导线,REF(指导线,1)),0,'小黄交'),ALIGN0;
MA5:=EMA(CLOSE,5);
YE:=(HIGH+LOW+CLOSE)/3;
YE1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
YE2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-YE);
YE3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
YE4:=IF(HIGH=LOW,1,YE-MIN(CLOSE,OPEN));
YE5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
YE6:=SUM(YE1*YE5,1);
YE7:=SUM(YE2*YE5,1);
YE8:=SUM(YE3*YE5,1);
YE9:=SUM(YE4*YE5,1);
主力买大:=YE9>YE7;
买大于卖:=YE9+YE8>YE7+YE6;
波段买量:SUM(YE9+YE8,150),LINETHICK0;
波段卖量:SUM(YE7+YE6,150),LINETHICK0;
波段买卖差:SUM(YE9+YE8,150)-(SUM(YE7+YE6,150)),LINETHICK0;
STICKLINE(ISLASTBAR AND YE9+YE8,0,(YE9+YE8)/10000,15,0),SHIFT4,colorFF;
STICKLINE(ISLASTBAR AND YE7+YE6,0,(YE7+YE6)/10000,10,0),SHIFT4,color8900;
STICKLINE(ISLASTBAR AND YE9>0,0,YE9/10000,6,0),SHIFT4,color80;
STICKLINE(ISLASTBAR AND YE7>0,0,YE7/10000,2,0),SHIFT4,colorFFFFFF;

飞狐散户彩带指标公式

 

相关文章