在线检测未来函数

通达信100天筹码分布主图指标公式

来源:Internet,编辑:股旁网,2015-03-11

CM1:=INTPART(PPART(1)*100);
CM2:=INTPART(PPART(2)*100);
CM3:=INTPART(PPART(3)*100);
CM4:=INTPART(PPART(4)*100);
CM5:=INTPART(PPART(5)*100);
CM6:=INTPART(PPART(6)*100);
CM7:=INTPART(PPART(7)*100);
CM8:=INTPART(PPART(8)*100);
CM9:=INTPART(PPART(9)*100);
CM10:=INTPART(PPART(10)*100);
CM11:=INTPART(PPART(11)*100);
CM12:=INTPART(PPART(12)*100);
CM13:=INTPART(PPART(13)*100);
CM14:=INTPART(PPART(14)*100);
CM15:=INTPART(PPART(15)*100);
CM16:=INTPART(PPART(16)*100);
CM17:=INTPART(PPART(17)*100);
CM18:=INTPART(PPART(18)*100);
CM19:=INTPART(PPART(19)*100);
CM20:=INTPART(PPART(20)*100);
CM21:=INTPART(PPART(21)*100);
CM22:=INTPART(PPART(22)*100);
CM23:=INTPART(PPART(23)*100);
CM24:=INTPART(PPART(24)*100);
CM25:=INTPART(PPART(25)*100);
CM26:=INTPART(PPART(26)*100);
CM27:=INTPART(PPART(27)*100);
CM28:=INTPART(PPART(28)*100);
CM29:=INTPART(PPART(29)*100);
CM30:=INTPART(PPART(30)*100);
CM31:=INTPART(PPART(31)*100);
CM32:=INTPART(PPART(32)*100);
CM33:=INTPART(PPART(33)*100);
CM34:=INTPART(PPART(34)*100);
CM35:=INTPART(PPART(35)*100);
CM36:=INTPART(PPART(36)*100);
CM37:=INTPART(PPART(37)*100);
CM38:=INTPART(PPART(38)*100);
CM39:=INTPART(PPART(39)*100);
CM40:=INTPART(PPART(40)*100);
CM41:=INTPART(PPART(41)*100);
CM42:=INTPART(PPART(42)*100);
CM43:=INTPART(PPART(43)*100);
CM44:=INTPART(PPART(44)*100);
CM45:=INTPART(PPART(45)*100);
CM46:=INTPART(PPART(46)*100);
CM47:=INTPART(PPART(47)*100);
CM48:=INTPART(PPART(48)*100);
CM49:=INTPART(PPART(49)*100);
CM50:=INTPART(PPART(50)*100);
CM51:=INTPART(PPART(51)*100);
CM52:=INTPART(PPART(52)*100);
CM53:=INTPART(PPART(53)*100);
CM54:=INTPART(PPART(54)*100);
CM55:=INTPART(PPART(55)*100);
CM56:=INTPART(PPART(56)*100);
CM57:=INTPART(PPART(57)*100);
CM58:=INTPART(PPART(58)*100);
CM59:=INTPART(PPART(59)*100);
CM60:=INTPART(PPART(60)*100);
CM61:=INTPART(PPART(61)*100);
CM62:=INTPART(PPART(62)*100);
CM63:=INTPART(PPART(63)*100);
CM64:=INTPART(PPART(64)*100);
CM65:=INTPART(PPART(65)*100);
CM66:=INTPART(PPART(66)*100);
CM67:=INTPART(PPART(67)*100);
CM68:=INTPART(PPART(68)*100);
CM69:=INTPART(PPART(69)*100);
CM70:=INTPART(PPART(70)*100);
CM71:=INTPART(PPART(71)*100);
CM72:=INTPART(PPART(72)*100);
CM73:=INTPART(PPART(73)*100);
CM74:=INTPART(PPART(74)*100);
CM75:=INTPART(PPART(75)*100);
CM76:=INTPART(PPART(76)*100);
CM77:=INTPART(PPART(77)*100);
CM78:=INTPART(PPART(78)*100);
CM79:=INTPART(PPART(79)*100);
CM80:=INTPART(PPART(80)*100);
CM81:=INTPART(PPART(81)*100);
CM82:=INTPART(PPART(82)*100);
CM83:=INTPART(PPART(83)*100);
CM84:=INTPART(PPART(84)*100);
CM85:=INTPART(PPART(85)*100);
CM86:=INTPART(PPART(86)*100);
CM87:=INTPART(PPART(87)*100);
CM88:=INTPART(PPART(88)*100);
CM89:=INTPART(PPART(89)*100);
CM90:=INTPART(PPART(90)*100);
CM91:=INTPART(PPART(91)*100);
CM92:=INTPART(PPART(92)*100);
CM93:=INTPART(PPART(93)*100);
CM94:=INTPART(PPART(94)*100);
CM95:=INTPART(PPART(95)*100);
CM96:=INTPART(PPART(96)*100);
CM97:=INTPART(PPART(97)*100);
CM98:=INTPART(PPART(98)*100);
CM99:=INTPART(PPART(99)*100);
CM100:=INTPART(PPART(100)*100);
IF(CURRBARSCOUNT<INTPART(CM2/2),CONST(COSTEX(REF(C,1),REF(C,2))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM3/2),CONST(COSTEX(REF(C,2),REF(C,3))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM4/2),CONST(COSTEX(REF(C,3),REF(C,4))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM5/2),CONST(COSTEX(REF(C,4),REF(C,5))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM6/2),CONST(COSTEX(REF(C,5),REF(C,6))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM7/2),CONST(COSTEX(REF(C,6),REF(C,7))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM8/2),CONST(COSTEX(REF(C,8),REF(C,9))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM9/2),CONST(COSTEX(REF(C,9),REF(C,10))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM10/2),CONST(COSTEX(REF(C,10),REF(C,11))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM11/2),CONST(COSTEX(REF(C,11),REF(C,12))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM12/2),CONST(COSTEX(REF(C,12),REF(C,13))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM13/2),CONST(COSTEX(REF(C,13),REF(C,14))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM14/2),CONST(COSTEX(REF(C,14),REF(C,15))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM15/2),CONST(COSTEX(REF(C,15),REF(C,16))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM16/2),CONST(COSTEX(REF(C,16),REF(C,17))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM17/2),CONST(COSTEX(REF(C,17),REF(C,18))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM18/2),CONST(COSTEX(REF(C,18),REF(C,19))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM19/2),CONST(COSTEX(REF(C,19),REF(C,20))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM20/2),CONST(COSTEX(REF(C,20),REF(C,21))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM21/2),CONST(COSTEX(REF(C,21),REF(C,22))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM22/2),CONST(COSTEX(REF(C,22),REF(C,23))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM23/2),CONST(COSTEX(REF(C,23),REF(C,24))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM24/2),CONST(COSTEX(REF(C,24),REF(C,25))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM25/2),CONST(COSTEX(REF(C,25),REF(C,26))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM26/2),CONST(COSTEX(REF(C,26),REF(C,27))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM27/2),CONST(COSTEX(REF(C,27),REF(C,28))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM28/2),CONST(COSTEX(REF(C,28),REF(C,29))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM29/2),CONST(COSTEX(REF(C,29),REF(C,30))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM30/2),CONST(COSTEX(REF(C,30),REF(C,31))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM31/2),CONST(COSTEX(REF(C,31),REF(C,32))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM32/2),CONST(COSTEX(REF(C,32),REF(C,33))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM33/2),CONST(COSTEX(REF(C,33),REF(C,34))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM34/2),CONST(COSTEX(REF(C,34),REF(C,35))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM35/2),CONST(COSTEX(REF(C,35),REF(C,36))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM36/2),CONST(COSTEX(REF(C,36),REF(C,37))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM37/2),CONST(COSTEX(REF(C,37),REF(C,38))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM38/2),CONST(COSTEX(REF(C,38),REF(C,39))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM39/2),CONST(COSTEX(REF(C,39),REF(C,40))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM40/2),CONST(COSTEX(REF(C,40),REF(C,41))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM41/2),CONST(COSTEX(REF(C,41),REF(C,42))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM42/2),CONST(COSTEX(REF(C,42),REF(C,43))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM43/2),CONST(COSTEX(REF(C,43),REF(C,44))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM44/2),CONST(COSTEX(REF(C,44),REF(C,45))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM45/2),CONST(COSTEX(REF(C,45),REF(C,46))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM46/2),CONST(COSTEX(REF(C,46),REF(C,47))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM47/2),CONST(COSTEX(REF(C,47),REF(C,48))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM48/2),CONST(COSTEX(REF(C,48),REF(C,49))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM49/2),CONST(COSTEX(REF(C,49),REF(C,50))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM50/2),CONST(COSTEX(REF(C,50),REF(C,51))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM51/2),CONST(COSTEX(REF(C,51),REF(C,52))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM52/2),CONST(COSTEX(REF(C,52),REF(C,53))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM53/2),CONST(COSTEX(REF(C,53),REF(C,54))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM54/2),CONST(COSTEX(REF(C,54),REF(C,55))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM55/2),CONST(COSTEX(REF(C,55),REF(C,56))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM56/2),CONST(COSTEX(REF(C,56),REF(C,57))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM57/2),CONST(COSTEX(REF(C,57),REF(C,58))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM58/2),CONST(COSTEX(REF(C,58),REF(C,59))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM59/2),CONST(COSTEX(REF(C,59),REF(C,60))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM60/2),CONST(COSTEX(REF(C,60),REF(C,61))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM61/2),CONST(COSTEX(REF(C,61),REF(C,62))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM62/2),CONST(COSTEX(REF(C,62),REF(C,63))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM63/2),CONST(COSTEX(REF(C,63),REF(C,64))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM64/2),CONST(COSTEX(REF(C,64),REF(C,65))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM65/2),CONST(COSTEX(REF(C,65),REF(C,66))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM66/2),CONST(COSTEX(REF(C,66),REF(C,67))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM67/2),CONST(COSTEX(REF(C,67),REF(C,68))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM68/2),CONST(COSTEX(REF(C,68),REF(C,69))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM69/2),CONST(COSTEX(REF(C,69),REF(C,70))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM70/2),CONST(COSTEX(REF(C,70),REF(C,71))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM71/2),CONST(COSTEX(REF(C,71),REF(C,72))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM72/2),CONST(COSTEX(REF(C,72),REF(C,73))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM73/2),CONST(COSTEX(REF(C,73),REF(C,74))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM74/2),CONST(COSTEX(REF(C,74),REF(C,75))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM75/2),CONST(COSTEX(REF(C,75),REF(C,76))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM76/2),CONST(COSTEX(REF(C,76),REF(C,77))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM77/2),CONST(COSTEX(REF(C,77),REF(C,78))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM78/2),CONST(COSTEX(REF(C,78),REF(C,79))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM79/2),CONST(COSTEX(REF(C,79),REF(C,80))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM80/2),CONST(COSTEX(REF(C,80),REF(C,81))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM81/2),CONST(COSTEX(REF(C,81),REF(C,82))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM82/2),CONST(COSTEX(REF(C,82),REF(C,83))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM83/2),CONST(COSTEX(REF(C,83),REF(C,84))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM84/2),CONST(COSTEX(REF(C,84),REF(C,85))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM85/2),CONST(COSTEX(REF(C,85),REF(C,86))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM86/2),CONST(COSTEX(REF(C,86),REF(C,87))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM87/2),CONST(COSTEX(REF(C,87),REF(C,88))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM88/2),CONST(COSTEX(REF(C,88),REF(C,89))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM89/2),CONST(COSTEX(REF(C,89),REF(C,90))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM90/2),CONST(COSTEX(REF(C,90),REF(C,91))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM91/2),CONST(COSTEX(REF(C,91),REF(C,92))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM92/2),CONST(COSTEX(REF(C,92),REF(C,93))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM93/2),CONST(COSTEX(REF(C,93),REF(C,94))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM94/2),CONST(COSTEX(REF(C,94),REF(C,95))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM95/2),CONST(COSTEX(REF(C,95),REF(C,96))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM96/2),CONST(COSTEX(REF(C,96),REF(C,97))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM97/2),CONST(COSTEX(REF(C,97),REF(C,98))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM98/2),CONST(COSTEX(REF(C,98),REF(C,99))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM99/2),CONST(COSTEX(REF(C,99),REF(C,100))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM100/2),CONST(COSTEX(REF(C,100),REF(C,101))),DRAWNULL),COLORBLUE;
IF(CURRBARSCOUNT<INTPART(CM1/2),CONST(C),DRAWNULL),COLORRED;
{DRAWKLINE(H,O,L,C);};

通达信100天筹码分布主图指标公式

 

相关文章