在线检测未来函数

通达信买进和最低价的主图指标公式

来源:Internet,编辑:股旁网,2015-04-14

M1:=5;
M2:=10;
M3:=20;
M4:=60;
M5:=120;
M6:=250;
M7:=30;
M8:=1;
M9:=2;
M10:=3;
MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
MA5:MA(CLOSE,M5);
MA6:MA(CLOSE,M6);
MA7:MA(CLOSE,M7);
MA8:MA(CLOSE,M8);
MA9:MA(CLOSE,M9);
MA10:MA(CLOSE,M10);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;
N:=BARSSINCEN(L=LLV(L,20),30);
A1:=IF(CURRBARSCOUNT<20 AND C<10,CONST(LLV(L,20)),DRAWNULL);
{STICKLINE(1,A1,A1-0.2,4,0),COLORBLUE;}
A2:=IF(CURRBARSCOUNT<20 AND C<10,CONST(HHV(C,20)),DRAWNULL);
{DRAWBAND(MA(L,20)*0.98,90,A2,90);}
{STICKLINE(1,A1,MA(L,20),0,-1),COLORBROWN;}
DRAWKLINE(H,O,L,C);
A3:A1+0.1,COLORBROWN,LINETHICK2;
DRAWICON(MA(L,20)/A3<1.02 AND L/A3<1.02,A3,26);
{周36:=MA(CLOSE,36)LINETHICK1,COLORWHITE
天60:=MA(CLOSE,60)LINETHICK1,COLORBLUE;
七天线:MA(C,7),COLORGRAY;
生命线:(MA(C,25)),LINETHICK2,COLORMAGENTA;
{不惑线:(MA(C,40)),COLORCYAN;
姊妹线:(EMA(C,56)),COLORWHITE;
{K线}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{线上阴线买停板
工作线:=(EMA(C,14)),POINTDOT,LINETHICK4,COLORYELLOW;
A3A:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4A:=EMA(C,10);
A23:=((C + L) + H) / 3;
A24:=EMA(A23,6);
A25:=EMA(A24,5);
A26:=CROSS(A24,A25);
DRAWICON(A26,(LOW / 1.015),1),LINETHICK2,COLORMAGENTA;
DRAWTEXT(CROSS(A4A,A3A),L*0.9,'线上阴线买停板'),LINETHICK4,COLORYELLOW;
STICKLINE(((C < 工作线) AND (C >= O)),H,L,0,1),COLORBLUE;
STICKLINE(((C < 工作线) AND (C >= O)),O,C,2,1),COLORBLUE;
STICKLINE(((C < 工作线) AND (C <= O)),H,L,0,0),COLORBLUE;
STICKLINE(((C < 工作线) AND (C <= O)),O,C,2,0),COLORBLUE;}
{高低以及日期显示}
A1P:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1P:=FILTER(A1P,3); C1P:=BACKSET(B1P,3+1); D1P:=FILTER(C1P,3);{高点}
A2P:=REF(LOW,3)=LLV(LOW,2*3+1); B2P:=FILTER(A2P,3); C2P:=BACKSET(B2P,3+1); D2:=FILTER(C2P,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上可作取舍}
H1:=(D1P AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
L1P:=(D2 AND NOT(D1P AND E1<E2)); H2:=D1P AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1P,X1)>0,LLVBARS(IF(L1P,LOW,10000),X1));
G1P:=F1>REF(F1,1); I1:=BACKSET(G1P,2); LDP:=I1>REF(I1,1);{过滤后低点}
L2PP:=LDP OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2PP),1)+1; F2:=BACKSET(L2PP AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
G2P:=F2>REF(F2,1); I2:=BACKSET(G2P,2); HDP:=I2>REF(I2,1);{过滤后高点}
DRAWNUMBER(LDP,L*0.999,L),COLORWHITE;{抵触价格显示};
DIF:=MACD.DIF;
H300:=HHVBARS(DIF,300);
A:=BOLL.UB;
T:=BARSLAST(CROSS(A>=REF(A,1),0.5));
E25:EXPMA(C,25),COLORMAGENTA;
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),T+1);
ZFF:=(HHV(H,T+1)-LLV(L,T+1))/LLV(L,T+1)*100;
TJ:=EVERY(MAX(C,O)/A<1.02 ,T+1);
XL:=(ATAN((E25/REF(E25,T)-1)*100)*180/3.1415926);
TJ1:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJ;
TJ2:=MIN(C,O)/E25>1.04;
XG:=TJ1 AND XL>75;
STICKLINE(XG,C,O,2,0),COLORLIRED;
STICKLINE(XG,H,L,0,0),COLORLIRED;
DRAWICON(XG,H*1.01,15);
DRAWTEXT(XG,L*0.95,'起程')COLORYELLOW;

通达信买进和最低价的主图指标公式

 

相关文章