在线检测未来函数

通达信回踩20均线主图及选股指标公式

来源:Internet,编辑:股旁网,2015-04-21

M20:MA(C,20),COLORGREEN,LINETHICK2;
A:=H/MAX(C,O);
B:=MAX(C,O)/MIN(C,O);
D:=MIN(C,O)/L;
T:=BARSLAST(CROSS(C,M20));
HH:=HHVBARS(H,T+1);
LL:=FINDLOWBARS(L,HH=0,T+1,1);
HC:=REF(C,HH);
LC:=REF(C,LL+1);
ZF:=(HC-LC)/LC*100;
TJ:=B>A AND D>B AND B>A;
TJ1:=M20>=REF(M20,1) AND L*0.98>M20;
TJ2:=RANGE(L/M20,0.95,1.01) AND MIN(C,O)>=M20;
TJ3:=TJ AND TJ2;
TJ4:=EVERY(C>=M20,T+1);
NH:=HHV(MAX(C,O)/M20,T+1);
XG:=REF(TJ1,2) AND TJ3 AND ZF>15 AND TJ4 AND T>9 AND NH<1.11;
STICKLINE(XG,H,L,0,1),COLORGREEN;
STICKLINE(XG,C,O,3.2,0),COLOR006600;
STICKLINE(XG,C,O,2.6,0),COLOR008800;
STICKLINE(XG,C,O,1.9,0),COLOR00AA00;
STICKLINE(XG,C,O,1.1,0),COLOR00CC00;
STICKLINE(XG,C,O,0.3,0),COLOR00FF00;
DRAWICON(XG,L*0.94,16);

{
选股公式:

M20:=MA(C,20);
A:=H/MAX(C,O);
B:=MAX(C,O)/MIN(C,O);
D:=MIN(C,O)/L;
T:=BARSLAST(CROSS(C,M20));
HH:=HHVBARS(H,T+1);
LL:=FINDLOWBARS(L,HH=0,T+1,1);
HC:=REF(C,HH);
LC:=REF(C,LL+1);
ZF:=(HC-LC)/LC*100;
TJ:=B>A AND D>B AND B>A;
TJ1:=M20>=REF(M20,1) AND L*0.98>M20;
TJ2:=RANGE(L/M20,0.95,1.01) AND MIN(C,O)>=M20;
TJ3:=TJ AND TJ2;
TJ4:=EVERY(C>=M20,T+1);
NH:=HHV(MAX(C,O)/M20,T+1);
XG:REF(TJ1,2) AND TJ3 AND ZF>15 AND TJ4 AND T>9 AND NH<1.11;
}

通达信回踩20均线主图及选股指标公式

 

相关文章