在线检测未来函数

同花顺黄金量柱子指标公式

来源:Internet,编辑:股旁网,2015-04-23

预测量万:=IF(ISNULL(REFX(&CLOSE,1)) AND STRFIND(PERIODNAME,"日线"),VOL*240/FROMOPEN,0)/10000;//线形不输出
成交量万:VOL/10000,COLOR00ffff;//线形不输出 //文章来至程序化交易网 cxh99.com//
倍量:VOL>=REF(V,1)*1.8 AND C>REF(C,1),coloryellow;
低量:VOL<REF(LLV(VOL,13),1),colormagenta;
平量:ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03,colorwhite;
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.CXH99.COM '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'');
倍缩:VOL<=REF(V,1)*0.5,colorcyan;
梯量:COUNT(V>REF(V,1),3)=3 AND COUNT(C>O,3)=3,colorgray;
缩量涨:COUNT(C>REF(C,1),2)=2 AND COUNT(V<REF(V,1),2)=2,colorblue;
STICKLINE(ISNULL(REFX(&CLOSE,1)) AND STRFIND(PERIODNAME,"日线"),预测量万*10000,0,11,1),COLORffffff;
DRAWTEXT(倍量,V*1.11,'倍'),coloryellow;
STICKLINE(C>=O,0,V,9,0),color0000aa;
STICKLINE(C<O,0,V,9,0),color00aa00;
STICKLINE(倍量,0,V,5,0),coloryellow;
STICKLINE(低量,0,V,5,0),colormagenta;
STICKLINE(平量,0,V,5,0),colorwhite;
STICKLINE(倍缩,0,V,5,0),colorcyan;
STICKLINE(梯量,0,V,5,0),colorgray;
STICKLINE(缩量涨,0,V,5,0),colorblue;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,colorred,LINETHICK1;
STICKLINE(黄金柱,0,V,0.5,0),colorred;
DRAWTEXT(黄金柱,V*1.24,'黄'),colorred;
DRAWTEXT(VOL=HHV(VOL,0),HHV(VOL,30)*0.938,'天量'),colorred;
MA5:MA(V,5),colorred;
MA35:MA(V,35),colormagenta;
MA120:MA(V,120),coloryellow,LINETHICK2;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL,POINTDOT;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),colorred,POINTDOT,NODRAW;
主动卖盘:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(主动买盘>0,0,主动买盘,2,0),colorred,NODRAW;
STICKLINE(主动卖盘<0,0,主动卖盘,2.4,0),colorgreen;
DRAWTEXT(VOL=HHV(VOL,0),HHV(VOL,30)*0.918,'天量'),colorred;

同花顺黄金量柱子指标公式

 

相关文章