在线检测未来函数

大智慧一笑K线指标公式

来源:Internet,编辑:股旁网,2015-04-29

QS0:=((CLOSE - LLV(LOW,120)) / (HHV(HIGH,120) - LLV(LOW,120)));
QS1:=((QS0 / 1) * EMA(CLOSE,20));
QS:=SMA(QS1,3,1);
QD0:=((CLOSE - LLV(LOW,119)) / (HHV(HIGH,119) - LLV(LOW,119)));
QD1:=((QD0 / 1) * EMA(CLOSE,20));
QD:=SMA(QD1,5,1);
QF0:=((CLOSE - LLV(LOW,118)) / (HHV(HIGH,118) - LLV(LOW,118)));
QF1:=((QF0 / 1) * EMA(CLOSE,20));
QF:=SMA(QF1,5,1);
PX1:=((((QS + QD) + QF) / 3) + EMA(CLOSE,20));
PX2:=MA(PX1,2);
PX3:=MA(PX1,3);
YY:=((((2 * CLOSE) + HIGH) + LOW) / 4);
MA1:=MA(YY,45);
收:=(PX1 - MA1);
中:=(PX2 - MA1);
开:=(PX3 - MA1);
MA2:=MA(收,8);
STICKLINE((收 >= 8),0,开,10,0),color8888BB;
STICKLINE((收 <= 0.1),1,开,10,0),colorAAAA55;
STICKLINE(((MA2 >= 8) AND (收 >= 8)),0,开,8,0),color6666DD;
STICKLINE(((MA2 <= 0.1) AND (收 < 0)),1,开,8,0),color666644;
DRAWTEXT(FILTER((收 >= 8),15),6,'顶区'),colorFF88ee;
DRAWTEXT(FILTER((收 <= 0.1),15),0.6,'底区'),colorFFFFFF;
DRAWTEXT(FILTER(((MA2 >= 8) AND (收 >= 8)),15),7,'大顶'),colorFFFF00;
DRAWTEXT(FILTER(((MA2 <= 0.1) AND (收 < 0)),15),0.8,'大底'),colorFFFFee;
底线:0.5,colorFF00FF;
STICKLINE((收 >= 开),收,(开 - 0.03),1,0),color44FFFF;
STICKLINE((收 >= 开),收,(开 - 0.03),0,0),colorCCFFFF;
STICKLINE((收 >= 开),中,(开 - 0.03),8,0),color44FFFF;
STICKLINE((收 >= 开),中,(开 - 0.03),7,0),color66FFFF;
STICKLINE((收 >= 开),中,(开 - 0.03),6,0),color77FFBB;
STICKLINE((收 >= 开),中,(开 - 0.03),5,0),color88FFBB;
STICKLINE((收 >= 开),中,(开 - 0.03),4,0),color99FFBB;
STICKLINE((收 >= 开),中,(开 - 0.03),3,0),colorAAFFBB;
STICKLINE((收 >= 开),中,(开 - 0.03),2,0),colorBBFFBB;
STICKLINE((收 >= 开),中,(开 - 0.03),1,0),colorCCFFBB;
STICKLINE((收 <= 开),收,(开 + 0.03),1,0),colorFF4400;
STICKLINE((收 <= 开),收,(开 + 0.03),0,0),colorFFCC00;
STICKLINE((收 <= 开),中,(开 + 0.03),8,0),colorFF4400;
STICKLINE((收 <= 开),中,(开 + 0.03),7,0),colorFF6600;
STICKLINE((收 <= 开),中,(开 + 0.03),6,0),colorFF7700;
STICKLINE((收 <= 开),中,(开 + 0.03),5,0),colorFF8800;
STICKLINE((收 <= 开),中,(开 + 0.03),4,0),colorFF9900;
STICKLINE((收 <= 开),中,(开 + 0.03),3,0),colorFFAA00;
STICKLINE((收 <= 开),中,(开 + 0.03),2,0),colorFFBB00;
STICKLINE((收 <= 开),中,(开 + 0.03),1,0),colorFFCC00;
MA2,colorFFFFBB;
生命线:MA(收,13),colorFFBBBB;
IF((生命线 < REF(生命线,0)),生命线,1),colorFFFFFF;
DRAWTEXT(FILTER((收 <= 0),30),收,'价连续暴跌\n见大底信号K线\n翻红,才能跟进!'),colorFFFFBB;
DRAWTEXT(FILTER(((MA2 >= 8) AND (收 >= 8)),30),收,'股价连续涨升\n见大顶信号K线\n翻蓝,必须卖出!'),colorFFFFFF;
底部选股:(收 <= 0),LINETHICK0;
MA(LLV(收,120),3),colorFFFF00;
MA(HHV(收,120),3),colorFF00FF;

大智慧一笑K线指标公式

 

相关文章