在线检测未来函数

通达信先胜短底指标公式

来源:Internet,编辑:股旁网,2015-05-06

VARA:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VARA*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VARA*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VARA*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARAA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*200;
VARD:=EMA(IF(CLOSE*1.35<=VARAA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
火焰山:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/118*VAR10,COLORYELLOW;
火焰:=STICKLINE(火焰山>0 ,0 ,火焰山 ,4 ,1);
今量:火焰山;
STICKLINE(火焰山>0,0 ,今量*1.2,8,0 ),COLOR00EEFF;
STICKLINE(火焰山>0,0 ,今量*0.8,8,0 ),COLOR00BBFF;
STICKLINE(火焰山>0,0 ,今量*0.6,8,0 ),COLOR0099FF;
STICKLINE(火焰山>0,0 ,今量*0.4,8,0 ),COLOR0066FF;
STICKLINE(火焰山>0,0 ,今量*0.2,8,0 ),COLOR0000FF;
X:=EMA(((SLOPE(CLOSE,6) * 6) + CLOSE),2);
Y:=EMA(CLOSE,2);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),4,1) / SMA(ABS((CLOSE - LL)),4,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
买:CROSS(火焰山>40,X)*50, LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(J<0,0,91,5,0),COLOR008888;
STICKLINE(J<0,0,91,2,0),COLOR00AAAA;
STICKLINE(J<0,0,91,1,0),COLOR00CCCC;
STICKLINE(J<0,0,91,0.2,0),COLOR00FFFF;
DRAWTEXT(J<0,80,'底');
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100,COLORFF00FF,LINETHICK1;
VAR1:=C-REF(C,1);
VAR29:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
STICKLINE(UP,0,-12,3,0),COLOR0000FF;
STICKLINE(DOWN,0,-12,3,0),COLOR00FF00;
STICKLINE(UP,98,110,3,0),COLOR0000FF;
STICKLINE(DOWN,98,110,3,0),COLOR00FF00;

通达信先胜短底指标公式

 

相关文章