在线检测未来函数

飞狐防线战略线指标公式

来源:Internet,编辑:股旁网,2015-05-26

DRAWBKBMP(C>=O or C<O,'moon');
VarA:=LLV(LOW,35);
VarB:=HHV(HIGH,30);
VarC:=EMA((CLOSE-VarA)/(VarB-VarA)*4,4)*25;
趋势: VarC,ColorFF00FF,linethick2;
底背: STICKLINE(VarC<10 and 100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))>97,0,25,5,0),COLORYELLOW;
顶背: STICKLINE(VarC>90,100,85,10,0),COLORRED;
VarD:=87.5;
VarE:=(VarC-LLV(VarC,4))/(HHV(VarC,4)-LLV(VarC,4))*4*25;
目标位: DRAWTEXT(IF(CROSS(趋势,VarD) AND VarE=100,50,0),56,'目标'),ColorFF00FF;
跑: DRAWTEXT(IF(CROSS(VarD,趋势),87,0),85,'跑'),Color00FF00;
卖: DRAWTEXT(IF(CROSS(趋势,VarE) AND 趋势>87,87,0),70,'卖'),Color00FF00;
Var6:=(2*C+H+L)/4;
Var8:=LLV(LOW,30);
VarA:=HHV(HIGH,30);
B:=EMA((Var6-Var8)/(VarA-Var8)*100,8);
B1:=EMA(B,5);
STICKLINE(B>0 AND B-B1>=0,79,80,6,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1<0,79,80,6,0),COLORCYAN;
STICKLINE(B>0 AND B-B1>=0,49,50,6,0),COLORRED;
STICKLINE(B>0 AND B-B1<0,49,50,6,0),COLORCYAN;
STICKLINE(B>0 AND B-B1>=0,19,20,6,0),COLOR00FF00;
STICKLINE(B>0 AND B-B1<0,19,20,6,0),COLORCYAN;
STICKLINE(B-B1>0,B,B1,8,1),COLORRED;
STICKLINE(B-B1<0,B,B1,8,1),Color00FF00;
V1:=(2*CLOSE+HIGH+LOW)/4;
V2:=LLV(LOW,21);
VA:=HHV(HIGH,34);
防线B:=EMA((V1-V2)/(VA-V2)*100,13);
防线BB:=EMA((0.667*REF(防线B,1)+0.333*防线B),2);
战略线:EMA(0.382*REF(防线B,2)+0.618*防线B,12),COLORYELLOW;

飞狐防线战略线指标公式

 

相关文章