在线检测未来函数

通达信突破上升趋势线主图及选股指标公式

来源:Internet,编辑:股旁网,2015-05-31

M5:MA(C,5);
M10:MA(C,10);
M20:MA(C,20);
M60:MA(C,60);
A:=M5>=M60 AND M10>=M60 AND M20>=M60;
T:=BARSLAST(CROSS(A,0.5));
JD:=(ATAN((M60/REF(M60,T)-1)*100)*180/3.1415926);
ZF:=(C-REF(C,T+1))/REF(C,T+1)*100;
LL:=MIN(MIN(M5,M10),M20);
TJ1:=EVERY(LL>M60,T);
TJ:=V=HHV(V,60) AND C>REF(C,1)*1.08 AND TJ1 AND ZF<60 AND JD>80;
T1:=BARSSINCEN(TJ,T+1);
EXT1:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),T1=0,REF(H,T1),1),COLORYELLOW,LINETHICK2;
TJA:=EVERY(C<EXT1,T1);
XG:=REF(TJA,1) AND CROSS(C,EXT1) AND T>30;
STICKLINE(XG,C,O,2,0),COLORMAGENTA;
STICKLINE(XG,H,L,0,0),COLORMAGENTA;

{
选股公式:

M5:=MA(C,5);
M10:=MA(C,10);
M20:=MA(C,20);
M60:=MA(C,60);
A:=M5>=M60 AND M10>=M60 AND M20>=M60;
T:=BARSLAST(CROSS(A,0.5));
JD:=(ATAN((M60/REF(M60,T)-1)*100)*180/3.1415926);
ZF:=(C-REF(C,T+1))/REF(C,T+1)*100;
LL:=MIN(MIN(M5,M10),M20);
TJ1:=EVERY(LL>M60,T);
TJ:=V=HHV(V,60) AND C>REF(C,1)*1.08 AND TJ1 AND ZF<60 AND JD>80;
T1:=BARSSINCEN(TJ,T+1);
NOTEXT1:=DRAWLINE(T=0,REF(H,T),T1=0,REF(H,T1),1);
TJA:=EVERY(C<NOTEXT1,T1);
REF(TJA,1) AND CROSS(C,NOTEXT1) AND T>30;
}

通达信突破上升趋势线主图及选股指标公式

 

相关文章