在线检测未来函数

飞狐主力行踪指标公式

来源:Internet,编辑:股旁网,2015-06-01

VAR2:=REF(LOW,1);
VAR3:=((SMA(ABS((LOW - VAR2)),13,1) / SMA(MAX((LOW - VAR2),0),13,1)) * 100);
VAR4:=EMA(IF((CLOSE * 1.2),(VAR3 * 13),(VAR3 / 13)),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=INTPART(((EMA(IF((LOW <= VAR5),((VAR4 + (VAR6 * 2)) / 2),0),3) / 618) * VAR7));
VAR9:=INTPART(EMA(CLOSE,5));
VAR10:=(((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * (0 - 10));
STICKLINE((VAR9 > REF(VAR9,1)),0,(VAR9 * 0.08),18,18),color10E410;
出货:(0 - IF((VAR9 > REF(VAR9,1)),VAR9,0)),STICK,LINETHICK5,colorFFFFFF;
STICKLINE((VAR9 < REF(VAR9,1)),0,(VAR9 * 0.08),4,1),color1010FF;
增仓:IF((VAR9 < REF(VAR9,1)),VAR9,0),STICK,LINETHICK2,color1010FF;
STICKLINE((VAR8 > REF(VAR8,1)),0,VAR8,4,1),color10FFFF;
主力:IF((VAR8 > REF(VAR8,1)),(VAR8 * 8),0),STICK,LINETHICK5,color10FFFF;
STICKLINE((VAR8 < REF(VAR8,1)),0,VAR8,4,1),colorFFF810;
洗盘:(0 - IF((VAR8 < REF(VAR8,1)),(VAR8 * 10),0)),STICK,LINETHICK5,colorFFF810;
仓位:INTPART((LOW * 5)),LINETHICK0,colorCCCDD10;
增减:INTPART(VAR10),colorFF7676;
DRAWTEXT((SYSPARAM(2) = BARPOS),CLOSE,''),ALIGN4,colorFFFF;
KXS:=SYSPARAM(1);
AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100);
BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100);
CC:=(AA - BB);
DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100);
EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW));
A1:=DYNAINFO(6);
A2:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01))));
A3:=(VOL / WINNER(LOW));
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=((100 * (CLOSE - A5)) / (A4 - A5));
A7:=((A2 > 0) OR (A2 = 1));
A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80));
A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4));
A10:=(A8 AND A9);
A11:=IF(FILTER(A8,3),5,0);
A12:=IF((FILTER(A10,3) OR EE),10,0);
XL1:=(MA(LOW,2) * 0.96);
XL2:=(MA(LOW,26) * 0.85);
DRAWTEXT(((KXS + 2) = BARSCOUNT(CLOSE)),1,(' ')),ALIGN4,colorFFFF;
XL3:=(((REF(XL1,1) < XL2) AND (REF(XL1,1) < XL1)) AND (REF(XL1,1) < REF(XL1,2)));
STICKLINE(XL3,0,(VAR8 * 3),18,0),color6EFF;
DRAWTEXT(XL3,(VAR8 * 2),'主\n力\n进\n场'),ALIGN4,colorFF;
短线突击队:=((100 * (CLOSE - LLV(LOW,21))) / (HHV(HIGH,21) - LLV(LOW,21)));
短线突击:=((100 * (INDEXC - LLV(INDEXL,21))) / (HHV(INDEXH,21) - LLV(INDEXL,21)));
个股:INTPART(SMA(短线突击队,3,1)),STICK,colorB0FFFF;
大盘:INTPART(SMA(短线突击,3,1)),LINETHICK2,colorFF00;
关注:STICKLINE(FILTER((个股 < 10),13),0,40,18,0),colorFF;
DRAWICON(CROSS(80,个股),80,2),ALIGN0;
离场:DRAWTEXT(CROSS(80,个股),82,'▲\n短\n线\n离\n场\n观\n望'),ALIGN4,LINETHICK2,color88518;

飞狐主力行踪指标公式

 

相关文章