在线检测未来函数

通达信锅里捞主图及选股指标公式

来源:Internet,编辑:股旁网,2015-06-11

LT:=LLVBARS(L,60);
LTT:=BARSLAST(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
EXT1:DRAWLINE(CURRBARSCOUNT=CONST(HT)+1,H,ISLASTBAR,REF(H,HT),0),COLORYELLOW,LINETHICK2;
TT:=BARSLAST(CURRBARSCOUNT=CONST(HT)+1);
DRAWLINE(TT=0,H,LTT=0,L,0),COLORYELLOW,LINETHICK2;
EXT2:DRAWLINE(LTT=0,(EXT1-L)*0.618+L,ISLASTBAR,REF((EXT1-L)*0.618+L,LTT),0)DOTLINE,COLORLIMAGENTA;
V1:=IF(C>O OR (C=O AND C>=REF(C,1)),VOL,0);
V2:=IF(C<O OR (C=O AND C<REF(C,1)),VOL,0);
LJ:=SUM(V1,LTT)/SUM(V2,LTT);
XG:=COUNT(CROSS(C>=EXT2,0.5),LTT+1)=1 AND CROSS(C>=EXT2,0.5) AND LJ>1.5;
DRAWICON(XG,L*0.95,25);
STICKLINE(XG,C,O,2,0),COLORYELLOW;
STICKLINE(XG,H,L,0,0),COLORYELLOW;
DRAWTEXT(LTT=0,L*0.98,'锅底'),COLORYELLOW;

{
选股公式:

LT:=LLVBARS(L,60);
LTT:=BARSLAST(CURRBARSCOUNT=CONST(LT)+1);
HT:=FINDHIGHBARS(H,LT+1,60,1);
TT:=BARSLAST(CURRBARSCOUNT=CONST(HT)+1);
HJ:=REF((REF(H,TT)-L)*0.618+L,LTT);
V1:=IF(C>O OR (C=O AND C>=REF(C,1)),VOL,0);
V2:=IF(C<O OR (C=O AND C<REF(C,1)),VOL,0);
LJ:=SUM(V1,LTT)/SUM(V2,LTT);
COUNT(CROSS(C>=HJ,0.5),LTT+1)=1 AND CROSS(C>=HJ,0.5) AND LJ>1.5;
}

通达信锅里捞主图及选股指标公式

 

相关文章