在线检测未来函数

通达信一线擒牛指标公式

来源:Internet,编辑:股旁网,2015-07-05

N:=4;
{日MACD}
日DIF:="MACD.DIF#DAY";
日DEA:="MACD.DEA#DAY";
日死叉:STICKLINE(日DIF<日DEA,100,99.9,5,0),COLORGREEN;
金叉:STICKLINE(日DIF>日DEA,100,99.9,5,0),COLORRED;
DRAWTEXT(ISLASTBAR,100,'日'),COLORWHITE;
{周MACD}
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周死叉:STICKLINE(周DIF<周DEA,34,33.9,5,0),COLORGREEN;
周金叉:STICKLINE(周DIF>周DEA,34,33.9,5,0),COLORRED;
DRAWTEXT(ISLASTBAR,33,'--周'),COLORYELLOW;
{月MACD}
月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
月死叉:STICKLINE(月DIF<月DEA,-10,-9.9,5,0),COLORGREEN;
月金叉:STICKLINE(月DIF>月DEA,-10,-9.9,5,0),COLORRED;
DRAWTEXT(ISLASTBAR,-7,'--月'),COLORLIGRAY;
LC:=REF(CLOSE,1);
风行操作线:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORWHITE;
IF(风行操作线>=REF(风行操作线,1),风行操作线,DRAWNULL),COLORRED,LINETHICK2;
顶部:100,COLORFFFF00,LINETHICK2,NODRAW;
强区:77,COLORFF85FF,DOTLINE;逃顶区:90,COLORYELLOW,DOTLINE;
生命线:34.00,COLORRED,NODRAW;
反弹:10,COLORYELLOW,DOTLINE;
底部:-10,COLORYELLOW,LINETHICK2,NODRAW;
DRAWTEXT(CURRBARSCOUNT=38,0,'底部区'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=38,20,'介入区'),COLORFF00FF;
DRAWTEXT(CURRBARSCOUNT=38,55,'安全区'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=38,83,'强势区'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=38,94,'逃顶区'),COLOR00FF00;

通达信一线擒牛指标公式

 

相关文章