在线检测未来函数

通达信乘风买卖指标公式

来源:Internet,编辑:股旁网,2015-07-31

BOLL20:=MA(CLOSE,20);
UB20:=BOLL20+2*STD(CLOSE,20);
LB20:=BOLL20-2*STD(CLOSE,20);
BOLL10:=MA(CLOSE,10);
UB10:=BOLL10+2*STD(CLOSE,10);
LB10:=BOLL10-2*STD(CLOSE,10);
N:=9;M:=3;
RSV:=(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100;
K:SMA(RSV,M,1),COLOREE90FF,LINETHICK2,NODRAW;
D:SMA(K,M,1),COLORFFFFFF,NODRAW;
J:IF(3*K-2*D>100,100,3*K-2*D),COLOR999000,NODRAW;
RSF6:100-SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100,COLOR00FFFF,LINETHICK2,NODRAW;
XXX2:DRAWLINE(CROSS(D,K),HHV(K,15),REF(CROSS(D,K),1),REF(HHV(K,15),1),1),COLORFFF000,DOTLINE;
XXX1:DRAWLINE(CROSS(K,D) AND REF(K,1)<35,LLV(K,15),REF(CROSS(K,D) AND REF(K,1)<35,1),REF(LLV(K,15),1),1),COLOR0000FF,DOTLINE;
DIF:=EMA(C,12)-EMA(C,26);
DEA:=EMA(DIF,9);
MACD:=20*(DIF-DEA);
MACDABS:=IF(PERIOD=1,10*ABS(MACD),IF(PERIOD=2,5*ABS(MACD),IF(PERIOD=3,4*ABS(MACD),IF(PERIOD=4,3*ABS(MACD),IF(PERIOD=5,2*ABS(MACD),ABS(MACD))))));
STICKLINE(MACD>0,MACDABS,0,2,1),COLORRED;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACDABS,0,2,1),COLORC0C0C0;
STICKLINE(MACD<0,MACDABS,0,2,1),COLORAA0000;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),MACDABS,0,2,1),COLOR2255DD;
RSF6,COLOR00FFFF,LINETHICK2;
K,COLOREE90FF,LINETHICK2;
D,COLORFFFFFF;
J,COLOR999000;
底部:IF((L<LB10 OR L<LB20) AND (J<0 OR K<20),85,100),COLORFFFFFF,LINETHICK2;
J抄底:IF(CROSS(J,0) AND (COUNT(L<LB10,3)>0 OR COUNT(L<LB20,3)>0),75,100),COLOR00FFFF,LINETHICK2;
K抄底:IF(CROSS(K,D) AND REF(K,1)<35 AND (COUNT(L<LB10,3)>0 OR COUNT(L<LB20,3)>0),75,100),COLORFF00FF,LINETHICK2;
高位风险:IF(H>UB20 AND H>UB10 AND K>95,25,0),COLOR00FF00,LINETHICK2;
背离风险:IF((H>UB20 OR H>UB10) AND MIN(UB20,UB10)/MAX(UB20,UB10)>0.95 AND K<HHV(K,20) AND COUNT(K>95,20)>0,35,0),COLORFF0000,LINETHICK2;

通达信乘风买卖指标公式

 

相关文章