在线检测未来函数

通达信淡定指金逃顶指标公式

来源:Internet,编辑:股旁网,2015-08-20

{使用说明:很简单的用法,出现黄柱个股就要准备逃顶了。}

VOLUME:=VOL,VOLSTICK;
MAVOL5:=MA(VOLUME,5);
MAVOL21:=MA(VOLUME,21);
MAVOL65:=MA(VOLUME,65);
STICKLINE(CROSS(MAVOL5,MAVOL21),5,8,2,0),COLORWHITE;
周DIF:=("MACD.DIF#WEEK");
周DEA:=("MACD.DEA#WEEK");
周MACD:=2*(周DIF-周DEA);
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9),COLORFFFF00;
MACD:=(DIFF-DEA)*2;
A1:BARSLAST(DIFF<REF(DIFF,1)),COLOR00FFFF,LINETHICK1;
A11:A1*-1,COLOR00FFFF,LINETHICK1;
A2:BARSLAST(DEA<REF(DEA,1)),COLORRED,LINETHICK1;
A22:A2*-1,COLORRED,LINETHICK1;
DRAWBAND(A2,RGB(150,50,20),A1,RGB(150,100,150));
DRAWBAND(A22,RGB(150,100,150),A11,RGB(150,50,20));
STICKLINE(周MACD>REF(周MACD,1) AND 周MACD>0,-5,5,18,0),COLORRED;
STICKLINE(周MACD<REF(周MACD,1) AND 周MACD>0,-5,5,18,0),COLORYELLOW;
STICKLINE(周MACD>REF(周MACD,1) AND 周MACD<0,-5,5,18,0),COLORLIRED;
STICKLINE(周MACD<REF(周MACD,1) AND 周MACD<0,-5,5,18,0),COLORBLUE;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,-3,3,3.5,1),COLORRED;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,-3,3,3.5,1),COLORLIRED;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,-3,3,3.5,1),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,-3,3,3.5,1),COLORBLUE;
DIIFF:=(EMA(A1,5) - EMA(A1,10));
DEAA:=EMA(DIIFF,3);
K线动能:=(DIIFF-DEAA),COLORYELLOW;
STICKLINE((K线动能 > 0),-1,1,1.5,0),COLOR0000FF;
STICKLINE((K线动能 < 0),-1,1,1.5,0),COLOR00FF00;
STICKLINE(CROSS(DIFF,DEA),0,0.04,5,1),COLORYELLOW;
STICKLINE(CROSS(DIFF,DEA),0.04,0.08,5,0),COLORRED;
STICKLINE(CROSS(DIFF,DEA),0.08,0.12,5,1),COLORYELLOW;
STICKLINE(CROSS(DIFF,DEA),0.12,0.16,4,1),COLORRED;
STICKLINE(CROSS(DIFF,DEA),0.16,0.2,3,1),COLORRED;
STICKLINE(CROSS(DIFF,DEA),0.2,0.24,2,0),COLORWHITE;
STICKLINE(CROSS(DIFF,DEA) AND DIFF<0,A11,0,2,0),COLORRED;
STICKLINE(CROSS(DIFF,DEA) AND DIFF>0,0,A1,2,0),COLORRED;
STICKLINE(CROSS(DEA,DIFF) AND DIFF<0,A11,0,2,0),COLORBLUE;
STICKLINE(CROSS(DEA,DIFF) AND DIFF>0,0,A1,2,0),COLORBLUE;
MACD底背离:
STICKLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),-25,25,0.00001,0),COLORYELLOW;
STICKLINE(A1>0 AND A2>0,A2,A1,0.00001,0),COLORFFFFFF;
STICKLINE(A1>0 AND A2>0,A22,A11,0.00001,0),COLORFFFFFF;
STICKLINE(A1>0 AND A2>0,0,A1,0.000001,0),COLORFF00FF;
STICKLINE(A1>0 AND A2>0,0,A11,0.000001,0),COLORGREEN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,-5,'〇'),COLORCYAN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,-12,'〇'),COLORCYAN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,5,'〇'),COLORGREEN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,12,'〇'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,A2,'∈'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,0,'∈'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,A22,'∈'),COLORGREEN;
STICKLINE(CROSS(DIFF,DEA) AND DIFF<0,A11,0,2,0),COLORRED;
STICKLINE(CROSS(DIFF,DEA) AND DIFF>0,0,A1,2,0),COLORRED;
STICKLINE(CROSS(DEA,DIFF) AND DIFF<0,A11,0,2,0),COLORBLUE;
STICKLINE(CROSS(DEA,DIFF) AND DIFF>0,0,A1,2,0),COLORBLUE;
N:=5;M1:=5;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,M1,5);
J:=3*K-2*D;
VARB2:=(RSV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
低买:=IF(黄金 AND RSV<VARB2-2,50,0);
高卖:=IF(黄金 AND RSV>VARB2,80,120);
上涨分界:=25;
KDJ提前金叉:(CROSS(上涨分界,低买)),COLORFF00FF,NODRAW;
DRAWTEXT(KDJ提前金叉,0,'⊙'),COLORFFFFFF;

通达信淡定指金逃顶指标公式

 

相关文章