在线检测未来函数

通达信资金紫薇仪指标公式

来源:Internet,编辑:股旁网,2015-08-20

N:=20;
M1:=5;
BOLL:MA(CLOSE,N);
UB:BOLL+2*STD(CLOSE,N);
LB:BOLL-2*STD(CLOSE,N);
MA1:MA(CLOSE,M1);
显示仪表盘1:=1;
涨幅周期:=350;
范围高A:=REFDATE(HHV(H,120),DATE)*1.05;
范围低A:=REFDATE(LLV(L,120),DATE)*0.95;
MA5:MA(C,5),COLORCYAN,LINETHICK2,NODRAW,COLORWHITE;
MA24:MA(C,24),COLORGREEN,LINETHICK2,NODRAW,COLORWHITE;
MA72:MA(C,72),COLORRED,LINETHICK2,NODRAW,COLORWHITE;
MA200:IF((MA(C,200)<=范围高A AND MA(C,200)>=范围低A) OR C>=MA(C,200),MA(C,200),DRAWNULL),COLORBLUE,LINETHICK2,NODRAW,COLORWHITE;
{=======================仪表盘=========================}
主升浪:=ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪回调:=ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>IF(MA200=DRAWNULL,0,MA200);
主浪深调:=ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>IF(MA200=DRAWNULL,0,MA200);
初升浪:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72;
底部反弹:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA5>MA24;
探底阶段:=ISLASTBAR AND IF(MA200=DRAWNULL,300,MA200)>MA72 AND MA72>MA24 AND MA24>MA5;
观望:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24>MA72 AND C<MA72,MA72>MA200 AND C<MA200);
有牛:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C>=MA72,MA72<MA200 AND C>=MA200);
放弃:=ISLASTBAR AND IF(MA200=DRAWNULL,MA24<MA72 AND C<MA72,MA72<MA200 AND C<MA200);
DRAWGBK(显示仪表盘1=1 AND 主升浪=0 AND 主浪回调=0 AND 主浪深调=0 AND 初升浪=0 AND 底部反弹=0 AND 探底阶段=0 AND 观望=0 AND 有牛=0 AND 放弃=0,0,0,0,'观望',0);
DRAWGBK(显示仪表盘1=1 AND 主升浪,0,0,0,'主升浪',0);
DRAWGBK(显示仪表盘1=1 AND 主浪回调,0,0,0,'主浪回调',0);
DRAWGBK(显示仪表盘1=1 AND 主浪深调,0,0,0,'主浪深调',0);
DRAWGBK(显示仪表盘1=1 AND 初升浪,0,0,0,'初升浪',0);
DRAWGBK(显示仪表盘1=1 AND 底部反弹,0,0,0,'底部反弹',0);
DRAWGBK(显示仪表盘1=1 AND 探底阶段,0,0,0,'探底阶段',0);
DRAWGBK(显示仪表盘1=1 AND 观望,0,0,0,'观望',0);
DRAWGBK(显示仪表盘1=1 AND 有牛,0,0,0,'有牛',0);
DRAWGBK(显示仪表盘1=1 AND 放弃,0,0,0,'放弃',0);
{===================彩色K线========================}
STICKLINE(C>O,C,O,3,0),COLOR0000AA;
STICKLINE(C>O,C,O,2.5,0),COLOR0000BB;
STICKLINE(C>O,C,O,1.5,0),COLOR0000CC;
STICKLINE(C>O,C,O,1,0),COLOR0000EE;
STICKLINE(C>O,H,L,0,0),COLOR0000FF;
STICKLINE(C<O,C,O,3,0),COLOR7B7B00;
STICKLINE(C<O,C,O,2.5,0),COLOR909000;
STICKLINE(C<O,C,O,1.5,0),COLORA8A800;
STICKLINE(C<O,C,O,1,0),COLORCECE00;
STICKLINE(C<O,H,L,0,0),COLORFFFF00;
STICKLINE(C=O,C,O,3,0),COLORWHITE;
STICKLINE(C=O,H,L,0,0),COLORWHITE;
{======================================================}
高点位:=REFDATE(HHV(H,总涨幅周期),DATE);
低点位:=REFDATE(LLV(L,总涨幅周期),DATE);
低位价:=REF(L,BARSLAST(低点位=L)),COLORGREEN;
高位价:=REF(H,BARSLAST(高点位=H)),COLORRED,NODRAW;
曾最大涨幅:=(高位价-低位价)/低位价*100;
当前涨幅:=(C-低位价)/低位价*100;
ZFA:=CON2STR(CONST(曾最大涨幅),2);
ZFB:=CON2STR(CONST(当前涨幅),2);
ZFC:=STRCAT('【曾最大涨幅】:',ZFA);
ZFD:=STRCAT(ZFC,'%');
ZFE:=STRCAT(ZFD,'【当前总涨幅】:');
ZFF:=STRCAT(ZFE,ZFB);
ZFG:=STRCAT(ZFF,'%');
DRAWTEXT_FIX(ISLASTBAR,0,1,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,1,0,ZFG),COLORYELLOW;
{========================额外==========================}
Z1:=STRCAT(DYBLOCK,' ');
Z2:=STRCAT(Z1,HYBLOCK);
Z3:=STRCAT(Z2,' ');
Z4:=STRCAT(Z3,GNBLOCK);
Z5:=STRCAT(Z4,' ');
Z6:=STRCAT(Z5,FGBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.01,0.012,0,STRCAT(Z6,ZHBLOCK)),COLORCYAN;
DRAWTEXT_FIX(1,0,0.075,0,STRCAT('【自定板块】:',ZDBLOCK)),COLORYELLOW;
{======================================================}
DRAWRECTREL(IF(CODELIKE('999999') OR CODELIKE('399001'),0,760),IF(CODELIKE('999999') OR CODELIKE('399001'),0,12),IF(CODELIKE('999999') OR CODELIKE('399001'),0,890),IF(CODELIKE('999999') OR CODELIKE('399001'),0,70),RGB(255,0,0));
DRAWRECTREL(IF(CODELIKE('999999') OR CODELIKE('399001'),0,760),IF(CODELIKE('999999') OR CODELIKE('399001'),0,12),IF(CODELIKE('999999') OR CODELIKE('399001'),0,890),IF(CODELIKE('999999') OR CODELIKE('399001'),0,70),IF(CONST(DYNAINFO(51))>=1,RGB(0,255,0),RGB(255,0,0)));
NNN1:=CON2STR(CONST(DYNAINFO(51)),2);
NNN2:=STRCAT('【 内外比:',NNN1);
NNN3:=STRCAT(NNN2,' 】');
DRAWTEXT_FIX(IF(CODELIKE('999999') OR CODELIKE('399001'),DRAWNULL,1),0.76,0.015,0,NNN3),COLORYELLOW;
DRAWTEXT_FIX(IF(CODELIKE('999999') OR CODELIKE('399001'),DRAWNULL,CONST(DYNAINFO(51))>=1),0.76,0.015,0,NNN3),COLORBLACK;
{=======================均线解盘===============================}
DRAWRECTREL(0,IF(显示仪表盘1=0,135,0),IF(显示仪表盘1=0,288,0),IF(显示仪表盘1=0,630,0),RGB(0,0,255));
DRAWTEXT_FIX(显示仪表盘1=0,0.08,0.16,0,'【 均线解盘 】'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.23,0,'主升浪: 5>24>72>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA5>MA24 AND MA24>MA72 AND MA72>MA200,0.238,0.23,0,'≡★≡'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.285,0,'主浪回调: 24>5>72>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA24>MA5 AND MA5>MA72 AND MA72>MA200,0.238,0.285,0,'≡★≡'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.34,0,'主浪深调: 24>72>5>200 '),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA24>MA72 AND MA72>MA5 AND MA5>MA200,0.238,0.34,0,'≡★≡'),COLORMAGENTA;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.395,0,'初升浪: 200>5>24>72'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MAX(MA24,MA72) AND MA5>MA24 AND MA24>MA72,0.238,0.395,0,'≡★≡'),COLOR0080FF;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.45,0,'底部反弹: 200>72>5>24'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MA72 AND MA72>MA24 AND MA5>MA24,0.238,0.45,0,'≡★≡'),COLORYELLOW;
DRAWTEXT_FIX(显示仪表盘1=0,0,0.51,0,'探底阶段: 200>72>24>5'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA200>MA72 AND MA72>MA24 AND MA24>MA5,0.238,0.51,0,'≡★≡'),COLORGREEN;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C>=MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORRED;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C>=MA200,0,0.565,0,'牛市行情: 72>200 C>200 牛市 ---'),COLORYELLOW;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72>MA200 AND C<MA200,0,0.565,0,'未知行情: 72>200 C<200 观望 ---'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C>=MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORMAGENTA;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C>=MA200,0,0.565,0,'初入牛市: 72<200 C>200 牛到 ---'),COLORWHITE;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C<MA200,0,0.565,0,'▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇▇'),COLORGREEN;
DRAWTEXT_FIX(显示仪表盘1=0 AND ISLASTBAR AND MA72<MA200 AND C<MA200,0,0.565,0,'熊市行情: 72<200 C<200 放弃 ---'),COLORBLACK;

通达信资金紫薇仪指标公式

 

相关文章