在线检测未来函数

同花顺最短趋势指标公式

来源:Internet,编辑:股旁网,2015-09-23

RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
操作线:SMA(RSV,3,1),COLORFF00FF,LINETHICK1;
趋势线:SMA(操作线,3,1),COLOR00FF00,LINETHICK1;
买卖差:=操作线-趋势线;
STICKLINE(买卖差>=0,(操作线-买卖差*0.05),(操作线-买卖差*0.15),3,0) ,COLOR00ffff;
STICKLINE(买卖差>=0,(操作线-买卖差*0.2),(操作线-买卖差*0.35),3,0) ,COLOR00ccff;
STICKLINE(买卖差>=0,(操作线-买卖差*0.4),(操作线-买卖差*0.55),3,0) ,COLOR0099ff;
STICKLINE(买卖差>=0,(操作线-买卖差*0.6),(操作线-买卖差*0.75),3,0) ,COLOR0066ff;
STICKLINE(买卖差>=0,(操作线-买卖差*0.8),(操作线-买卖差*0.95),3,0) ,COLOR0000cc;
STICKLINE(买卖差<0,(趋势线+买卖差*0.05),(趋势线+买卖差*0.15),3,0) ,COLOR006600;
STICKLINE(买卖差<0,(趋势线+买卖差*0.2),(趋势线+买卖差*0.35),3,0) ,COLOR009900;
STICKLINE(买卖差<0,(趋势线+买卖差*0.4),(趋势线+买卖差*0.55),3,0) ,COLOR00cc00;
STICKLINE(买卖差<0,(趋势线+买卖差*0.6),(趋势线+买卖差*0.75),3,0) ,COLOR00ff00;
STICKLINE(买卖差<0,(趋势线+买卖差*0.8),(趋势线+买卖差*0.95),3,0) ,COLOR66ff00;
超卖:20,colorwhite;
超买:80,colorblue;
DRAWTEXT(CROSS(操作线,趋势线),操作线,'▲'),LINETHICK2,COLORFF00FF;
DRAWTEXT(CROSS(趋势线,操作线),趋势线,'▼'),LINETHICK2,COLOR00FF00;
VC:=(2*C+H+L)/4;
VD:=LLV(L,34);
VE:=HHV(H,34);
VF:=LLV(L,21);
V10:=HHV(H,21);
V11:=EMA((VC-VF)/(V10-VD)*100,5);
V12:=EMA((VC-VD)/(VE-VD)*100,8);
V13:=EMA(V12,5);
STICKLINE(V12>0 AND (V12-V13)>=0 ,80 ,78 ,6 ,0 ),COLORFF00FF;
STICKLINE(V12>0 AND (V12-V13)<0 ,80 ,78 ,6 ,1 ),COLOR00FF00;
STICKLINE(V12>0 AND (V12-V13)>=0 ,20 ,18 ,6 ,0 ),COLORFF00FF;
STICKLINE(V12>0 AND (V12-V13)<0 ,20 ,18 ,6 ,1 ),COLOR00FF00;

同花顺最短趋势指标公式

 

相关文章