在线检测未来函数

通达信只做拉升主图指标公式

来源:Internet,编辑:股旁网,2015-10-15

N:=10;
P:=2;
P1:=2;
操作线:EMA(C,7),COLOR00FF00;
A:=(REF(操作线,1));
STICKLINE((操作线>A),A,操作线,6,0),COLOR00FF00;
STICKLINE((操作线<=A),A,操作线,6,0),COLOR0000FF;
VARA:=IF((CLOSE>150),91.3,0.91299998);
心愿红线:((MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4)+P*STD((MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,N),COLORYELLOW;
A1:=MA(C,2);{2日移动平均线}
A3:=(A1+心愿红线)/2;{2、心愿红线之和除2的平均线,也就是中心线}
IF (A1>心愿红线,A1,A3),COLORRED,LINETHICK2;{2日线大于心愿红线且2日线交叉A3线显示粗红线}
IF (A1>心愿红线,心愿红线,A3),COLORRED,LINETHICK2;{2日线大于心愿红线且心愿红线交叉A3线显示粗红线}
IF (A1<=心愿红线,A1,A3),COLOR00FF00,LINETHICK2;{2日线小于等于心愿红线且2日线交叉A3线显示粗绿线}
IF (A1<=心愿红线,心愿红线,A3),COLOR00FF00,LINETHICK2;{52日线小于等于心愿红线且心愿红线交叉A3线显示粗绿线}
A3,COLORWHITE,LINETHICK2;{中心线显示粗白线}
得意不能忘形:INTPART(C/0.913 )*0.913,POINTDOT,LINETHICK2,COLORYELLOW;
得意不能忘形+(0.913),POINTDOT,LINETHICK2,COLORRED ;
B:INTPART(C/3.652 )*3.652,POINTDOT,LINETHICK2,COLORRED;
B+(3.652),POINTDOT,LINETHICK2,COLORRED;
E:(得意不能忘形+得意不能忘形+(0.913))/2, POINTDOT,LINETHICK2,COLORRED;
VARC:=EMA(HIGH,21)/HIGH*CLOSE;
警戒:EMA(VARC,21)*1.18;

通达信只做拉升主图指标公式

 

相关文章