在线检测未来函数

大智慧理想买卖指标公式

来源:Internet,编辑:股旁网,2015-12-01

INPUT:N1(5,2,100),N2(26,2,100),N3(45,2,100),N4(7,2,100),换手率(5,1,20);
DIF1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
DEA1:=EMA(DIF1,N3);
DIF2:=EMA(CLOSE,N4)-EMA(CLOSE,N3);
DEA2:=EMA(DIF2,N4);
MACD:=2*(DIF1-DEA1);
MACDMA:=MA(MACD,N1);
STICKLINE(MACD>0,MACD,0,8,1),COLORred;
STICKLINE(MACD<0,MACD,0,8,1),COLORGREEN;
持股:STICKLINE(MACD>MACDMA AND MACD>0,MACD,MACDMA,8,0),COLOR9800FF;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3);
D:=MA(K,3);
TYP := (HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=(C/MA(C,5)-1)*100<-10;
A2:=(C/MA(C,13)-1)*100<-10;
A3:=(C/MA(C,34)-1)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
A6:=COUNT(ABS(C/REF(C,1)-1)*100>=6,30)>=1;
A7:=C>0.98*O and (C-REF(C,1))/REF(C,1)*100>=0 and (H-C)/C*100<=2;
A8:=C>0.98*O and (O-L)/C*100>=3;
A9:=C>0.98*O and (C-REF(C,1))/REF(C,1)*100>=3;
A10:=C>0.98*O and (H-L)/C*100<=5 and (C-REF(C,1))/REF(C,1)*100>=-2;
A11:=(C-L)/C*100>4;
hs:=(v/capital)*100>=换手率;
DB:=A1 AND A2 AND A3 AND A4 AND A5 AND A6;
底部:STICKLINE(db,(MACD*0.5),MACD,4,0),COLORffaaff;
gmbz:=REF(db,1) and (A7 or A8 or A9 or A10 or A11) and hs;
敢买就涨:STICKLINE(gmbz,0,MACD,8,0),COLORyellow;
DRAWTEXT(gmbz,(MACD*1.1),'必杀'),COLORWHITE;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,20);
v3:=EMA(((CLOSE-V1)/(V2-V1))*((-100)),3);
V4:=((CLOSE)/(REF(CLOSE,5))>=1.15);
{V5:=BACKSET(V4,5);
介入:IF((V5 AND (COUNT(V5,5)=1) or (CLOSE>=HHV(HIGH,HIGH))
AND ((CLOSE)/(REF(CLOSE,1))>1.098) AND (REF(VOL,LOW)>REF(VOL,34))
AND (REF(VOL,LOW)>REF(VOL,1)) AND (V3>(-93))
AND (REF(VOL,LOW)>REF(VOL,8))),-1.4,0),Stick,COLORblue,linethick5;
DRAWTEXT(介入 AND (V3<(-75)),(-1),'关注'),COLORWHITE;}
V6:=100-3*SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,90)-LLV(LOW,29))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,90)-LLV(LOW,29))*100,20,1),15,1);
V7:=100-3*SMA((OPEN-LLV(LOW,34))/(HHV(HIGH,90)-LLV(LOW,29))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,34))/(HHV(HIGH,90)-LLV(LOW,29))*100,20,1),15,1);
V8:=V6<REF(V7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
BYCG:=(V8 AND COUNT(V8,30)=1 and c<ema(c,20) and ma(c,20)>ma(c,200));
不要错过:STICKLINE(BYCG,0,macd,8,0) ,COLORred;
DRAWTEXT(BYCG,(MACD*1.2),'必杀'),COLORWHITE;
QSX:=(1.06*(3*SMA((CLOSE- LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)+50);
DRAWTEXT(CROSS(QSX,8.5),(MACD*1.2),'买'),COLOR0000FF;
DRAWTEXT(CROSS(87,Qsx),(MACD*1.1),'逃'),COLORFFFFFF;
V9:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
V10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
V11:=V9<REF(V10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(V11 AND COUNT(V11,30)=1,(MACD*1.1),'大资金进场'),coloryellow;
DRAWTEXT(V11 AND COUNT(V11,30)=1,1.5,'$'),CoLorwhite;
HLM1:=MA(HHV(H,485),17);
HLM2:=MA(HHV(H,222),17);
HLM3:=MA(HHV(H,96),17);
HLM4:=MA(LLV(L,485),17);
HLM5:=MA(LLV(L,222),17);
HLM6:=MA(LLV(L,96),17);
HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);
HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);
HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);
HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);
HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
HLM12:=MA(IF(C*1.35<=HLM10,HLM11*10,HLM11/10),3);
HLMH:=HHV(HLM12,30);
关注:=MA(IF(L<=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200;
DRAWTEXT(CROSS(关注,1.2),-1,'▲'),ColorFF00ff;
DRAWTEXT(CROSS(关注,4.5),(MACD*1.1),'买点'),Color00Ffff;
DRAWICON(CROSS(关注,7.0),(MACD*1.5),1);
{见底信号}
qsx1:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100;
备钱:=((ref(qsx1,1)<ref(qsx1,2) and qsx1<-30) and qsx1>=ref(qsx1,1)) or (ref(cross(-30,qsx1),1) and cross(qsx1,-30)) or qsx1=-30;
DRAWTEXT(备钱,1.5,'¥'),CoLorwhite;
bb:=((ref(qsx1,1)<ref(qsx1,2) and qsx1<-20 and qsx1>-25) and qsx1>=ref(qsx1,1)) or (ref(cross(-20,qsx1),1) and cross(qsx1,-20));
见底信号:STICKLINE(bb,0,MACD,8,0),COLORwhite;
DRAWTEXT(bb,-0.9,'≌'),CoLorwhite;
顶:=97;
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
底:=8;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
VAR14:=HHV(HIGH,50)/LLV(LOW,100)>1.5;
VAR15:=(HHV(HIGH,50)-LOW)/(HHV(HIGH,50)-LLV(LOW,100));
VAR16:=(LOW-LLV(LOW,100))/(HHV(HIGH,50)-LLV(LOW,100));
VAR17:=HHVBARS(HIGH,50)<LLVBARS(LOW,100);
VAR18:=VAR14 AND VAR15>0.5 AND VAR16>0.3 AND VAR17;
VAR19:=COUNT(VAR18,20)=1;
反弹:IF(VAR19 AND VAR18 ,-1.4,0),STICK,LINETHICK4,COLOR00f0FF;
DRAWTEXT(抢反弹,-1.5,'反弹'),COLOR00f0FF;
VAR2W:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:= EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND M1<20;
马池: IF(趋势<11,2,0),COLORf0FF0F,LINETHICK2;
抄底: IF(CROSS(趋势,底),2,0),COLOR6666FF,LINETHICK2;
qw1:=(HIGH+LOW+CLOSE*2)/4;
qw3:=EMA(qw1,10);
qw4:=STD(qw1,10);
qw5:=(qw1-qw3)*100/qw4;
qw6:=EMA(qw5,5);
rk7:=EMA(qw6,10);
涨:=EMA(qw6,10)+100/2-5;
跌:=EMA(涨,4);
多线:=IF(cross(涨,跌) and 跌<-10,30,0);
空线:=IF(cross(跌,80),70,100);
买1:=ema(跌,4);
买2:=ema(买1,4);
买m3:=ema(买2,4);
买m4:=ema(买m3,4);
DRAWTEXT(cross(涨,跌) and 跌<20 and 跌>-10,-1.2,'买入'),colorccff99;
DRAWTEXT(多线>0,-1.2,'看涨'),color0000ff;
x:=c-ref(ma(c,20),11);
lgl:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 and c/ref(c,1)>0.905 and c/ref(c,1)<1.05 and VOL/CAPITAL*100<5,50,0);
wr1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*x;
wr2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
wr3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*x;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
s1:=(wr1+wr2+wr3+bias1+bias2+bias3)/6*x;
s2:=ema(s1,3);
s3:=abs(bias1-bias3);
sx:=(s1+s3)/2;
xc1:=(-1)*(ema(100*(1-WINNER(CLOSE)),1)-50)+50;
ccc:=xc1+sx;
zjz:=IF( lgl>0 and ccc<0,200,0)*x;
lxl:=if(sx<0 and c=llV(c,5) and c/ref(c,1)>0.905 and c/ref(c,1)<1.05 and VOL/CAPITAL*100<5,-50,0);
jbj:=if(ccc<0 and lxl=-50,100,0)*x;
ma3:= ma(c,3);
c0:=ref(c,2)*0.865;
c1:=ref(c,13)*0.772;
bot:=MIN(c0,c1);
hsl:=100*vol/capital*x;
ma13:=ma(c,13)*x;
cxc:=if((c-bot)/c<3/100 and sum(hsl,5)/5<1.8,1,0);
vmc:=if(cxc>0 and (lxl<0 or lgl>0),10,0);
满仓:=if((vmc>0),120,0);
DRAWTEXT(满仓>0 AND REF(满仓,1)=0,-1.2,'满仓'),colormagenta;

大智慧理想买卖指标公式

 

相关文章