在线检测未来函数

通达信红箭齐发指标公式

来源:Internet,编辑:股旁网,2015-12-01

N:=9;
M1:=2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M1,1);
J:=3*K-2*D;
XG:=CROSS(J,0);
DIF:=(EMA(CLOSE,15) - EMA(CLOSE,26)),COLORRED;
DEA:=EMA(DIF,5),COLOR00FFFF;
MACD:2*(DIF-DEA), COLORSTICK;
DIF2:4*DIF-3*DEA,COLORFF00FF;
DEA2:=EMA(DIF2,1),COLOR2588FF;
IF(C>DEA2,DEA2,DRAWNULL),COLOR0000F0,LINETHICK3;
IF(DEA2<=REF(DEA2,1),DEA2,DRAWNULL),COLOR00E600,LINETHICK3;
XG2:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4);
STICKLINE(XG2,3,MACD,2,0),COLORFF00FF;
分界线:0,COLORFF00FF;
DRAWICON(XG2,16,1);
DRAWICON(XG AND XG2,5,1);
DRAWTEXT(XG AND XG2,4,'←红箭齐发'),COLOR00FFFF;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.8,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,1.1,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD>0,0,MACD,0.6,0),COLOR40FF00;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR000055;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR000099;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR0000BB;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.8,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,1.1,0),COLOR40FF00;
STICKLINE(MACD<=REF(MACD,1) AND MACD<0,0,MACD,0.6,0),COLOR40FF00;

通达信红箭齐发指标公式

 

相关文章