在线检测未来函数

通达信顶底三线主图指标公式

来源:Internet,编辑:股旁网,2015-12-02

{底部三线}
XQ1:=1130218;
XZ1:=1130529;
下降趋势线:DRAWLINE(DATE=XQ1,H,DATE=XZ1,H,1)DOTLINE,COLORCYAN;
XZ2:=1130912;
止跌整理:DRAWLINE(DATE=XZ1,H,DATE=XZ2,H,1)DOTLINE,COLORYELLOW;
起涨整理:DRAWLINE(DATE=XZ2,H,REF(DATE=XZ2,1),REF(H,1),1),COLORRED;
DRAWBAND(下降趋势线,RGB(200,80,0),止跌整理,RGB(200,0,200));
DRAWBAND(止跌整理,RGB(180,80,0),起涨整理,RGB(100,0,0));
{顶部三线}
QD1:=1140620;
ZD1:=1141027;
上涨趋势线:DRAWLINE(DATE=QD1,L,DATE=ZD1,L,1)DOTLINE,COLORRED;
ZD2:=1150209;
上涨趋势线2:DRAWLINE(DATE=ZD1,L,DATE=ZD2,L,1)DOTLINE,COLORYELLOW;
ZD3:=1150709;
强势整理线:DRAWLINE(DATE=ZD2,L,DATE=ZD3,L,1)DOTLINE,COLORLICYAN;
弱势整理线:DRAWLINE(DATE=ZD3,L,REF(DATE=ZD3,1),REF(L,1),1),COLORCYAN;
弱势整理线2:DRAWLINE(DATE=ZD2,L,REF(DATE=ZD2,1),REF(L,1),1),COLORLIBLUE;
STICKLINE(上涨趋势线2>强势整理线,上涨趋势线2,强势整理线,5,0),COLORLIGREEN;
{DRAWBAND(上涨趋势线2,RGB(200,80,0),强势整理线,RGB(40,0,250));}
STICKLINE(强势整理线>弱势整理线,强势整理线,弱势整理线,5,0),COLORBLUE;
{DRAWBAND(强势整理线,RGB(0,100,0),弱势整理线,RGB(0,0,200));}
STICKLINE(上涨趋势线>弱势整理线2,上涨趋势线,弱势整理线2,5,0),COLORLIBLUE;
{DRAWBAND(上涨趋势线,RGB(180,80,0),弱势整理线2,RGB(100,0,200));}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE) ;

通达信顶底三线主图指标公式

 

相关文章