在线检测未来函数

飞狐主力强度指标公式

来源:Internet,编辑:股旁网,2016-01-05

Q:=(2*CLOSE+HIGH+LOW)/4;
A1:=LLV(LOW,24);
A2:=HHV(HIGH,24);
A:EMA((Q-A1)/(A2-A1)*100,13),colorred,linethick1;
B:EMA(0.667*REF(A,1)+0.333*A,3),color00ff00,linethick1;
力度:=A-B,linethick0,COLORGREEN;
STICKLINE((A-B)>0,A,B,6,1),COLORRED;
STICKLINE((A-B)<0,A,B,6,1),COLORgreen;
DRAWICON(力度>3,B,12);
DRAWICON(力度<-3,A,11);
STICKLINE(CROSS(A,B),20,50,6,1),COLORRED;
STICKLINE(CROSS(B,A),80,50,6,1),colorgreen;
DRAWICON(CROSS(A,B),50,8);
DRAWICON(CROSS(B,A),50,9);
Var1:=VOL/SUM(VOL,13);
Var2:=DMA(CLOSE,Var1);
主力强度:=(CLOSE-Var2)/Var2*100/2.5,LINETHICK0;
Va1:=EMA(CLOSE,8);
Va2:=EMA(Va1,20);
Va3:=CROSS(Va1,Va2);
Va4:=Va1<MA(CLOSE,120);
A3:=Va3 AND Va4 AND 主力强度>1.6;
A4:=CROSS( 主力强度,0 ) and 主力强度>1.5 ;
追涨:A4>0 or A3>0,COLORWHITE;
STICKLINE(←追涨>0,0,20,6,0),COLORgreen;
DRAWTEXT(←追涨>0,15,'←追涨'),COLORWHITE;
Var22:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
Var3:=IF(CLOSE>OPEN,Var2*(HIGH-LOW),IF(CLOSE< OPEN,Var2*(HIGH-OPEN+CLOSE-LOW),VOL/2))/(IF(CLOSE>OPEN,0-Var2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE< OPEN,0-Var2*(HIGH-LOW),0-VOL/2))*(-1))-IF(CLOSE>OPEN,0-Var2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE< OPEN,0-Var2*(HIGH-LOW),0-VOL/2))*(-1)/IF(CLOSE>OPEN,Var2*(HIGH-LOW),IF(CLOSE< OPEN,Var2*(HIGH-OPEN+CLOSE-LOW),VOL/2));
Var4:=IF(CLOSE>OPEN,Var2*(HIGH-LOW),IF(CLOSE< OPEN,Var2*(HIGH-OPEN+CLOSE-LOW),VOL/2))-IF(CLOSE>OPEN,0-Var2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE< OPEN,0-Var2*(HIGH-LOW),0-VOL/2))*(-1);
Var5:=IF(CLOSE>OPEN,Var2*(HIGH-LOW),IF(CLOSE< OPEN,Var2*(HIGH-OPEN+CLOSE-LOW),VOL/2));
Var6:=IF(CLOSE>OPEN,0-Var2*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE< OPEN,0-Var2*(HIGH-LOW),0-VOL/2))*(-1);
买比:= Var5/VOL*100,COLORYELLOW;
卖比:= Var6/VOL*100, COLOR00ffff;
中线买:=MA(买比,10),LINETHICK1,colorred;
中线卖:=MA(卖比,10),LINETHICK1,colorgreen;
金豆豆:DRAWICON(CROSS(中线买,55),105,12);
苦豆豆:DRAWICON(CROSS(中线卖,55),105,11),ColorFF8900;
{BIAS乖离率}
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
抄底:IF(乖离<-12 AND 乖离>=-18,-15,0), COLOR00ffff,STICK;
STICKLINE(乖离<-12 AND 乖离>=-18,-15,0,6,0) , COLOR00ffff;
DRAWTEXT(乖离<-12 AND 乖离>=-18,-12,'←抄底'),COLORWHITE;
抄底二:IF(乖离<-18,50,0),ColorFF35FF;
STICKLINE(乖离<-18,50,0,3 ,0),ColorFF35FF;
Var11:=DMA(CLOSE,VOL/MA(VOL,4)/4);
Var02:=DMA(CLOSE,VOL/MA(VOL,31)/31);
Var33:=(CLOSE-Var1)/Var1*100<-10;
Var44:=(Var1-Var2)/Var2*100<-16;
Var55:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
Var66:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
Var7:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
Var8:=INDEXC;
Var9:=MA(Var8,6);
VarA:=MA(Var8,24);
VarB:=MA(Var8,32);
VarC:=VarB>Var9*1.11 AND VarA>Var9*1.095;
sss:=(Var3 AND Var4 AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 OR Var5 AND Var6 AND CROSS(Var7,79) OR VarC AND CLOSE/COST(8)<=0.8)*100;
抄底王:sss>0,colorWHITE;
STICKLINE(sss>0,0,20,6,0),colorWHITE;
0,colorgreen;
50,POINTDOT,colorwhite;
80,POINTDOT,colorwhite;

飞狐主力强度指标公式

 

相关文章