在线检测未来函数

通达信底位黑马主图指标公式

来源:Internet,编辑:股旁网,2016-01-13

DRAWBAND(MA(CLOSE,60),RGB(55,0,0),MA(CLOSE,120),RGB(0,91,0));
DRAWBAND(MA(CLOSE,5),RGB(155,50,50),MA(CLOSE,10),RGB(83,123,68));
DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA;
MA30:=MA(CLOSE,30);
MA60:MA(CLOSE,60),COLORGREEN,LINETHICK1;
MA120:MA(CLOSE,120),COLORLIRED,LINETHICK1;
MA240:MA(CLOSE,240),COLORBLUE;
DRAWICON(CROSS(MA10,MA20),MA20,1); {10日上穿20日做记号}
DRAWICON(CROSS(MA20,MA60),MA60,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA120),MA120,1); {20日上穿60日做记号}
DRAWICON(CROSS(MA20,MA240),MA240,1);{20日上穿120日做记号}
DRAWICON(CROSS(MA60,MA120),MA60,1); {60日上穿120日做记号}
DRAWICON(CROSS(MA60,MA240),MA240,1); {60日上穿240日做记号}
DRAWICON(CROSS(MA120,MA240),MA240,1);{120日上穿240日做记号}
DRAWICON(CROSS(MA20,MA10),MA20,2); {10日下穿20日做记号}
DRAWICON(CROSS(MA60,MA20),MA60,2); {20日下穿60日做记号}
DRAWICON(CROSS(MA120,MA60),MA120,2); {60日下穿120日做记号};
RSVC:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
白马:=SMA(RSVC,3,1);
DC:=SMA(白马,3,1),LINETHICK1;
主升线:=3*白马-2*DC,COLORYELLOW,LINETHICK1;
RSVV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短K:=SMA(RSVV,3,1);
短D:=SMA(短K,3,1);
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
长K:=SMA(RSV1,5,1);
长D:=SMA(长K,10,1);
回归斜率线A:=EMA(SLOPE(C,4)*20+C,42);
经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
经典K:=SMA(经典RL,3,1); 经典D:=SMA(经典K,3,1); 经典J:=3*经典K-2*经典D;
MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))) /(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
MAHL2:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}
MAHL3:=IF(EMA(C,2)>回归斜率线A AND MAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}
上线:=SMA(C,6.5,1);
一号支撑线:=SMA(C,14.5,1);
上线1:=SMA(C,3,1);
一号支撑线1:=SMA(C,8,1);
上线2:=SMA(C,3.5,1);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,55),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
A7:=(2*C+H+L)/4;
操作:=MA(A7,5),COLORBLUE,LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
DRAWTEXT(长K>长D AND 短D>REF(短D+2,1) AND CROSS(上线1,上线) AND 上线1>操作,LOW *0.92,'买进' ),COLORYELLOW;
VAR1:=LLV(A7,21);
VAR2:=HHV(A7,30);
DRAWTEXT(CROSS(上线1,操作) AND 上线1<一号支撑线 AND 上线1<一号支撑线1 AND 上线1<上线 AND CLOSE>VAR1 AND (C-REF(H,1)>0 OR C-REF(C,1)>3.5) AND 长D-长K<15 AND 短D>REF(短D+0.1,1),LOW *0.98,'见底' ),COLORYELLOW;
YCX:=操作>=REF(操作,1);
H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);
L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);
DRAWTEXT(长K>长D AND COUNT(MA5>MA10 ,2)=2 AND CROSS(上线1,一号支撑线1) AND 上线1>操作 ,LOW *0.98,'全仓' ),COLORYELLOW;
SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
M1:=1000*操作/一号支撑线<=1015 AND 1000*操作/一号支撑线>=975;
M2:=1000*一号支撑线1/一号支撑线<=1020 AND 一号支撑线1/一号支撑线>=980;
M3:=1000*上线/一号支撑线<=1015 AND 上线/一号支撑线>=985;
DRAWTEXT((长K>长D OR 主升线>85) AND IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进') ,COLORYELLOW;
D:=MA(CLOSE,89)-MA(CLOSE,10)/3;
DRAWTEXT(长K>长D AND IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;
RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;
K:=SMA(RSV,3,1);
D1:=SMA(K,3,1);
J:=3*K-2*D1;
VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}
VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}
E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;
F:=MA(E,3)+0.03;
G:=MA(E,1);
主升:=C/REF(C,1)>=1.043;
DRAWICON(长K/长D<1.3 AND CROSS(F,G) AND J>65,HIGH*1.02,15),COLORGREEN;
DRAWICON(长K>长D AND 短D>REF(短D+2,1) AND CROSS(G,F),LOW *0.9,9),COLORYELLOW;
DRAWTEXT(短D>REF(短D+0.5,1) AND CLOSE>OPEN AND H1<C AND O<L1 AND YCX AND CROSS(上线1,操作) AND LOW>VAR1 AND 上线1>一号支撑线 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(短D>REF(短D+0.5,1) AND CLOSE>OPEN AND 上线>一号支撑线1 AND 一号支撑线1>一号支撑线 AND CLOSE>MA(CLOSE,一号支撑线) AND 操作>=REF(CLOSE,操作) AND CROSS(上线1,操作) AND LOW>VAR1 AND J<90,LOW *0.9,'主升' ),COLORRED;
DRAWTEXT(长K>长D AND 短D>REF(短D+2,1) AND CROSS(上线1,操作) AND M1 AND M2 AND M3,LOW *0.94,'买进' ),COLORYELLOW;
DRAWTEXT(长K/长D>1.3 AND CROSS(50,主升线),LOW *0.96,'回买' ),COLORRED;

通达信底位黑马主图指标公式

 

相关文章