在线检测未来函数

飞狐资金盘解指标公式

来源:Internet,编辑:股旁网,2016-01-18

DRAWGBK(1,colorrgb(0,0,100),colorrgb(0,0,0),1);
VARIABLE:WDAY[7]='星期六';
WDAY[1]:='星期日';
WDAY[2]:='星期一';
WDAY[3]:='星期二';
WDAY[4]:='星期三';
WDAY[5]:='星期四';
WDAY[6]:='星期五';
FY:=YEAR;
FM:=MONTH;
FD:=DAY;
WD:=WEEKDAY;
P:=SYSPARAM(1);
STR1:=''+'今日: '+NUMTOSTR(FY[P],0)+'年'+NUMTOSTR(FM[P],0)+'月'+NUMTOSTR(FD[P],0)+'日 '+WDAY[WD[P]+1];
DRAWTEXTEX(CLOSE,1,480,22,STR1),colorDDFF;
AA:=VOL/((HIGH-LOW)*2-(ABS(CLOSE-OPEN)));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*(HIGH-OPEN+CLOSE-LOW),VOL/2));
主动卖盘:=IF(CLOSE>OPEN,-AA*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,-AA*(HIGH-LOW),-VOL/2));
卖盘:=VOL-主动买盘;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((CLOSE-V1)/(V2-V1)*4,4);
DRAWTEXT(CROSS(价位线,0.45),AA,'买'),color0000FF;
DRAWTEXT(CROSS(3.1,价位线),AA,'卖'),colorFF00;
VERTLINE(CROSS(价位线,0.45)),color0000FF,LINEDASHDOT;
VERTLINE(CROSS(3.1,价位线)),colorFF00,LINEDASHDOT;
WJ:=(HIGH+LOW+CLOSE)/3;
VD1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
VD2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-WJ);
VD3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
VD4:=IF(HIGH=LOW,1,WJ-MIN(CLOSE,OPEN));
VD5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
VD6:=VD1*VD5;
VD7:=VD2*VD5;
VD8:=VD3*VD5;
VD9:=VD4*VD5;
买入量:=VD9+VD8;
卖出量:=VD6+VD7;
卖量:=VOL-买入量;
卖量大:=(卖量-买入量)/卖量>0.4;
买量大:=(买入量-卖量)/买入量>0.4;
买入资金:=买入量*CLOSE/100;
卖出资金:=卖出量*CLOSE/100;
资金进出:=买入资金-卖出资金;
十天资金:=SUM(资金进出,10),Color7D9585;
五天资金:=SUM(资金进出,5),ColorC0C0C0;
三天资金:=SUM(资金进出,3),Color00971B;
一天资金:=SUM(资金进出,1),Color4040A6;
量5:=MA(VOL,5),colorred;
量10:=MA(VOL,10);
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:VOL,POINTDOT,COLORE4C1EE;
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主动卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(VOL>0,VOL,0,8,0),ColorA697AF;
STICKLINE(主动买盘>0,0,主动买盘,7,0),color6F41ED;
STICKLINE(主动卖盘>0,0,主动卖盘,5,0),COLOR6CD100;
PARTLINE(MA(VOL,5)>=REF(MA(VOL,5),1),MA(VOL,5)),COLORRED,LINETHICK2;
PARTLINE(MA(VOL,5)<=REF(MA(VOL,5),1),MA(VOL,5)),COLOR00C700,LINETHICK2;
换手率:IF(CAPITAL=0,INDEXV/ESTDATA(12),VOL/FINANCE(7)),PRECISION2,LINETHICK0;
买卖比:=主动买盘/主动卖盘;
买卖资金比:=买入资金/卖出资金;
挂单买盘:=MA(主动买盘,3);
挂单卖盘:=(MA(主动卖盘,3));
yyzq:=(sysparam(3)-sysparam(2));
FILL:=barscount(c)>SYSPARAM(2) and barscount(c)<if(sysparam(3)-sysparam(2)>20,SYSPARAM(2)+INTPART(yyzq/2),20);
pich:=refx(hhv(成交,yyzq),yyzq);
picl:=refx(llv(挂单卖盘,yyzq),yyzq);
fillrgn(fill,refx(pich,yyzq),refx(picl,yyzq)),Color000093;
DRAWTEXTEX(CLOSE,1,230,80,'■一天资金:'+NUMTOSTR(一天资金[SYSPARAM(1)],2)+'\n'+'■三天资金:'+NUMTOSTR(三天资金[SYSPARAM(1)],2)+'\n'+'■五天资金:'+NUMTOSTR(五天资金[SYSPARAM(1)],2)+'\n'+'■十天资金:'+NUMTOSTR(十天资金[SYSPARAM(1)],2)),ALIGN4,colorCCFFCC;
DRAWTEXTEX(c,100,1,120,'┃当日买卖总量 = '+NUMTOSTR(VOL,2)),ColorA6B7F3;
DRAWTEXTEX(c,100,1,200,'┃当日主动买量 = '+NUMTOSTR(主动买盘,2)),Color0000FF;
DRAWTEXTEX(c,100,1,280,'┃当日主动卖量 = '+NUMTOSTR(主动卖盘,2)),Color00FF00;
DRAWTEXTEX(c,100,1,360,'┃当日买卖比 : '+NUMTOSTR(买卖比,2)),ColorFF00FF;
DRAWTEXTEX(c,100,1,440,'┃买入资金累计万元 : '+NUMTOSTR(买入资金,2)),Colorred,LINETHICK1;
DRAWTEXTEX(c,100,1,520,'┃卖出资金累计万元 : '+NUMTOSTR(卖出资金,2)),Color00ff00,LINETHICK1;
DRAWTEXTEX(c,100,1,600,'┃资金进出万元 : '+NUMTOSTR(资金进出,2)),Coloryellow,LINETHICK1;
DRAWTEXTEX(c,100,1,680,'┃买卖资金比 : '+NUMTOSTR(买卖资金比,2)),Coloryellow,LINETHICK1;
DRAWTEXTEX(c,100,1,760,'┃当日挂单买盘 : '+NUMTOSTR(挂单买盘,2)),Colorred,LINETHICK1;
DRAWTEXTEX(c,100,1,840,'┃当日挂单卖盘 : '+NUMTOSTR(挂单卖盘,2)),Color00ff00,LINETHICK1;

飞狐资金盘解指标公式

 

相关文章