在线检测未来函数

通达信征战涨停指标公式

来源:Internet,编辑:股旁网,2016-02-01

DRAWGBK(C>0,RGB(28,28,28),RGB(28,28,28),0,'',0);
峰谷周期:=5;峰谷虚实:=1;高量周期:=10;M周期内:=1;
XA_3:=REF(CLOSE,1);
XA_4:=ISLASTBAR AND CLOSE<500;
XA_5:=VOL;
XA_6:=MA(VOL,5);
XA_7:=XA_5<=LLV(XA_5,100)*1;
XA_8:=COUNT(XA_7,5)>=3 OR XA_6<=LLV(XA_6,100) AND XA_5>0 AND BARSCOUNT(XA_5)>=100;
XA_9:=FILTER(XA_8,5);
XA_10:=VOL>=REF(VOL,1)*1.9 AND CLOSE>XA_3;
XA_11:=HIGH<0.382*HHV(HIGH,240) OR LOW<1.382*LLV(LOW,240);
XA_12:=VOL<0.382*HHV(VOL,240) AND MA(VOL,5)<=MA(VOL,40);
XA_13:=XA_12 AND XA_11;
XA_14:=VOL/REF(VOL,1)>=1.1;
XA_15:=CLOSE>OPEN AND BETWEEN(VOL/REF(VOL,1),1.1,2.5);
XA_16:=CLOSE>REF(CLOSE,1) AND REFX(LLV(MIN(CLOSE,OPEN),3),3)>=LOW;
XA_17:=XA_14 AND XA_16;
XA_18:=XA_17 AND XA_13;
XA_19:=CLOSE>OPEN AND CLOSE<REFX(OPEN,1) AND REFX(XA_16,1);
XA_20:=LLV(MIN(OPEN,CLOSE),3);
XA_21:=0.97*MA(VOL,3)<=REF(VOL,3);
XA_22:=REF(CLOSE>XA_3 AND VOL>1.1*REF(VOL,1),3) AND CLOSE>=REF(CLOSE,3) AND REF(CLOSE>=OPEN,3) AND XA_20>=REF(OPEN,3) AND XA_21;
XA_23:=BARSLAST(XA_22);
XA_24:=REF(XA_20,XA_23);
XA_25:=REF(CLOSE,XA_23+3);
XA_26:=REF(OPEN,XA_23+3);
XA_27:=峰谷周期;
XA_28:=IF(峰谷虚实=0,HIGH,MAX(CLOSE,OPEN));
XA_29:=5;
XA_30:=XA_29*1;
XA_31:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_28,XA_30)=HHV(XA_28,2*XA_30+1),XA_30),XA_30+1),XA_30));
XA_32:=REF(XA_28,XA_31);
XA_33:=XA_29*2;
XA_34:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_28,XA_33)=HHV(XA_28,2*XA_33+1),XA_33),XA_33+1),XA_33));
XA_35:=REF(XA_28,XA_34);
XA_36:=XA_29*4;
XA_37:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_28,XA_36)=HHV(XA_28,2*XA_36+1),XA_36),XA_36+1),XA_36));
XA_38:=REF(XA_28,XA_37);
XA_39:=XA_29*8;
XA_40:=BARSLAST(FILTER(BACKSET(FILTER(REF(XA_28,XA_39)=HHV(XA_28,2*XA_39+1),XA_39),XA_39+1),XA_39));
XA_41:=REF(XA_28,XA_40);
XA_42:=1+0/100;
XA_43:=CROSS(CLOSE,XA_42*XA_32);
XA_44:=XA_43 AND REF(HHV(XA_28,XA_31),1)<=XA_32;
XA_45:=CROSS(CLOSE,XA_42*XA_35);
XA_46:=XA_45 AND REF(HHV(XA_28,XA_34),1)<=XA_35;
XA_47:=CROSS(CLOSE,XA_42*XA_38);
XA_48:=XA_47 AND REF(HHV(XA_28,XA_37),1)<=XA_38;
XA_49:=CROSS(CLOSE,XA_42*XA_41);
XA_50:=XA_49 AND REF(HHV(XA_28,XA_40),1)<=XA_41;
XA_51:=XA_44 OR XA_48 OR XA_48 OR XA_50;
XA_52:=IF(XA_44,XA_31,IF(XA_46,XA_34,IF(XA_48,XA_37,XA_40)));
XA_53:=REF(XA_28,XA_52);
XA_54:=IF(峰谷虚实=0,LOW,MIN(CLOSE,OPEN));
XA_55:=FILTER(BACKSET(FILTER(REF(XA_54,XA_27)=LLV(XA_54,2*XA_27+1),XA_27),XA_27+1),XA_27);
XA_56:=BARSLAST(XA_55);
XA_57:=REF(XA_54,XA_56);
XA_58:=0.002*LOW+0.005;
XA_59:=XA_55 AND ABS(XA_57-REF(XA_57,1))<=XA_58 AND REF(XA_56,1)>=5;
XA_60:=XA_55 AND ABS(XA_57-REF(XA_53,XA_52+1))<=XA_58;
XA_61:=BETWEEN(XA_28,XA_53*0.995,XA_53*1.001);
XA_62:=COUNT(XA_61,10)>=3 AND HHV(HIGH,XA_52)<=XA_53*1.001;
XA_63:=XA_5/HHV(XA_5,20)<=0.618;
XA_64:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)<=0.96 OR CLOSE/OPEN<=0.96) AND XA_63;
XA_65:=HIGH>LOW AND (CLOSE/REF(CLOSE,1)>=1.04 OR CLOSE/OPEN>=1.04) AND XA_63;
XA_66:=3;
XA_67:=3;
XA_68:=HHV(HIGH,240)-LLV(LOW,240);
XA_69:=IF(XA_68<=1,0,IF(XA_68<=5,0.02,2.5/1000*XA_68)+0.005);
XA_70:=VOL>=REF(VOL,1)*1.1 OR CLOSE>OPEN*IF(CLOSE<500,1.03,1.01);
XA_71:=REFX(LLV(LOW,XA_67),XA_67);
XA_72:=XA_70 AND LOW<=XA_71;
XA_73:=REF(HHV(HIGH,XA_66),1);
XA_74:=REF(HHV(MAX(CLOSE,OPEN),XA_66),1);
XA_75:=XA_72 AND ABS(XA_73-XA_71)<=XA_69;
XA_76:=XA_72 AND ABS(XA_74-XA_71)<=XA_69;
XA_77:=REFX(LLV(MIN(CLOSE,OPEN),XA_67),XA_67);
XA_78:=XA_70 AND LOW<=XA_77;
XA_79:=XA_78 AND ABS(XA_73-XA_77)<=XA_69;
XA_80:=XA_78 AND ABS(XA_74-XA_77)<=XA_69;
XA_81:=XA_75 OR XA_76 OR XA_79 OR XA_80;
XA_82:=50/IF(CLOSE>=1,10000,100000);
XA_83:=1.1*XA_3-XA_82;
XA_84:=1.05*XA_3-XA_82;
XA_85:=0.9*XA_3+XA_82;
XA_86:=0.95*XA_3+XA_82;
XA_87:=NAMELIKE(4) OR NAMELIKE(5);
XA_88:=IF(XA_87,CLOSE>=XA_84,CLOSE>=XA_83);
XA_89:=CLOSE<OPEN AND (CLOSE<=XA_86 OR CLOSE<0.95*OPEN+XA_82) OR (CLOSE>1000 AND CLOSE<=XA_3*0.975);
XA_90:=XA_89;
XA_91:=BARSLAST(FILTER(XA_90,3));
XA_92:=REF(OPEN,XA_91);
XA_93:=LOW<OPEN*0.96 AND XA_11 AND MA(CLOSE,60)<=REF(MA(CLOSE,60),1);
XA_94:=BARSLAST(XA_93);
XA_95:=REF(OPEN,XA_94)>=HHV(MAX(CLOSE,OPEN),XA_94) AND REF(LOW,XA_94)<=1.01*LLV(MIN(CLOSE,OPEN),XA_94);
XA_96:=XA_95 AND XA_94>=5 AND MA(VOL,5)<MA(VOL,60);
XA_97:=FILTER(XA_96,5);
XA_98:=LOW*0.005;
XA_99:=LOW<=LLV(LOW,3);
XA_100:=ABS(LOW-REF(XA_24,1))<=XA_98 OR ABS(LOW-REF(XA_24,XA_23+1))<=XA_98 AND LOW<=LLV(MIN(OPEN,CLOSE),XA_23);
XA_101:=ABS(LOW-REF(XA_25,1))<=XA_98 OR ABS(LOW-REF(XA_25,XA_23+1+3))<=XA_98;
XA_102:=ABS(LOW-REF(XA_26,1))<=XA_98 OR ABS(LOW-REF(XA_26,XA_23+1+3))<=XA_98;
XA_103:=ABS(LOW-REF(XA_53,1))<=XA_98 OR ABS(LOW-REF(XA_53,XA_52+1))<=XA_98;
XA_104:=ABS(LOW-REF(XA_57,1))<=XA_98 OR ABS(LOW-REF(XA_57,XA_56+1))<=XA_98;
XA_105:=ABS(LOW-REF(XA_92,1))<=XA_98 AND XA_91>=1;
XA_106:=XA_99 AND (XA_100 OR XA_103 OR XA_104 OR XA_105 OR XA_101 OR XA_102);
XA_107:=(MIN(OPEN,CLOSE)-LOW)/CLOSE>=0.02 AND (MIN(OPEN,CLOSE)-LOW)/(HIGH-LOW)>0.5>=0.02;
XA_108:=LOW>REF(HIGH,1);
XA_109:=REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND REF((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW),1)>0.5 AND XA_107 AND HIGH<REF(HIGH,1) AND VOL<REF(VOL,1)*1;
XA_110:=CLOSE>OPEN AND CLOSE<REF(CLOSE,1);
XA_111:=CLOSE<OPEN AND CLOSE>REF(CLOSE,1);
XA_112:=AMOUNT/VOL/100;
XA_113:=CLOSE<OPEN AND XA_112>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,1) AND XA_112<=HIGH;
XA_114:=XA_111 OR XA_113;
XA_115:=CLOSE>OPEN AND CLOSE>XA_3 AND VOL<REF(VOL,1);
XA_116:=REF(VOL,1)>=VOL*1.9 AND REF(CLOSE>REF(CLOSE,1),1);
XA_117:=COUNT(XA_10,3)=1 AND XA_116;
XA_118:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
XA_119:=SUM(XA_118,3)<=(-5);
XA_120:=CLOSE>OPEN AND CLOSE>REF((OPEN+CLOSE)/2,1);
XA_121:=REF(XA_119,1) AND XA_120;
XA_122:=(CLOSE-OPEN)/OPEN*100>=3;
XA_123:=BETWEEN(MIN(CLOSE,OPEN),REF(OPEN+(CLOSE-OPEN)*0.6,1),REF(CLOSE,1)) AND CLOSE<XA_3;
XA_124:=VOL/REF(VOL,1)<=0.71;
XA_125:=REF(XA_122,1) AND XA_123 AND XA_124;
XA_126:=COUNT(CLOSE>=XA_3,3)=3 AND REF(COUNT(VOL>=REF(VOL,1),2)=2,1);
XA_127:=MIN(CLOSE,OPEN)>REF(MAX(CLOSE,OPEN),1);
XA_128:=COUNT(XA_127,3)=3;
XA_129:=HIGH=LOW;
XA_130:=COUNT(XA_129,3)=3=0 AND XA_129=0;
XA_131:=XA_128 AND XA_130;
XA_132:=4;
XA_133:=IF(峰谷虚实=1,MIN(CLOSE,OPEN),LOW);
XA_134:=BARSLAST(XA_10);
XA_135:=LLV(XA_133,XA_134)>=REF(XA_133,XA_134) AND XA_134>=XA_132;
XA_136:=FILTER(BACKSET(FILTER(REF(VOL,XA_27)=HHV(VOL,2*XA_27+1),XA_27),XA_27+1),XA_27);
XA_137:=BARSLAST(XA_136);
XA_138:=LLV(XA_133,XA_137)>=REF(XA_133,XA_137) AND XA_137>=XA_132 AND XA_137>=高量周期;
XA_139:=LOW>REF(HIGH,1);
XA_140:=BARSLAST(XA_10);
XA_141:=LLV(LOW,XA_140)>REF(HIGH,XA_140+1) AND XA_140>=XA_132;
XA_142:=XA_135 OR XA_138 OR XA_141;
XA_143:=MIN(CLOSE,OPEN);
XA_144:=MAX(CLOSE,OPEN);
XA_145:=HIGH-LOW;
XA_146:=CLOSE>=1.0497*REF(CLOSE,1)-XA_82;
XA_147:=RANGE(ABS(CLOSE-OPEN)/XA_145,0,0.8) AND (HIGH-XA_144)/XA_145>=0.1 AND (XA_143-LOW)/XA_145>=0.1;
XA_148:=LLV(XA_143,2)>=REF(0.5*(XA_144+XA_143),2);
XA_149:=HHV(VOL,2)<REF(VOL,2);
XA_150:=REF(XA_146,2) AND COUNT(XA_147,2)=2 AND XA_148 AND XA_149;
XA_151:=LLV(XA_143,3);
XA_152:=(CLOSE-OPEN)/OPEN>=5/100 OR XA_118>=5;
XA_153:=20;
XA_154:=(XA_143-LLV(XA_143,4))/LLV(XA_143,4)<3/100;
XA_155:=LLV(XA_143,5)=LLV(XA_143,XA_153) AND BARSCOUNT(CLOSE)>=XA_153;
XA_156:=0;
XA_157:=IF(XA_156=1,CLOSE>=OPEN AND REF(XA_152=0 OR CLOSE<OPEN,1) AND CLOSE>REF(XA_144,1),1);
XA_158:=XA_152 OR (BETWEEN(XA_118,3,5) AND XA_10) AND XA_157 AND XA_154;
XA_159:=BARSLAST(XA_158>0);
XA_160:=REF(XA_159,1)+1;
XA_161:=LLV(MIN(CLOSE,OPEN),XA_160);
XA_162:=XA_161>=REF(LOW,XA_160);
XA_163:=COUNT(XA_158>0,13)=2;
XA_164:=REF(OPEN,XA_160);
XA_165:=ABS(OPEN-XA_164)/XA_164<10/100;
XA_166:=1*(XA_158 AND XA_163 AND XA_165 AND REF(XA_162,1) AND BETWEEN(XA_160,4,13));
地量:=COUNT(XA_9,M周期内);
矮将:=COUNT(XA_18,M周期内);
金柱:=COUNT(REFX(XA_22,3),M周期内);
元帅:=COUNT(XA_19,M周期内),COLORRED;
涨板:=COUNT(XA_88,M周期内);
零号:=COUNT(XA_108,M周期内);
过左:=COUNT(XA_51,M周期内);
阴短:=COUNT(XA_64,M周期内),COLORLIGREEN;
阳矮:=COUNT(XA_65 AND CLOSE>LOW,M周期内),COLORLIRED;
踩精:=COUNT(XA_106,M周期内),COLORCYAN;
假阴:=COUNT(XA_114,M周期内);
背反:=COUNT(XA_115,M周期内);
伸缩:=COUNT(XA_117,M周期内);
次阳:=COUNT(XA_121,M周期内),COLORRED;
悬阴:=COUNT(XA_125,M周期内);
三元:=COUNT(XA_131,M周期内);
梯四:=COUNT(XA_126,M周期内);
三绝:=COUNT(XA_142,M周期内)>=1;
双休:=COUNT(XA_150,M周期内),COLORCYAN;
双阳:=COUNT(XA_166,M周期内);
双剑:=COUNT(XA_109,M周期内);
十字:=COUNT(XA_81,M周期内);
直憋:=COUNT(XA_97,M周期内);
峰谷:=COUNT(XA_59 OR XA_60,M周期内);
咬峰:=COUNT(XA_62,M周期内);
XA_167:=IF(涨板>0,1,0)+IF(地量>0,1,0)+IF(矮将>0,1,0)+IF(金柱>0,1,0)+IF(元帅>0,1,0);
XA_168:=IF(过左>0,1,0)+IF(伸缩>0,1,0)+IF(阴短>0,1,0)+IF(阳矮>0,1,0)+IF(直憋>0,1,0);
XA_169:=IF(踩精>0,1,0)+IF(双剑>0,1,0)+IF(假阴>0,1,0)+IF(背反>0,1,0)+IF(零号>0,1,0);
XA_170:=IF(十字>0,1,0)+IF(峰谷>0,1,0)+IF(次阳>0,1,0)+IF(三元>0,1,0)+IF(悬阴>0,1,0);
XA_171:=IF(梯四>0,1,0)+IF(咬峰>0,1,0)+IF(三绝>0,1,0)+IF(双休>0,1,0)+IF(双阳>0,1,0);
总类:=XA_167+XA_168+XA_169+XA_170+XA_171;
XA_172:=涨板+地量+矮将+金柱+元帅;
XA_173:=过左+伸缩+阴短+阳矮+直憋;
XA_174:=踩精+双剑+假阴+背反+零号;
XA_175:=十字+峰谷+次阳+三元+悬阴;
XA_176:=梯四+咬峰+三绝+双休+双阳;
总数:=XA_172+XA_173+XA_174+XA_175+XA_176;
攻击强度:=((总类+总数)/2)-3,COLORWHITE;
控盘1:STICKLINE(攻击强度>0,0,攻击强度,2,0),COLORRED;
控盘2:STICKLINE(攻击强度<0,0,攻击强度,2,0),COLORGREEN;

通达信征战涨停指标公式

 

相关文章