在线检测未来函数

通达信实用看盘主图指标公式

来源:Internet,编辑:股旁网,2016-02-26

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
B1:(20*MID+19*REF(MID,1)+18*REF(MID,2)
+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)
+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)
+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)
+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)
+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORRED,LINETHICK2;
B2:=EMA(FORCAST(EMA(MID,8),8),9);
B3:=EMA(FORCAST(EMA(MID,7),7),8);
B4:=EMA(FORCAST(EMA(MID,6),6),7);
B5:=EMA(FORCAST(EMA(MID,5),5),6);
B6:=EMA(FORCAST(EMA(MID,4),4),5);
B7:=EMA(FORCAST(EMA(MID,3),3),4);
B8:=EMA(FORCAST(EMA(MID,2),2),3);
MA5:EMA(FORCAST(MA(MID,4),4),2)COLORYELLOW,LINETHICK2;
IF(C,REF(B2,8),DRAWNULL),COLORF0F000;
IF(C,REF(B3,7),DRAWNULL),COLORF0F000;
IF(C,REF(B4,6),DRAWNULL),COLORF0F000;
IF(C,REF(B5,5),DRAWNULL),COLORF0F000;
IF(C,REF(B6,4),DRAWNULL),COLORF0F000;
IF(C,REF(B7,3),DRAWNULL),COLORF0F000;
IF(C,REF(B8,2),DRAWNULL),COLORF0F000;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(C,1)) AND C=H,1,0);
STICKLINE(涨停,O,C,2.5,0),COLORFF00FF;
STICKLINE(涨停,H,L,0,1),COLORFF00FF;
跌停:=IF((REF(C,1)-C)*100/REF(C,1)>=(10-0.01*100/REF(C,1)) AND C=L,1,0);
STICKLINE(跌停,O,C,2.5,0),COLOR00FF00;
STICKLINE(跌停,H,L,0,1),COLOR00FF00;

通达信实用看盘主图指标公式

 

相关文章