在线检测未来函数

通达信变幻五线主图指标公式

来源:Internet,编辑:股旁网,2016-03-07

M2:=EMA(C,2);
M3:=EMA(C,3);
M4:=EMA(C,4);
M5:=EMA(C,5);
M6:=EMA(C,6);
M7:=EMA(C,7);
M8:=EMA(C,8);
WJ:=(M2+M3+M4+M5+M6+M7+M8)/7;
WD:=MAX(M2,MAX(M3,MAX(M4,MAX(M5,MAX(M6,MAX(M7,M8))))));
WX:=MIN(M2,MIN(M3,MIN(M4,MIN(M5,MAX(M6,MAX(M7,M8))))));
WB:EMA(WJ+(WD-(WD+WX)/2)*0.809,3),DOTLINE;
M10:=EMA(C,10);
M15:=EMA(C,15);
M20:=EMA(C,20);
M25:=EMA(C,25);
M30:=EMA(C,30);
M35:=EMA(C,35);
SJ:=(M5+M10+M15+M20+M25+M30+M35)/7;
SD:=MAX(M5,MAX(M10,MAX(M15,MAX(M20,MAX(M25,MAX(M30,M35))))));
SX:=MIN(M5,MIN(M10,MIN(M15,MIN(M20,MAX(M25,MAX(M30,M35))))));
YB:EMA(SJ+(SD-(SD+SX)/2)*0.809,5);
M40:=EMA(C,40);
M50:=EMA(C,50);
M60:=EMA(C,60);
M70:=EMA(C,70);
M80:=EMA(C,80);
M90:=EMA(C,90);
JJ:=(M30+M40+M50+M60+M70+M80+M90)/7;
JD:=MAX(M30,MAX(M40,MAX(M50,MAX(M60,MAX(M70,MAX(M80,M90))))));
JX:=MIN(M30,MIN(M40,MIN(M50,MIN(M60,MAX(M70,MAX(M80,M90))))));
JB:EMA(JJ+(JD-(JD+JX)/2)*0.809,10);
M100:=EMA(C,100);
M120:=EMA(C,120);
M140:=EMA(C,140);
M160:=EMA(C,160);
M180:=EMA(C,180);
BJ:=(M60+M80+M100+M120+M140+M160+M180)/7;
BD:=MAX(M60,MAX(M80,MAX(M100,MAX(M120,MAX(M140,MAX(M160,M180))))));
BX:=MIN(M60,MIN(M80,MIN(M100,MIN(M120,MAX(M140,MAX(M160,M180))))));
BLB:EMA(BJ+(BD-(BD+BX)/2)*0.809,20);
M200:=EMA(C,200);
M240:=EMA(C,240);
M280:=EMA(C,280);
M320:=EMA(C,320);
M360:=EMA(C,360);
LJ:=(M120+M160+M200+M240+M280+M160+M360)/7;
LD:=MAX(M120,MAX(M160,MAX(M200,MAX(M240,MAX(M280,MAX(M320,M360))))));
LX:=MIN(M120,MIN(M160,MIN(M200,MIN(M240,MAX(M280,MAX(M320,M360))))));
LB:EMA(LJ+(LD-(LD+LX)/2)*0.809,40),DOTLINE;

通达信变幻五线主图指标公式

 

相关文章