在线检测未来函数

通达信破壳而出主图指标公式

来源:Internet,编辑:股旁网,2016-03-29

DRAWGBK(C>0,RGB(0,0,0),RGB(00,0,0),0,'000',0);
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.001,0.050,0,GNBLOCK),COLORCYAN;{概念};
DRAWKLINE(H,O,L,C);
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210;
黄牛线:=EMA(HH,5),COLORGREEN,LINETHICK2;
黄牛线1:=EMA(HH,10),COLORGREEN,LINETHICK2;
黄牛线2:=EMA(HH,30),COLORGREEN,LINETHICK2;
黄牛线3:=EMA(HH,60),COLORGREEN,LINETHICK2;
黄牛线4:EMA(HH,90),COLORRED,LINETHICK2;
黄牛线5:=EMA(HH,120),COLORGREEN,LINETHICK2;
黄牛线6:EMA(HH,250),COLORGREEN,LINETHICK2;
{IF((黄牛线>=REF(黄牛线,1)),黄牛线,DRAWNULL),LINETHICK2,COLORRED;}
IF((黄牛线4>=REF(黄牛线4,1)),黄牛线4,DRAWNULL),LINETHICK2,COLORRED;
IF((黄牛线6>=REF(黄牛线6,1)),黄牛线6,DRAWNULL),LINETHICK2,COLORRED;
E5:EMA(C,5),COLORGREEN,LINETHICK2;
IF((E5>=REF(E5,1)),E5,DRAWNULL),LINETHICK2,COLORRED;
离合:(黄牛线-((H-黄牛线)*H-黄牛线)/黄牛线),COLOR485756;
离合1:(黄牛线1-((H-黄牛线1)*H-黄牛线1)/黄牛线1),COLOR2B2B2B;
离合2:(黄牛线2-((H-黄牛线2)*H-黄牛线2)/黄牛线2),COLOR604D4A;
离合3:(黄牛线3-((H-黄牛线3)*H-黄牛线3)/黄牛线3),COLOR1E1E1E;
离合4:(黄牛线4-((H-黄牛线4)*H-黄牛线4)/黄牛线4),COLOR333333;
离合5:(黄牛线5-((H-黄牛线5)*H-黄牛线5)/黄牛线5),COLOR575757;
离合6:(黄牛线6-((H-黄牛线6)*H-黄牛线6)/黄牛线6),COLOR6E6E6E;
最大临界线:MAX(离合6,MAX(离合5,MAX(离合4,MAX(离合3,MAX(离合2,MAX(离合1,离合)))))),COLORA2A2A2,LINETHICK2;
最小临界线:MIN(离合6,MIN(离合5,MIN(离合4,MIN(离合3,MIN(离合2,MIN(离合1,离合))))))COLOR485756;
STICKLINE(最小临界线<=最大临界线,最小临界线,最大临界线,0,0),COLOR6E6E6E;
上升离合:=(黄牛线+((C-黄牛线)*C-黄牛线)/黄牛线),COLORRED;
上升离合1:=(黄牛线1+((H-黄牛线1)*H-黄牛线1)/黄牛线1),COLORFFBBCC;
上升离合2:=(黄牛线2+((H-黄牛线2)*H-黄牛线2)/黄牛线2),COLORFF99CC;
上升离合3:=(黄牛线3+((H-黄牛线3)*H-黄牛线3)/黄牛线3),COLORFF97CC;
上升离合4:(黄牛线4+((H-黄牛线4)*H-黄牛线4)/黄牛线4),COLORYELLOW,LINETHICK2;
上升离合5:=(黄牛线5+((H-黄牛线5)*H-黄牛线5)/黄牛线5),COLORFF85CC;
上升离合6:=(黄牛线6+((H-黄牛线6)*H-黄牛线6)/黄牛线6),COLORRED,LINETHICK2;
TP1:=CROSS(最大临界线,黄牛线);
TP3:=CROSS(C,最大临界线);
TP6:=CROSS(上升离合4,E5);
DRAWTEXT(TP1 AND ZT,L,'↖金元宝'),COLORRED,LINETHICK4;
DRAWTEXT(TP3 AND ZT,L,'↖精准导弹'),COLORWHITE,LINETHICK4;
DRAWTEXT(TP6 AND ZT,L,'↖超级主升'),COLORYELLOW,LINETHICK4;
DRAWTEXT(TP3,L,'买'),COLORGREEN,LINETHICK4;
DRAWKLINE(H,O,L,C);

通达信破壳而出主图指标公式

 

相关文章