在线检测未来函数

大智慧主力进退线指标公式

来源:Internet,编辑:股旁网,2016-04-28

VAR1:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR2:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR3:=SMA(VAR2,13,8);
VAR4:=SMA(VAR1,21,8);
x:=CEILING(SMA(VAR3,13,8));
底:IF((x-VAR4<(-65)),1,6),COLOR00FF00;
顶:IF((x-VAR4>85),95,100),COLORF0F000;
RSV:= (CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
FASTK:=SMA(RSV,7,1);
K:SMA(FASTK,7,1);
D:SMA(K,9,1),COLORFFFFFF;
stickline(k>D,k,d,6,0),colorred;
stickline(k<D,k,d,2,0),colorwhite;
强弱分界线: 50,pointdot, COLORf00ff0;
Var1x:=IF(MONTH<12,1,1);
Var3x:=(2*CLOSE+HIGH+LOW)/4;
Var4x:=LLV(LOW,34);
Var5x:=HHV(HIGH,34);
主力进退线:EMA((Var3x-Var4x)/(Var5x-Var4x)*100,13)*Var1x,linethick2,colorred;
DRAWTEXT(cross(主力进退线,D),D,'B'),COLORred;
DRAWTEXT(cross(D,主力进退线),D,'s'),COLORyellow;

大智慧主力进退线指标公式

 

相关文章