在线检测未来函数

通达信21KDJ指标公式

来源:Internet,编辑:股旁网,2016-05-23

线4:20,COLOR545454,DOTLINE;
线3:10,COLOR545454,DOTLINE;
线2:0,COLOR545454,DOTLINE;
线1:-10,COLOR545454,DOTLINE;
RSV:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*50-20;
K:SMA(RSV,9,1),COLOR4D4DFF,LINETHICK1;
D:SMA(K,3,1),COLOR00FF00,LINETHICK1;
J:EMA(K,9),DOTLINE,COLORFF2400;
VARK:K,COLORWHITE,LINETHICK2;
上升K:IF(VARK>REF(VARK,1),VARK,DRAWNULL),COLORRED,LINETHICK2;
走平K:IF(VARK=REF(VARK,1),VARK,DRAWNULL),COLORFFFFFF,LINETHICK2;
下降K:IF(VARK<REF(VARK,1),VARK,DRAWNULL),COLORFF2400,LINETHICK2;
VARD:D,COLORWHITE,LINETHICK2;
上升D:IF(VARD>REF(VARD,1),VARD,DRAWNULL),COLORFF00FF,LINETHICK2;
走平D:IF(VARD=REF(VARD,1),VARD,DRAWNULL),COLORFFFFFF,LINETHICK2;
下降D:IF(VARD<REF(VARD,1),VARD,DRAWNULL),COLORGREEN,LINETHICK2;
VARJ:J,COLORWHITE;
上升J:IF(VARJ>REF(VARJ,1),VARJ,DRAWNULL),COLORRED;
走平J:IF(VARJ=REF(VARJ,1),VARJ,DRAWNULL),COLORFFFFFF;
下降J:IF(VARJ<REF(VARJ,1),VARJ,DRAWNULL),COLORFF0000;
STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARK>=0 AND VARK>=REF(VARK,1),0,0+VARK,0,1),COLOR9F9F5F;
STICKLINE(VARD>=0 AND VARD>=REF(VARD,1),0,0+VARD,0,1),COLOR9F9F5F;
STICKLINE(VARJ>=0 AND VARJ>=REF(VARJ,1),0,0+VARJ,0,1),COLOR9F9F5F;
STICKLINE(VARJ<=0 AND VARK>=REF(VARD,1),0,0+VARD,0,1),COLOR9F9F5F;
N:=60;
K值:="KDJ.K";
DD:=C=LLV(C,N);{120日最低点}
DDSJ:=BARSLAST(REF(DD,1));{上一低点时间}
DDGJ:=REF(CLOSE,DDSJ+1)>CLOSE;{股价趋势}
KDZB:=REF(K值,DDSJ+1)<K值;{KDJ.K指标趋势}
K底背离:=DDGJ AND KDZB;
GD:=C=HHV(C,N);{120日最高点}
GDSJ:=BARSLAST(REF(GD,1));{上一高点时间}
GDGJ:=REF(CLOSE,GDSJ+1)<CLOSE;{股价趋势}
KGZB:=REF(K值,GDSJ+1)>K值;
K顶背离:=GDGJ AND KGZB;
MACD:="MACD.MACD";
MDZB:=REF(MACD,DDSJ+1)<MACD;{MACD指标趋势}
M底背离:=DDGJ AND MDZB;
MGZB:=REF(MACD,GDSJ+1)>MACD;
M顶背离:=GDGJ AND MGZB;
RSI:="RSI.RSI1";
RDZB:=REF(RSI,DDSJ+1)<RSI;{RSI指标趋势}
R底背离:=DDGJ AND RDZB;
RGZB:=REF(RSI,GDSJ+1)>RSI;
R顶背离:=GDGJ AND RGZB;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
CDZB:=REF(CCI,DDSJ+1)<CCI;{CCI指标趋势}
C底背离:=DDGJ AND CDZB;
CGZB:=REF(CCI,GDSJ+1)>CCI;
C顶背离:=GDGJ AND CGZB;
REFLINE: -5,15,30,COLORBLACK;
DRAWICON(K顶背离,IF(ISLASTBAR,20.5,20),2),LINETHICK2 ;
DRAWICON(M顶背离,(ISLASTBAR,10.5,10),2),LINETHICK2 ;
DRAWICON(R顶背离,(ISLASTBAR,0.5,0),2),LINETHICK2 ;
DRAWICON(C顶背离,(ISLASTBAR,-10.6,-10),2),LINETHICK2 ;
DRAWTEXT(ISLASTBAR,-10.1 ,'CCI '),LINETHICK2,COLORGREEN;
DRAWICON(C底背离,IF(ISLASTBAR,12,-10.1 ),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,0,'RSI '),LINETHICK2,COLORRED;
DRAWICON(R底背离,IF(ISLASTBAR,8.5,0),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,10,'MACD '),LINETHICK2,COLORMAGENTA;
DRAWICON(M底背离,IF(ISLASTBAR,4.5,10),1),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR,20,'KDJ '),LINETHICK2,COLORRED;
DRAWICON(K底背离,IF(ISLASTBAR,1.5,20),1),LINETHICK2,COLORRED;

通达信21KDJ指标公式

 

相关文章