在线检测未来函数

通达信绝岭霹雳主图指标公式

来源:Internet,编辑:股旁网,2016-05-25

操作线:EMA(C,7),COLORRED;
A:=(REF(操作线,1));
STICKLINE((操作线>A),A,操作线,6,0),COLOR0000FF;
STICKLINE((操作线<=A),A,操作线,6,0),COLOR00FF00;
VARA:=IF((CLOSE>150),91.3,0.91299998);
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
绝岭霹雳:BBI+2*STD(BBI,10),COLORYELLOW,LINETHICK5;
A1:=MA(C,2);
A3:=(A1+绝岭霹雳)/2;
A3,COLORWHITE,LINETHICK2;
VARC:=EMA(HIGH,21)/HIGH*CLOSE;
警戒:EMA(VARC,21)*1.18,COLORFF9900,LINETHICK2;
H20:HHV(H,20),COLORWHITE,LINETHICK2;
Y:=CYC(1);
U1:=CYC(5);
主力:CYC(8),COLORFF00FF,LINETHICK3;
U3:=CYC(13);
XX1:=U1>主力 AND 主力>U3;
C5:=IF(XX1>0,LLV(U1, 5),HHV(主力,5));
C8:=IF(XX1>0,LLV(主力, 8),HHV(主力,5));
C13:=IF(XX1>0,LLV(U3, 13),HHV(主力,5));
散户:LLV(主力, 8),COLORGRAY,LINETHICK3;
雷达:DYNAINFO(7),COLORBLUE;
{DRAWTEXT(散户=REF(散户,1),散户,' ┬ '),COLORYELLOW;
DRAWTEXT(REF(散户,1)<REF(散户,2) AND 散户=REF(散户,1),散户,'┃'),COLORYELLOW;}
DRAWLINE(散户<REF(散户,1) ,散户,散户=REF(散户,1),散户,0),COLORYELLOW;
R1:=C;
R2:=LLV(LOW,45);
R3:=HHV(HIGH,45);
Y1:=C;
Y2:=LLV(LOW,144);
Y3:=HHV(HIGH,144);
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
RSVR:=((R1-R2)/(R3-R2))*100;
KR:=SMA(RSVR,3,1);
DR:=SMA(KR,3,1);
RSVY:=((Y1-Y2)/(Y3-Y2))*100;
KY:=SMA(RSVY,3,1);
DY:=SMA(KY,3,1);
X1:=CYC(8);
X2:=CYC(13);
X3:=CYC(21);
XX:=C>X2 AND C>X2;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100;
DIFF:= EMA(CLOSE,8) - EMA(CLOSE,21);
DEA:= EMA(DIFF,8);
MACD:= 2*(DIFF-DEA);
J13:=CYC(8)-CYC(21);
K13:=SMA(J13,3,1);
D13:=SMA(K13,3,1);
MACD13:=4*(K13-D13);
JS:= MACD>0 AND K>D AND RSI1>50 AND DR<60 AND DY<60 AND XX>0 AND MACD13>0 AND MACD13>REF(MACD13,1);
XG:= JS>0 AND CROSS(K,D) AND CROSS(MACD,0)AND MA(V,5)>MA(V,40);
短:=D;
短1:=REF(D,1);
中:=DR;
中1:=REF(DR,1);
长:=DY;
长1:=REF(DY,1);
AAA:=CROSS(D,REF(D,2))AND 短1<50 AND DR>REF(DR,1)AND DY>REF(DY,1) AND D<30 AND DR<20 AND DY <20 ;
黄:=IF(AAA>0,50,0);
白:=IF(XG>0,30,0);
IF (A1>绝岭霹雳,A1,A3),COLORBLUE,LINETHICK2;
{IF (A1>绝岭霹雳,绝岭霹雳,A3),COLORBLUE,LINETHICK2;}
IF (A1<=绝岭霹雳,A1,A3),COLOR00FF00,LINETHICK2;
{IF (A1<=绝岭霹雳,绝岭霹雳,A3),COLOR00FF00,LINETHICK2;}
DRAWTEXT(黄>0 ,LOW*0.999,'O'),COLORYELLOW;
DRAWTEXT(白>0 ,LOW*0.999,'O'),COLORWHITE;

通达信绝岭霹雳主图指标公式

 

相关文章