在线检测未来函数

通达信很好的KDJ买卖顶底及选股指标公式

来源:Internet,编辑:股旁网,2016-05-30

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,M1,1);
D:SMA(K,M2,1);
J:3*K-2*D;
N1:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC;
专吸: IF(VAR1<=8,25,0),STICK,COLORWHITE;
DRAWTEXT(CROSS(VAR1,VAR2),80,'准备'),COLOR00FFFF;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓: IF((VARO7<10),-30,-10) ,COLOR00CCFF,LINETHICK1;
0,LINETHICK2 ,COLORFFCC00;
底线:10,COLOR9F9F5F;
顶线:92,COLOR9F9F5F;
BB:=IF(BARSLAST(CROSS(K,RSV))>=3 AND CROSS(RSV,K) AND K<30,20,0);
STICKLINE(BB,0,20,2.8,0),COLOR0000BB;
AA:=IF(BARSLAST(CROSS(RSV,K))>=4 AND CROSS(K,RSV) AND RSV>50,20,0);
STICKLINE(AA,80,100,2.8,0),COLORD8D8D8;
下线:30,COLOR9F9F5F,DOTLINE;
上线:70,COLOR9F9F5F,DOTLINE;
CC:=IF(BARSLAST(CROSS(K,RSV))>=1 AND CROSS(RSV,K) AND K<40,20,0);
STICKLINE(CC,10,30,2.8,0),COLORFF1CAE;
QQ:=IF(BARSLAST(CROSS(RSV,K))>=2 AND CROSS(K,RSV) AND RSV>70,20,0);
STICKLINE(QQ,70,90,2.8,0),COLORFF2400;
K1:SMA(RSV,3,1),COLORF580F5,LINETHICK1;
D1:SMA(K,3,1),COLORCCDD33,LINETHICK1;

{
选股公式:

N:=9;
M1:=3;
M2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
N1:=5;
VAR1:=4*SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:=8;
去除ST:=IF(NAMELIKE('ST'),0,1) AND IF(NAMELIKE('*ST'),0,1);
去除停牌:=DYNAINFO(4)>1;
去亏损:=FINANCE(33)>0;
XG:CROSS(VAR1,VAR2) AND 去除ST AND 去除停牌 AND 去亏损;
}

通达信很好的KDJ买卖顶底及选股指标公式

 

相关文章