在线检测未来函数

通达信紧盯大牛股选股指标公式

来源:Internet,编辑:股旁网,2016-06-15

VOL1:=MA(V,5);
VOL2:=MA(V,30);
TJ1:=NOT(NAMELIKE('S') OR NAMELIKE('*S'));
TJ2:=DYNAINFO(4)>0;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2));
进出量:=买量+卖量;
N:=5;
M:=13;
N日内净流入:=SUM(进出量,N)/10000;
流入:=IF(N日内净流入>REF(N日内净流入,1),N日内净流入,DRAWNULL);
连红天:=BARSLASTCOUNT(进出量>0);
M日内翻红天:=COUNT(进出量>0,M);
走熊天:=BARSLASTCOUNT(N日内净流入<0);
走牛天:=BARSLASTCOUNT(N日内净流入>0);
强势天:=BARSLASTCOUNT((N日内净流入>REF(N日内净流入,1))>0 AND N日内净流入>0);
弱势天:=BARSLASTCOUNT((N日内净流入<REF(N日内净流入,1))>0 AND N日内净流入<0);
DX:=SUM(进出量,N)/10000;
TJ3:=DX-REF(DX,1);
A1:=MA(TJ3,5);
A2:=MA(TJ3,30);
大单比率:=(A1,A2)>=2;
A3:=(VOL/CLOSE)/3;
A4:=SUM((IF(((A3>60) AND C<15 AND (CLOSE>(REF(CLOSE,1)))),A3,0)),1);
A5:=SUM((IF(((A3>20) AND C>15 AND (CLOSE>(REF(CLOSE,1)))),A3,0)),1);
主力买:=A4+A5;
A6:=SUM((IF(((A3>60) AND C<15 AND (CLOSE<(REF(CLOSE,1)))),A3,0)),1);
A7:=SUM((IF(((A3>20) AND C>15 AND (CLOSE<(REF(CLOSE,1)))),A3,0)),1);
主力卖:=A6+A7;
主力净买额:=IF(FINANCE(7)<5000000000,(主力买-主力卖)/10,0);
TJ4:=主力净买额/FINANCE(7)*1000000;
A8:=MA(TJ4,5);
A9:=MA(TJ4,10);
净买占比:=(A3,A4)>=5;
XG:VOL1/VOL2>=3 AND TJ1 AND TJ2 AND 大单比率 AND 净买占比;

通达信紧盯大牛股选股指标公式

 

相关文章