在线检测未来函数

大智慧KDJ通道主图指标公式

来源:Internet,编辑:股旁网,2016-06-28

DRAWGBK(c>0),color001111;
DRAWTEXTABS(12,8, '所属板块: '+BKNAME),Color888888;
DRAWTEXTABS(12,21,'每股收益: '+NUMTOSTRN(FINANCE2(3),2)+'元 '+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),1)+'倍 '+' 每股公积金:'+NUMTOSTRN(FINANCE2(7),2)+'元'),Color888888;
DRAWTEXTABS(12,34,'总股 本: '+NUMTOSTRN(FINANCE2(35),2)+'万股'),Color888888;
DRAWTEXTABS(12,47,'流通 A股: '+NUMTOSTRN(FINANCE2(37),2)+'万股'),Color888888;
jcG:=ema((HHV(HIGH,9)+ LLV(LOW,9))/2,9);
blG:=(CLOSE- LLV(LOW,9))/( HHV(HIGH,9)- LLV(LOW,9));
J1Y:=-49;
RSVY:=blG*100;
KY:=SMA(RSVY,3,1);
DY:=SMA(KY,3,1);
JY:=3*KY-2*DY;
【J值】:JY,LINETHICK0,COLORFF00FF;
【K值】:KY,LINETHICK0,COLORFFFFFF;
【D值】:DY,LINETHICK0,COLOR00FFFF;
k1Y:=1/3*rsvY+ref(kY,1)/3*2;
d1Y:=1/3*kY+ref(dY,1)/3*2;
JjY:=3*K1Y-2*D1Y;
j11Y:=jY;j昨Y:=ref(jY,1);jxY:=if(j1Y=-50,j11Y,if(j1Y=-49,j昨Y,j1Y));
xxxY:=((9/7*jxY-2*ref(kY,1)+12/7*ref(dY,1))/100)*(HHV(HIGH,9)-LLV(LOW,9))+LLV(LOW,9);
【J线拐头】:XXXY,COLOR0044FF,LAYER2,LINETHICK1;
【交叉位】:((3*REF(DY,1)-2*REF(KY,1))*(HHV(H,9)-LLV(L,9))/100)+LLV(L,9),COLOR00CC00,LAYER3,LINETHICK1;
DRAWTEXTABS(12,310,IFS(JY<REF(JY,1) AND JY<DY,'注意:如果明日14:40后股价不能突破'+NUMTOSTRN(ABS(XXXY),2)+'元J线将继续下行'+'(休市后为预测明日价)','')),LINETHICK2,COLORFF5500;
DRAWTEXTABS(12,310,IFS(JY<REF(JY,1) AND JY>DY,'注意:如果明日14:40后股价不能突破'+NUMTOSTRN(ABS(XXXY),2)+'元J线将继续下行'+' ,跌破'+NUMTOSTRN(ABS(【交叉位】),2)+'元J线将死叉!(休市后为预测明日价)','')),LINETHICK2,COLORFF5500;
DRAWTEXTABS(12,310,IFS(JY>REF(JY,1) AND JY>DY,'注意:如果明日14:40后股价不跌破'+NUMTOSTRN(ABS(XXXY),2)+'元J线将继续上行'+'(休市后为预测明日价)','')),LINETHICK2,COLOR0022FF;
DRAWTEXTABS(12,310,IFS(JY>REF(JY,1) AND JY<DY,'注意:如果明日14:40后股价不跌破'+NUMTOSTRN(ABS(XXXY),2)+'元J线将继续上行'+' ,突破'+NUMTOSTRN(ABS(【交叉位】),2)+'元J线将金叉!(休市后为预测明日价)','')),LINETHICK2,COLOR0022FF;
kzG:=sma(jcG*(1+(BLG-0.5)/2),3,1);
dzG:=sma(jcG*(SMA(BLG,3,1)-0.5)/2+jcG,3,1);
jzG:=3*kzG-2*dzG;
坐标20:sma(jcG*(0.2-0.5)/2+jcG,3,1),COLOR003333,LAYER4;
坐标80:sma(jcG*(0.8-0.5)/2+jcG,3,1),COLOR003333,LAYER4;
FILLRGN(坐标20,坐标80,C>0),COLOR000000,LAYER7;
FILLRGN(jzG,KZG,C>0),COLOR330033,LAYER5;
FILLRGN(KzG,DZG,C>0),COLOR333333,LAYER4;
{以下设置东郭立体K线};
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1.5,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0) ,COLOR0000ff;
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
stickline(var9Q,c,(o+c)/2,8,0),color000055;
stickline(var9Q,c,(o+c)/2,7,0),color000066;
stickline(var9Q,c,(o+c)/2,6,0),color000077;
stickline(var9Q,c,(o+c)/2,5,0),color000099;
stickline(var9Q,c,(o+c)/2,4,0),color0000bb;
stickline(var9Q,c,(o+c)/2,3,0),color0000dd;
stickline(var9Q,c,(o+c)/2,1.5,0),color0000ff;
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
stickline(varaQ,c,(o+c)/2,8,0),colorff11ff;
stickline(varaQ,c,(o+c)/2,7,0),colorff33ff;
stickline(varaQ,c,(o+c)/2,6,0),colorff55ff;
stickline(varaQ,c,(o+c)/2,5,0),colorff77ff;
stickline(varaQ,c,(o+c)/2,4,0),colorff99ff;
stickline(varaQ,c,(o+c)/2,3,0),colorffbbff;
stickline(varaQ,c,(o+c)/2,1.5,0),colorffddff;
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
stickline(varbQ,c,(o+c)/2,8,0),color333333;
stickline(varbQ,c,(o+c)/2,7,0),color555555;
stickline(varbQ,c,(o+c)/2,6,0),color777777;
stickline(varbQ,c,(o+c)/2,5,0),color999999;
stickline(varbQ,c,(o+c)/2,4,0),colorbbbbbb;
stickline(varbQ,c,(o+c)/2,3,0),colordddddd;
stickline(varbQ,c,(o+c)/2,1.5,0),colorffffff;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
stickline(varcQ,o,(o+c)/2,8,0),color003300;
stickline(varcQ,o,(o+c)/2,7,0),color005500;
stickline(varcQ,o,(o+c)/2,6,0),color007700;
stickline(varcQ,o,(o+c)/2,5,0),color009900;
stickline(varcQ,o,(o+c)/2,4,0),color00bb00;
stickline(varcQ,o,(o+c)/2,3,0),color00dd00;
stickline(varcQ,o,(o+c)/2,1.5,0),color00ff00;
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
stickline(vardQ,o,(o+c)/2,8,0),colorff1100;
stickline(vardQ,o,(o+c)/2,7,0),colorff3300;
stickline(vardQ,o,(o+c)/2,6,0),colorff5500;
stickline(vardQ,o,(o+c)/2,5,0),colorff7700;
stickline(vardQ,o,(o+c)/2,4,0),colorff9900;
stickline(vardQ,o,(o+c)/2,3,0),colorffbb00;
stickline(vardQ,o,(o+c)/2,1.5,0),colorffdd00;

大智慧KDJ通道主图指标公式

 

相关文章