在线检测未来函数

通达信借盘下棋指标公式

来源:Internet,编辑:股旁网,2016-07-13

S1:=IF(CODELIKE('300'),0,1);
{通达信去掉*、S、ST}
S2:=IF(NAMELIKE('S'),0,1);
S3:=IF(NAMELIKE('*'),0,1);
{通达信去掉停牌}
S4:=DYNAINFO(17)>0;
去掉:= S2 AND S3 AND S4;
ZD2:="KDJ.J#DAY"(9,3,3);
DIF11:=(EMA(DCLOSE,12)-EMA(DCLOSE,26))/EMA(DCLOSE,26)*100;
DEA22:=EMA(DIF11,9);
准备飞:=(DIF11-DEA22)*100;
集结号:=50;
穿:=准备飞-REF(准备飞,1)COLORRED LINETHICK2;
★集结号:CROSS(穿,集结号) AND C<20 AND 去掉,NODRAW;
DIF1:=(EMA(DCLOSE,12)-EMA(DCLOSE,26))/EMA(DCLOSE,26)*100;
DEA1:=EMA(DIF1,9);
AAA1:=(DIF1-DEA1)*120;
买:=45;
入:=AAA1-REF(AAA1,1);
正大:=CROSS(入,买),NODRAW;
DIF:=(EMA(DCLOSE,10)-EMA(DCLOSE,72))/EMA(DCLOSE,72)*100;
DEA:=EMA(DIF,17);
AAA:=(DIF-DEA)*100;
牛股:=CROSS(AAA-REF(AAA,1),45),NODRAW;
正大牛股:=(正大 AND 牛股),NODRAW;
角线:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
角线MA:=MA(角线,5);
ANA:=PLOYLINE(CROSS(角线,角线MA),角线MA);
ANB:=PLOYLINE(CROSS(角线MA,角线),角线MA);
角买:=CROSS(角线,角线MA) AND ((ANB>REF(ANB,1) AND ANB>ANA AND 角线MA<=0) OR ((角线MA<=-45 OR CROSS(角线MA,-45)) AND (ANB<-60 OR LLV("KDJ.J",3)<=-49) AND ANB>0));
买点:=角买=1;
AA10:=MA(CLOSE,8);
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
均线30:=MA(CLOSE,30);
均线89:=MA(CLOSE,89);
均线:=MA(CLOSE,16);
天马:=((((((OPEN <= 均线) AND ((均线30 - REF(均线30,1)) > 0))
AND (CLOSE > 均线89)) AND (BB10 > 1)) AND ((CLOSE / OPEN) > 1.04)));
{股价必涨}
AA:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
BB:=MR AND NOT(REF(MR,1));
股价必涨:=(AA OR BB OR 角买点 OR 天马);
{抄底}
二十日换手率:=BETWEEN(SUM(HSCOL,20),10,200);{意思是 20日换手率介于10---100之间}
DFO:=(C-REF(C,1))/REF(C,1)*100<-5;
AAO:=BARSLAST(DFO);
突破:=CROSS(C,REF(O,AAO));
抄底:=(二十日换手率 AND 突破),NODRAW;
大牛:(正大牛股 AND 股价必涨),NODRAW;
必涨:(正大牛股 AND 抄底),,NODRAW;
大牛股:(大牛 AND 必涨 AND 抄底),NODRAW;
共同富裕:=大牛股 OR 大牛 OR 必涨,NODRAW;
A:=EMA(C,21);
B:=A>REF(A,1);
QN1:=MA(C,13);
QN:=ATAN((QN1-REF(QN1,1)))*180/2;
QN4:=QN>1 AND QN1>REF(QN1,1);
QN2:=MA(C,21);
QN3:=ATAN((QN2-REF(QN2,1)))*180/2;
LTP:=COUNT(C/REF(C,1)>1.098,10)>0 AND DYNAINFO(4)>0,NODRAW;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
第二回调线:=(1-7/100)*DD;
第二回调:(C<=第二回调线 AND LTP AND QN3>1 AND QN4 {AND J>=REF(J,5)})*2.5, COLORRED,NODRAW;
YT:=(第二回调>0 OR 共同富裕 OR ★集结号) ,NODRAW;
{DRAWGBK(ISLASTBAR AND (P=1 OR YT),RGB(30,30,30),RGB(30,30,30),0,' ',1);}
A1:="KD.K#DAY"(9,3,3);
A2:="KD.D#DAY"(9,3,3);
AA1:=(A1+A2)/2;
A3:="KD.K#WEEK"(9,3,3);
A4:="KD.D#WEEK"(9,3,3);
A5:="KD.K#MONTH"(9,3,3);
A6:="KD.D#MONTH"(9,3,3);
A7:="KDJ.J#WEEK"(9,3,3);
A8:="KD.K"(9,3,3);
A9:="KD.D"(9,3,3);
上面日K:A1,COLORYELLOW,NODRAW;
日D:A2,COLORYELLOW,NODRAW;
中间周K:A3,COLORWHITE,NODRAW;
周D:A4,COLORWHITE,NODRAW;
下面月K:A5,COLORGREEN,NODRAW;
月D:A6,COLORGREEN,NODRAW;
◎周J:A7,COLORWHITE,NODRAW;
{STICKLINE(C>0,-0.3 ,3 ,5 ,0 ),COLORWHITE;}
STICKLINE( A1>A2,2 ,3 ,5 ,0 ),COLOR650000;
STICKLINE( A1<A2,2 ,3 ,5 ,0 ),COLOR111111;
STICKLINE( A3>A4,2 ,0.5 ,5 ,0 ),COLOR650000;
STICKLINE( A3<A4,2, 0.5 ,5 ,0 ),COLOR111111;
STICKLINE( A5>A6,-0.3 ,0.5 ,5 ,0 ),COLOR650000;
STICKLINE( A5<A6,-0.3 ,0.5 ,5 ,0 ),COLOR111111;
STICKLINE( C>0,0.5 ,0.5 ,5 ,0 ),COLOR555555;
STICKLINE( C>0,2 ,2,10 ,0 ),COLOR555555;
K:=A8*3/120;
D:=A9*3/120;
J:=A7*3/120;
AA2:=AA1*3/120;
{A3*3/120;
A4*3/120;}
DRAWBAND(A3*3/120,RGB(250,00,250),A4*3/120,RGB(00,250,250));
DRAWTEXT(A3>=A4,J,'◎'),COLORFFFFFF;
DRAWTEXT(A3<A4,J,'◎'),COLOR00FFFF;
STICKLINE(K>D,K,D,5,1),COLORFFFF00;
STICKLINE(K<=D,K,D,5,1),COLORRED;
STICKLINE(C>0,1.25,1.25,3,0),COLOR555555;
{STICKLINE(C>0,AA2,AA2,2,0),COLOR00FFFF;};
STICKLINE(CROSS(穿,集结号) AND ZD2>=50 AND C<20 AND 去掉,0,2.5,1,0),COLORMAGENTA;
STICKLINE(CROSS(穿,集结号) AND ZD2<50 AND C<20 AND 去掉,0,0.5,4,1),COLORCYAN;
DRAWTEXT(CROSS(穿,集结号) AND ZD2<50 AND C<20 AND 去掉,0.5,' ★★号'),COLORCYAN;
DRAWTEXT(CROSS(穿,集结号) AND ZD2>=50 AND C<20 AND 去掉,2,' ★集结号'),COLORMAGENTA;
DRAWICON(大牛>0,3,1);
DRAWICON(必涨>0,1,3);
DRAWICON(大牛股>0,0,23);
DRAWBAND(第二回调,RGB(200,0,0),0,RGB(200,0,0));
STICKLINE(第二回调,0,2,1,1);

通达信借盘下棋指标公式

 

相关文章