在线检测未来函数

通达信水都观指标公式

来源:Internet,编辑:股旁网,2016-07-28

昨收:=REF(C,1);
最高价偏离:=ABS(H-昨收);
最低价偏离:=ABS(L-昨收);
高低偏离:=ABS(H-REF(L,1));
昨K线长:=ABS(昨收-REF(O,1));
稳定性测度:=IF(最低价偏离>高低偏离 AND 最低价偏离>最高价偏离,最低价偏离+最高价偏离/2+昨K线长/4,高低偏离+昨K线长/4);
强弱测度:=C+(C-O)/2-REF(C,1);
振动系数:=强弱测度/稳定性测度;
振动量:=振动系数*MAX(最高价偏离,最低价偏离);
振动线:=SUM(振动量,0);
均125:=EMA(振动线,125);
观音显圣:振动线>均125,COLORFF00FF, NODRAW;
均240:=EMA(振动线,240);
朝拜观音:FILTER(CROSS(振动线,均240),24),LINETHICK0,COLORYELLOW,NODRAW;
DRAWICON(朝拜观音,均125-0.10,9);
慈航普渡:均125>=REF(均125,1),COLORRED,NODRAW;
IF(慈航普渡,均125,DRAWNULL),COLORRED,LINETHICK2;
{IF(C,均125,DRAWNULL),COLOR004F00,LINETHICK1;}
STICKLINE(NOT(观音显圣),均125,振动线+(均125-振动线)*0.75,5,0),COLOR004F00;
STICKLINE(NOT(观音显圣),振动线+(均125-振动线)*0.75,振动线+(均125-振动线)*0.5,5,0),COLOR007600;
STICKLINE(NOT(观音显圣),振动线+(均125-振动线)*0.5,振动线+(均125-振动线)*0.25,5,0),COLOR00AD00;
STICKLINE(NOT(观音显圣),振动线,振动线+(均125-振动线)*0.25,5,0),COLOR00DE00;
STICKLINE(观音显圣,均125,均125+(振动线-均125)*0.25,5,0),COLORFA00FF;
STICKLINE(观音显圣,均125+(振动线-均125)*0.25,均125+(振动线-均125)*0.5,8,0),COLORFA50FF,LINETHICK3;
STICKLINE(观音显圣,均125+(振动线-均125)*0.5,均125+(振动线-均125)*0.75,8,0),COLORFA93FF,LINETHICK3;
STICKLINE(观音显圣,振动线,均125+(振动线-均125)*0.75,8,0),COLORFFCCFF;
均150:=EMA(振动线,150);
{IF(C,均150,DRAWNULL),COLOR88BBBB;}
均175:=EMA(振动线,175);
IF(C,均175,DRAWNULL),COLORFFCC00;
均200:=EMA(振动线,200);
IF(C,均200,DRAWNULL),COLOR777777;
均225:=EMA(振动线,225);
IF(C,均225,DRAWNULL),COLORBBBBBB;

通达信水都观指标公式

 

相关文章