在线检测未来函数

通达信无K线主图指标公式

来源:Internet,编辑:股旁网,2016-09-19

AQ:=O#MONTH;
B:=C#MONTH;
AA0:=H#MONTH;
BB0:=L#MONTH;
AA1:=REF(H#MONTH,1);
BB1:=REF(L#MONTH,1);
STICKLINE(B>=AQ,AA0,BB0,4,0),COLOR127248;
STICKLINE(B<AQ,AA0,BB0,4,0),COLOR722424;
ZX:=(6*C+2*O+H+L)/10;
NOTEXT1:ZX,COLORFFD0D0,LINETHICK2;
现价:DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3),COLORFFD0D0;
DRAWICON(ISLASTBAR=1 AND C>REF(C,1),C,38);
DRAWICON(ISLASTBAR=1 AND C<REF(C,1),C,39);
EBBI:=WMA(ZX,24);
月箱:=CROSS(ZX,EBBI) AND AA1-1.05*BB1>0 AND AA0-1.3*BB0<0 AND EVERY(BB0>=BB1,4) AND (AA1-ZX)>0.73*(AA1-BB1),NODRAW;
JU:=ABS(ZX-EBBI);
靠近:=JU<=LLV(JU,5);
加仓:=C>EBBI AND EXIST(月箱,10) AND REF(靠近,1) AND ZX>REF(ZX,1),COLORYELLOW;
DRAWICON(加仓,ZX,23);
DRAWICON(月箱,L,5);
VAR0:=REF(ZX,1);
VAR2:=(100-((80*(HHV(HIGH,16)-CLOSE))/(HHV(HIGH,16)-LLV(LOW,16))));
VAR3:=(100-MA(((100*(HHV(HIGH,8)-CLOSE))/(HHV(HIGH,8)-LLV(LOW,8))),48));
VAR12:=SMA(ABS(LOW-VAR0),13,1)/SMA(MAX(LOW-VAR0,0),10,1);
VAR13:=EMA(VAR12,10);
VAR14:=LLV(LOW,33);
VAR15:=EMA(IF(LOW<=VAR14,VAR13,0),3);
试买:=EXIST(VAR15>REF(VAR15,1),20) AND CROSS(VAR2,MA(VAR3,6));
DRAWTEXT(试买,L,'试买'),COLORMAGENTA;
上轨:=WMA(SMA(HHV(HIGH,16),4,1),2);
出轨:=HIGH>1.02*上轨 AND H=HHV(H,3);
落袋:=REF(出轨,1)=1 AND H<=REF(H,1) AND C<O;
DRAWICON(落袋,H,9);
DRAWTEXT(落袋,ZX,'落袋'),COLORWHITE;

通达信无K线主图指标公式

 

相关文章