在线检测未来函数

通达信庄股跟踪指标公式

来源:Internet,编辑:股旁网,2016-09-30

VA1:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VA2:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VA3:=VA1<REF(VA2,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
A:=WINNER(CLOSE+CLOSE*15/100)*100;
B:=WINNER(CLOSE+CLOSE*0/100)*100;
CC:=A-B;
D:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
E:=CC<3 AND D<0.5 AND OPEN!=LOW;
A1:=DYNAINFO(6);
A2:=IF(LOW>A1,0,IF(HIGH<A1,1,(A1-LOW+0.01)/(HIGH-LOW+0.01)));
A3:=VOL/WINNER(LOW);
A4:=REF(HHV(CLOSE,120),1);
A5:=REF(LLV(CLOSE,120),1);
A6:=100*(CLOSE-A5)/(A4-A5);
A7:=A2>0 OR A2=1;
A8:=A7 AND A3/REF(A3,3)>=3 AND A6<80;
A9:=REF(A8,1) OR REF(A8,2) OR REF(A8,3) OR REF(A8,4);
A10:=A8 AND A9;
A11:=IF(FILTER(A8,3),5,0);
A12:=IF(FILTER(A10,3) OR E,10,0);
T:=(COUNT(A8,30)>=3 AND COUNT(A10,30)>=3)*38;
STICKLINE(T,-0.025,0.025,8,0),COLORYELLOW;
MA5:=MA(CLOSE,5);
MA21:=MA(CLOSE,21);
MA65:=MA(CLOSE,65);
多头:=COUNT(MA21>MA65,10)=10;
GX:=MAX(MA5,MAX(MA21,MA65));
DX:=MIN(MA5,MIN(MA21,MA65));
粘合:=ABS(GX/DX-1)*100<=15;
多头粘合:=IF(多头 AND 粘合,2,0),COLORFF00FF,POINTDOT,NODRAW;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA1:=EMA(DIFF,9);
MACD1:=2*(DIFF-DEA1);
庄股:=COUNT(MACD1<0,10)=10,COLORFFFF00,POINTDOT,NODRAW;
目标:=IF(多头 AND 粘合 AND 庄股,5,0),COLORFFFFFF,LINETHICK2;
STICKLINE(目标,-0.025,0.025,8,0),COLOR0088FF;
N:=14;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>=REF(MACD,1),0,MACD,0,0),COLOR000099;
STICKLINE(MACD<REF(MACD,1),0,MACD,0,0),COLOR88FF55;
AO:DIF,COLORFFFFFF,LINETHICK1;
Q:=IF(AO>REF(AO,1),AO,DRAWNULL),COLORRED,LINETHICK1;
AO5:DEA,COLOR0099FF;
AC:MACD,COLOR00FF00,NODRAW;
N2:=3;
AA:=REF(AO,N2)=HHV(AO,2*N2+1);
BB:=BACKSET(AA,N2+1);
CCC:=FILTER(BB,N2) AND AO=HHV(AO,N2+1);
AA1:=BARSLAST(REF(CCC,1));
背离:=REF(CLOSE,AA1+1)<C AND REF(AO,AA1+1)>AO AND CCC;
DRAWICON(顶背离,0,2);
AA2:=REF(AO,N2)=LLV(AO,2*N2+1);
BB2:=BACKSET(AA2,N2+1);
CC2:=FILTER(BB2,N2) AND AO=LLV(AO,N2+1);
AB2:=BARSLAST(REF(CC2,1));
底背离:=REF(CLOSE,AB2+1)>CLOSE AND REF(AO,AB2+1)<AO AND CC2;
DRAWICON(底背离,0,1);
零轴:0,COLORRED;
进场:IF(A11>0,0.08,DRAWNULL),COLORFFFFFF,LINETHICK3,STICK;
加仓:IF(A12>0,0.08,DRAWNULL),COLOR0000FF,LINETHICK3,STICK;

通达信庄股跟踪指标公式

 

相关文章