在线检测未来函数

通达信慧华量指标公式

来源:Internet,编辑:股旁网,2016-10-11

虚:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚,0,(-1),(-1)),COLOR00C0C0;
实:VOL,VOLSTICK;
V5:MA(实,5),COLORWHITE;
V10:MA(实,10),COLORYELLOW;
V60:MA(实,60),COLORMAGENTA;
X_1:=REF(CLOSE,1);
X_2:=VOL<MA(VOL,60)/3 OR VOL<CAPITAL*0.005;
STICKLINE(VOL/REF(VOL,1)>=0.97 AND VOL/REF(VOL,1)<=1.03,VOL,0,0.85,0),COLORWHITE;
STICKLINE(CLOSE>OPEN AND REF(CLOSE,1)<REF(OPEN,1) AND HIGH<REF(OPEN,1) AND CLOSE<(REF(OPEN,1)-REF(CLOSE,1))/3+REF(CLOSE,1),VOL,0,0.57,0),COLORGREEN;
STICKLINE(OPEN>CLOSE AND CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>=REF(OPEN,1),VOL,0,0.57,0),COLORRED;
今夕比:实/REF(实,1),COLORYELLOW;
量比:实/MA(VOL,60),COLORMAGENTA;
量本比:10000*VOL/FINANCE(7),COLORRED;
买卖比:DYNAINFO(23)/DYNAINFO(22);
百低比:VOL/REF(LLV(VOL,100),1),NODRAW;
量能饱和度:IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))>1,1,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20)))*100,NODRAW,COLORYELLOW;
X_3:=1*AMOUNT;
X_4:=HHV(X_3,10)=X_3;
X_5:=HHV(X_3,30)=X_3;
X_6:=HHV(X_3,60)=X_3;
X_7:=HHV(X_3,100)=X_3;
X_8:=HHV(X_3,250)=X_3;
X_9:=X_4 OR X_5 OR X_6 OR X_7 OR X_8 AND CAPITAL/1000000<=35 AND CLOSE>REF(CLOSE,1);
STICKLINE(X_9,VOL,VOL*5/7,1.97,0),COLORYELLOW;
X_10:=VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND REF(VOL,2)>=REF(VOL,3) AND REF(VOL,3)>=REF(VOL,4) AND VOL>0;
X_11:=CLOSE>REF(OPEN,1) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,1)>=(REF(CLOSE,2)+REF(OPEN,2))/2 OR (REF(CLOSE,1)>=(REF(CLOSE,3)+REF(OPEN,3))/2 AND REF(CLOSE,3)>REF(OPEN,3)) AND HIGH>LOW);
STICKLINE(VOL<MA(VOL,60)*1/3,VOL,0,1.17,0),COLORMAGENTA;
X_12:=(OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5));
DRAWICON(VOL/REF(VOL,1)>1.95 AND VOL/REF(VOL,1)<=6 AND (CLOSE>OPEN OR (CLOSE<OPEN AND CLOSE>=REF(CLOSE,1))),VOL*1.0027,1);
DRAWICON(VOL/REF(VOL,1)>1.95 AND VOL/REF(VOL,1)<=2.02 AND (CLOSE>OPEN OR (CLOSE<OPEN AND CLOSE>=REF(CLOSE,1))),0,41);
DRAWICON(VOL/REF(VOL,1)<=0.51 AND HIGH>LOW,VOL*0.87,2);
STICKLINE(FILTER(VOL>REF(VOL,1) AND REF(VOL,1)>REF(VOL,2) AND CLOSE>OPEN,2),VOL,VOL*8/9,1.97,0),COLORMAGENTA;
STICKLINE(FILTER(VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2) AND HIGH>LOW,2),VOL,VOL*7/9,1.97,0),COLORBROWN;
X_13:=REF(VOL,6)>REF(VOL,5) AND REF(VOL,6)>REF(VOL,4) AND REF(VOL,6)>REF(VOL,3) AND REF(VOL,6)>REF(VOL,2) AND REF(VOL,6)>REF(VOL,1);
X_14:=REF(VOL,5)>REF(VOL,4) AND REF(VOL,5)>REF(VOL,3) AND REF(VOL,5)>REF(VOL,2) AND REF(VOL,5)>REF(VOL,1);
X_15:=REF(VOL,4)>REF(VOL,3) AND REF(VOL,4)>REF(VOL,2) AND REF(VOL,4)>REF(VOL,1);
X_16:=REF(VOL,6)/VOL>=0.97 AND REF(VOL,6)/VOL<=1.03;
X_17:=REF(VOL,5)/VOL>=0.97 AND REF(VOL,5)/VOL<=1.03;
X_18:=REF(VOL,4)/VOL>=0.97 AND REF(VOL,4)/VOL<=1.03;
DRAWICON(X_13 AND X_16 OR (X_14 AND X_17) OR (X_15 AND X_18),VOL*0.93,41);
DRAWICON((OPEN-CLOSE)/OPEN>=0.04 AND (VOL/MA(VOL,60)<=2/3 OR VOL/REF(VOL,1)<=1.15 OR VOL<HHV(VOL,5)),VOL*1.0158,39);
DRAWICON((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND (VOL<=MA(VOL,60) OR VOL/REF(VOL,1)<=1.2 OR VOL<HHV(VOL,5)) AND HIGH>LOW,VOL*1.0159,38);
DRAWICON(X_10 AND X_11,0,38);
DRAWICON(VOL<REF(LLV(VOL,100),1) AND HIGH>LOW,VOL*1.0359,23);
DRAWICON(COUNT(X_12,3) AND VOL<REF(LLV(VOL,20),1) AND HIGH>LOW,VOL*1.095,17);
X_19:=HHV(VOL,3)<REF(VOL,3);
X_20:=LLV(LOW,3)>REF(OPEN,3) AND REF(CLOSE,3)>REF(OPEN,3) AND CLOSE>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,3) AND REF(CLOSE,1)>REF(OPEN,3) AND HIGH>LOW AND CLOSE>OPEN;
X_21:=X_19 AND X_20;
DRAWICON(X_21,0,10);

通达信慧华量指标公式

 

相关文章