在线检测未来函数

通达信新涨停回马枪主图指标公式

来源:Internet,编辑:股旁网,2016-10-25

P1:=5;
P2:=10;
P3:=20;
P4:=30;
MA1:MA(C,P1);
MA2:MA(C,P2);
MA3:MA(C,P3);
MA4:MA(C,P4);
ZT:=(C/REF(C,1)-1)*100>9.5;
ZT1:=BARSLAST((C/REF(C,1)-1)*100>9.5);
最后涨停距今数:ZT1,NODRAW,COLORWHITE;
ZT2:=BARSLAST(ZT);
ZT3:=REF(H,ZT2)-REF(L,ZT2);
STICKLINE(C,(REF(L,ZT2)+ZT3*0.5),(REF(L,ZT2)+ZT3*0.5),7,0),COLORRED;
STICKLINE(C,REF(L,ZT2),REF(L,ZT2),2,0),COLORBLUE;
STICKLINE(ZT,O,C,2.6,0),COLOR0000E5;
STICKLINE(ZT,O,C,2.4,0),COLOR335555;
STICKLINE(ZT,O,C,1.8,0),COLOR338888;
STICKLINE(ZT,O,C,1.2,0),COLOR33AAAA;
STICKLINE(ZT,O,C,0.6,0),COLOR33CCCC;
STICKLINE(ZT,O,C,0.1,0),COLOR33EEEE;
{DRAWTEXT(BARSTATUS=2 AND ZT1>13,(REF(L,ZT2)+ZT3*0.5)*1.06,CON2STR(ZT1,0)),LINETHICK2,COLORYELLOW};
STICKLINE(ZT1=2,L*0.97,L*0.98,8,0),COLOR0000FF;
STICKLINE(ZT1=4,H*1.03,H*1.02,8,0),COLOR9966FF;
STICKLINE(ZT1=7,L*0.97,L*0.98,8,0),COLOR00FFFF;
STICKLINE(ZT1=12,H*1.03,H*1.02,8,0),COLORFF33FF;
DRAWTEXT(ZT1=1,H*1.06,'1'),COLORYELLOW;
DRAWTEXT(ZT1=2,H*1.06,'2'),COLORYELLOW;
DRAWTEXT(ZT1=3,H*1.06,'3'),COLORYELLOW;
DRAWTEXT(ZT1=4,H*1.06,'4'),COLORYELLOW;
DRAWTEXT(ZT1=5,H*1.06,'5'),COLORYELLOW;
DRAWTEXT(ZT1=6,H*1.06,'6'),COLORYELLOW;
DRAWTEXT(ZT1=7,H*1.06,'7'),COLORYELLOW;
DRAWTEXT(ZT1=8,H*1.06,'8'),COLORYELLOW;
DRAWTEXT(ZT1=9,H*1.06,'9'),COLORYELLOW;
DRAWTEXT(ZT1=10,H*1.06,'10'),COLORYELLOW;
DRAWTEXT(ZT1=11,H*1.06,'11'),COLORYELLOW;
DRAWTEXT(ZT1=12,H*1.06,'12'),COLORYELLOW;
DRAWTEXT(ZT1=13,H*1.06,'13'),COLORYELLOW;
DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:= EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
A1:= BARSLAST((C/REF(C,1)-1)*100>9.5);
A2:= IF(REF(L,A1)>REF(H,A1+1),REF(C,A1+1),REF(O,A1));
A3:= BETWEEN(A1,2,13);
A4:= C>=A2 AND BETWEEN(L/A2,1.035,0.97);
A5:= V<REF(V,1) AND V<MA(V,5);
A6:= ABS(C/O-1)*100<5;
A7:= LLV(C,A1)>=A2;
A8:= MACD>-1;
关注:=A3 AND A4 AND A5 AND A6 AND A7 AND A8;
A9:=MA(C,5)>=A2 AND C>A2 AND C>=MA(C,5) AND REF(C,1)<=REF(MA(C,5),1)
AND LLV(L,A1)<A2*1.045;
买入:=REF(A3,1)>0 AND A9;
STICKLINE(关注 AND NOT(ZT),O,C,2.4,0),COLOR550055;
STICKLINE(关注 AND NOT(ZT),O,C,1.8,0),COLOR880088;
STICKLINE(关注 AND NOT(ZT),O,C,1.2,0),COLORAA00AA;
STICKLINE(关注 AND NOT(ZT),O,C,0.6,0),COLORCC00CC;
STICKLINE(关注,O,C,0.1,0),COLOREE00EE;
STICKLINE(买入 AND NOT(ZT),O,C,2.4,0),COLOR000055;
STICKLINE(买入 AND NOT(ZT),O,C,1.8,0),COLOR000088;
STICKLINE(买入 AND NOT(ZT),O,C,1.2,0),COLOR0000AA;
STICKLINE(买入 AND NOT(ZT),O,C,0.6,0),COLOR0000CC;
STICKLINE(买入,O,C,0.1,0),COLOR0000EE;
跌停:=(C-REF(C,1))/REF(C,1)*100<-9.95;
STICKLINE(跌停,O,C,2.4,0),COLOR555500;
STICKLINE(跌停,O,C,1.8,0),COLOR888800;
STICKLINE(跌停,O,C,1.2,0),COLORAAAA00;
STICKLINE(跌停,O,C,0.6,0),COLORCCCC00;
STICKLINE(跌停,O,C,0.1,0),COLOREEEE00;

通达信新涨停回马枪主图指标公式

 

相关文章