在线检测未来函数

通达信各户能量指标公式

来源:Internet,编辑:股旁网,2016-10-25

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:(主力-均量),NODRAW;
大户能量:(大户-均量),NODRAW;
中户能量:(中户-均量),NODRAW;
散户能量:(散户-均量),NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),30,30+主力能量,3,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),30,30+主力能量,3,0),COLORYELLOW;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),30,30+主力能量,3,0),COLORGREEN;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),30,30+主力能量,3,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,30,30),'主力'),COLORRED;
操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),25,25+大户能量,3,0),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),25,25+大户能量,3,0),COLORYELLOW;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),25,25+大户能量,3,0),COLORGREEN;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),25,25+大户能量,3,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,25,25),'大户'),COLORYELLOW;
操盘2:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),20,20+中户能量,3,0),COLORRED;
减仓2:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),20,20+中户能量,3,0),COLORYELLOW;
反弹2:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),20,20+中户能量,3,0),COLORGREEN;
寻底2:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),20,20+中户能量,3,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(中户能量>=0,20,20),'中户'),COLORMAGENTA;
操盘3:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),15,15+散户能量,3,0),COLORRED;
减仓3:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),15,15+散户能量,3,0),COLORYELLOW;
反弹3:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),15,15+散户能量,3,0),COLORGREEN;
寻底3:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),15,15+散户能量,3,0),COLORBLUE;
DRAWTEXT(ISLASTBAR=1,IF(散户能量>=0,15,15),'散户'),COLORWHITE;

通达信各户能量指标公式

 

相关文章